Browser crash after using plugin

Help
2004-11-07
2013-05-13
1 2 > >> (Page 1 of 2)
  • Udo Ketschau
    Udo Ketschau
    2004-11-07

    I have a problem using mplayer plugin. The browser always crash if I use the plugin.
    The movies from a testground (plugger) is playing well with sound. After playing crash the browser.
    If the plugin compiled with the wrong gtk, it crashs before playing( I think it would be normal ).
    I have test mozilla and netscape with 3 variants of configure. Below mentioned I have list what I do.
    Lines with # means my comment.

    Someone can help? Maybe it is the same problem like discussed in thread "ksandre 2004-09-10 17:28" ?

    Greetings Udo

    Debian sarge kernel :2.6.8-7
    gcc version 3.2.3 (Debian)

    MPlayer 1.0pre5-3.2.3 (C) 2000-2004 MPlayer Team
    mplayerplug-in-2.70.tar

    Mozilla 1.7.3
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041007 Debian/1.7.3-5

    Netscape 7.1
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624 Netscape/7.1

    **************************************************
    $./configure --enable-x

    # Carry out a test:
    $/mplayer/mplayerplug-in$ /usr/local/netscape/netscape
    # Now access movie on plugger testground.

    # Browser output:
    ----player thread: Movie downloaded
    # Browser crash after playing movie.

    # Next attempt
    $/mplayer/mplayerplug-in$ /usr/lib/mozilla/mozilla-bin
    # Now access movie on plugger testground.

    # Browser output:
    segmentation fault
    # Browser crash after playing movie.

    **************************************************
    $./configure ......

    # Next attempt
    $/mplayer/mplayerplug-in$ /usr/lib/mozilla/mozilla-bin
    # Now access movie on plugger testground.

    # Browser output:
    Unknown Mozilla toolkit (136794240), assuming toolkit is GTK2
    This may cause Mozilla to crash. If it crashes recompile mplayerplug-in with a different toolkit.
    segmentation fault

    # Browser crash after playing movie.

    **************************************************

    # Next attempt
    $ /usr/local/netscape/netscape
    # Now access movie on plugger testground.

    # Browser output:
    Unknown Mozilla toolkit (137927392), assuming toolkit is GTK2
    This may cause Mozilla to crash. If it crashes recompile mplayerplug-in with a different toolkit.

    #Browser crash immediately bevore playing movie.

    ***************************************************
    $./configure --enable-gtk1  ........

    # Next attempt
    $ /usr/local/netscape/netscape

    # Now access movie on plugger testground.

    # Browser output:
    Gtk-CRITICAL **: file gtkwidget.c: line 3824 (gtk_widget_set_events): assertion `!GTK_WIDGET_REALIZED (widget)' failed.

    # Browser crash after playing.
    **************************************************
    # Next attempt
    $ /usr/lib/mozilla/mozilla-bin

    # Now access movie on plugger testground.

    # Browser output:
    Unknown Mozilla toolkit (144576064), assuming toolkit is GTK1
    This may cause Mozilla to crash. If it crashes recompile mplayerplug-in with a different toolkit.
    # ......... Lot of error messages
    #Browser crash immediately bevore playing movie.

     
    • Kevin DeKorte
      Kevin DeKorte
      2004-11-07

      When you have a browser crash before playing the movie it is a problem with the widget toolkit match. Just like the error message is telling you.

      As for the browser crashing after the movie is complete. I'm not sure what is causing that as I cannot duplicate it on my FC2 box. A backtrace of the crash would be helpful. Run mozilla with the -g option to enable the debugger and the type bt when it crashes and post that here.

       
      • Udo Ketschau
        Udo Ketschau
        2004-11-07

        If I start mozilla with -g I get no more output. Maybe I do somthing wrong. But I have enabeled debug=1 in /etc/mplayerplug-in.conf.  The whole output has 50k. I would send it to your email. Here a short abstract:
        .......
        READ: Falling back on default (hardcoded) input config
        READ:
        READ: Playing /tmp/mplayHkr1Xv.
        READ: MPEG-ES file format detected.
        READ: VIDEO:  MPEG1  320x240  (aspect 1)  25,000 fps  6553,2 kbps (819,1 kbyte/s)
        READ: vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0.0" => local display)
        READ: Disabling DPMS
        READ: ==========================================================================
        READ: Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
        READ: VDec: vo config request - 320 x 240 (preferred csp: Mpeg PES)
        .........
        V:  48,4  1210   2%  3%  0,0% 0 0 0%
        V:  48,4  1211   2%  3%  0,0% 0 0 0%
        V:  48,4  1211   2%  3%  0,0% 0 0 0%
        READ: Successfully enabled DPMS
        READ: 
        READ: Exiting... (End of file)
        ----player thread: breaking read loop - Exiting
        ----player thread: tryagain = 0

        # This is the last entry before crash.

         
    • Kevin DeKorte
      Kevin DeKorte
      2004-11-07

      Also, can you try the code in CVS and see if it works any better?

       
      • Udo Ketschau
        Udo Ketschau
        2004-11-07

        I have this never done before, but I will try it.

         
      • Udo Ketschau
        Udo Ketschau
        2004-11-10

        I have try it now. But the same problem. The browser crash's after playing the movie. (File plugin-threads.cpp Line 1396 function playNode if return was execute.)

         
        • Kevin DeKorte
          Kevin DeKorte
          2004-11-10

          My mistake is that mozilla does not support a debugger with the -g command line option. Can you install firefox and run it like this

          firefox -g

          at gdb prompt type:  run

          duplicate the crash

          at the gdb prompt type: bt

          and send me the results of that.

          Thanks,

          Kevin

           
          • Udo Ketschau
            Udo Ketschau
            2004-11-10

            No luck today.  I have installed 2 versions of firefox (US, DE). If I start with firexox -g and type run at gdb prompt no browser window opend. Some mistake? (I send the output to your email)
            If I start firefox without -g I get a little bit more output after crash:
            ..........
            READ: Exiting... (End of file)

            ----player thread: breaking read loop - Exiting
            ----player thread: tryagain = 0
            ./run-mozilla.sh: line 72:  7161 Speicherzugriffsfehler  "$prog" ${1+"$@"}

            # Speicherzugriffsfehler = segmentation fault

             
            • Kevin DeKorte
              Kevin DeKorte
              2004-11-10

              Is the version of mplayer you use, using the EN or DE messages? If it is the DE then could you install the EN one? There might be a problem with mplayer not properly receiving the shutdown message.

               
              • Udo Ketschau
                Udo Ketschau
                2004-11-11

                I have recompiled the mplayer tarball with
                $ locale
                LANG=en_US.ISO-8859-15
                LC_CTYPE="en_US.ISO-8859-15"
                LC_NUMERIC="en_US.ISO-8859-15"
                LC_TIME="en_US.ISO-8859-15"
                LC_COLLATE="en_US.ISO-8859-15"
                LC_MONETARY="en_US.ISO-8859-15"
                LC_MESSAGES="en_US.ISO-8859-15"
                LC_PAPER="en_US.ISO-8859-15"
                LC_NAME="en_US.ISO-8859-15"
                LC_ADDRESS="en_US.ISO-8859-15"
                LC_TELEPHONE="en_US.ISO-8859-15"
                LC_MEASUREMENT="en_US.ISO-8859-15"
                LC_IDENTIFICATION="en_US.ISO-8859-15"
                LC_ALL=en_US.ISO-8859-15

                LANGUAGE=en_US.ISO-8859-15

                The error is the same in english:

                ..........
                READ: Exiting... (End of file)

                ----player thread: breaking read loop - Exiting
                ----player thread: tryagain = 0
                ./run-mozilla.sh: line 72: 10307 Segmentation fault      "$prog" ${1+"$@"}

                 
                • Kevin DeKorte
                  Kevin DeKorte
                  2004-11-12

                  Well unfortunately none of the info you have sent me is helping so far. Are you sure the compiler used on mozilla (about:buildconfig) and the compiler used on mplayerplug-in are close?

                  Another thing maybe to check is that you glibc and and kernel versions are using the same threading model? All of these are just guesses. Without the gdb backtrace I really can't even guess where it is failing.

                   
                  • Udo Ketschau
                    Udo Ketschau
                    2004-11-13

                    I have reinstalled gdb. Now it work. I send you the output of bt to your email.

                     
    • Udo Ketschau
      Udo Ketschau
      2004-11-11

      Addendum to errormessage:

      The exitcode is 139.

      Maybe it helps a little bit.

       
    • Kevin DeKorte
      Kevin DeKorte
      2004-11-16

      I got your email with the backtrace and after looking at it, it looks like your glibc is crashing. Not much I can do with that.

       
      • Udo Ketschau
        Udo Ketschau
        2004-11-17

        Bad news. But thank so for help. I think I must wait for debian sarge stable, because a downgrade of libc6 is not possible without destroying the whole system.

         
    • Barry Ries
      Barry Ries
      2004-12-28

      Seems to be a 2.6 issue. It works fine when I boot into 2.4 mode. Yet it crashes after playback on 2.6.7 (Mepis 2004.6 dec 2004 release).

      I've tried it on all version from 2.66 to 2.75 and it always blows up after playback.

       
      • Kevin DeKorte
        Kevin DeKorte
        2004-12-28

        Must be some other error as I develop mplayerplug-in on Fedora 2 and Fedora 3 machines where the 2.6 kernel is used. I don't even have a 2.4 kernel on my machines. Also, I believe that mepis ships with mplayerplug-in installed. Does that one work?

         
    • Emily Dai
      Emily Dai
      2005-01-26

      I use mozilla 1.6 and it crash when I try to go back. Here is the error message I got:
      mimetype: application/x-mplayer2
      Embedded mode
      Argument Name: height
      Argument Value: 240
      Argument Name: width
      Argument Value: 320
      Argument Name: ,
      Argument Value:
      Argument Name: src
      Argument Value: http://images.linspire.com/file_types/clips.wmv
      New window! old: 0x0    new 0x2600001
      Size: 5 244 2600001
      Size: 320x240
      resizing widgets to 320 x 240
      back in SetWindow
      New Size: 320x240
      resizing widgets to 320 x 240
      resizing widgets to 320 x 240
      exiting URL base with http://images.linspire.com/file_types/
      ready to setup threads
      creating thread - NP_EMBED
      creating player thread
      In launchPlayerThread, state = 110
      ----player thread: in playPlayList
      ----player thread: about to go to sleep, js_state = 6, state = 110
      MAIN THREAD DONE
      exiting URL base with http://images.linspire.com/file_types/
      signalling player from write
      Signalling Player thread, state = 110, js_state = 6
      ---player thread: got wakeup signal, js_state = 6, state = 115
      ----player thread: playPlayList - waiting complete
      ----player thread: building command string
      Destroy stream found a URL match
      http://images.linspire.com/file_types/clips.wmv
      http://images.linspire.com/file_types/clips.wmv
      calling buildPlaylist with filename /tmp/mplayI7eUNw
      Scanning for speed
      low = 0, med = 0, high = 0
      playlist adjustment complete
      PLAY 0:mplayer
      PLAY 0:-wid
      PLAY 0:0x2600001
      PLAY 0:-xy
      PLAY 0:320
      PLAY 0:-cache
      PLAY 0:1024
      PLAY 0:-vo
      PLAY 0:x11
      PLAY 0:-zoom
      PLAY 0:-osdlevel
      PLAY 0:0
      PLAY 0:-nojoystick
      PLAY 0:-slave
      ----player thread: local_list =  0x8ade418
      PL URL: http://images.linspire.com/file_types/clips.wmv
      play = 1, cancelled= 0
      next= (nil)
      ----player thread: entering loop
      ----player thread: looking for node to play
      ----player thread: chose url http://images.linspire.com/file_types/clips.wmv
      ----player thread: playing url: http://images.linspire.com/file_types/clips.wmv
      ----player thread: URL: http://images.linspire.com/file_types/clips.wmv
      Starting: mplayer -wid 0x2600001 -xy 320 -cache 1024 -vo x11 -zoom -osdlevel 0 -nojoystick -slave -nomouseinput /tmp/mplayI7eUNw
      redrawing window
      READ: MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team

      READ: CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 4)

      READ: Detected cache-line size is 64 bytes

      READ: CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

      READ: Compiled with runtime CPU detection - WARNING - this is not optimal!

      READ: To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

      READ:

      READ:

      READ: Setting up LIRC support...

      READ: mplayer: could not connect to socket

      READ: mplayer: No such file or directory

      READ: Failed to open LIRC support.

      READ: You will not be able to use your remote control.

      READ: Playing /tmp/mplayI7eUNw.

      READ: ASF file format detected.

      READ: VIDEO:  [WMV1]  256x192  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)

      READ: Clip info:

      READ:  name: CODEC Shootout

      READ:  author: Hallau Shoots & Company

      READ:  copyright: 2000, Hallau Shoots & Company

      READ:  comments: Windows Media 7 compressed for a 500k connection

      READ: ==========================================================================

      READ: Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders

      READ: AUDIO: 44100 Hz, 1 ch, 16 bit (0x10), ratio: 4006->88200 (32.0 kbit)

      READ: Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))

      READ: ==========================================================================

      READ: vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)

      READ: ==========================================================================

      READ: Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family

      READ: Selected video codec: [ffwmv1] vfm:ffmpeg (FFmpeg M$ WMV1/WMV7)

      READ: ==========================================================================

      READ: Checking audio filter chain for 44100Hz/1ch/16bit -> 44100Hz/2ch/16bit...

      READ: AF_pre: af format: 2 bps, 1 ch, 44100 hz, little endian signed int

      READ: AF_pre: 44100Hz 1ch Signed 16-bit (Little-Endian)

      READ: [AO ARTS] Connected to sound server.

      READ: [AO ARTS] Stream opened.

      READ: [AO ARTS] buffer size: 20480

      READ: [AO ARTS] buffer size: 2048

      READ: AO: [arts] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)

      READ: Building audio filter chain for 44100Hz/1ch/16bit -> 44100Hz/2ch/16bit...

      READ: Starting playback...

      READ: VDec: vo config request - 256 x 192 (preferred csp: Planar YV12)

      READ: VDec: using Planar YV12 as output csp (no 0)

      READ: Movie-Aspect is undefined - no prescaling applied.

      READ: VO: [x11] 256x192 => 320x240 Planar YV12  [zoom]

      ----player thread: panel height in thread = 0
      redrawing window
      READ: SwScaler: using unscaled Planar YV12 -> BGRA special converter

      ANS_LENGTH=432 V:   3.1 A-V:  0.104 ct:  0.000   1/  1 ??% ??% ??,?% 0 0 98%

      A:   3.4 V:   3.4 A-V: -0.020 ct: -0.021  12/ 12 ??  ??% ??,?% 0 0 97%
      ANS_PERCENT_POSITION=17%

      A:   3.9 V:   3.9 A-V:  0.011 ct: -0.022  24/ 24 31   4%  2.0% 0 0 96%
      ANS_PERCENT_POSITION=2 -0.010 ct: -0.023  25/ 25 29%  4%  2.0% 0 0 95%

      ANS_PERCENT_POSITION=29 A-V: -0.021 ct: -0.025  26/ 26 29%  4%  1.9% 0 0 95%

      A:   4.4 V:   4.4 A-V:  0.010 ct: -0.008  39/ 39 21   4%  1.4% 0 0 94%
      ANS_PERCENT_POSITION=3 -0.013 ct: -0.009  40/ 40 20%  3%  1.4% 0 0 93%

      ANS_PERCENT_POSITION=34 A-V:  0.012 ct: -0.008  41/ 41 20%  3%  1.4% 0 0 93%

      A:   4.8 V:   4.9 A-V: -0.038 ct: -0.010  54/ 54 16   3%  1.2% 0 0 92%
      ANS_PERCENT_POSITION=4 -0.025 ct: -0.012  55/ 55 16%  3%  1.2% 0 0 92%

      ANS_PERCENT_POSITION=49 A-V: -0.047 ct: -0.015  56/ 56 16%  3%  1.2% 0 0 92%

      A:   5.3 V:   5.4 A-V: -0.039 ct: -0.018  69/ 69 14   3%  1.1% 0 0 90%
      ANS_PERCENT_POSITION=6 -0.038 ct: -0.021  70/ 70 14%  3%  1.0% 0 0 90%

      ANS_PERCENT_POSITION=64 A-V:  0.011 ct: -0.020  71/ 71 14%  3%  1.1% 0 0 90%

      A:   5.8 V:   5.9 A-V: -0.029 ct: -0.024  84/ 84 12   3%  1.2% 0 0 88%
      ANS_PERCENT_POSITION=7  0.031 ct: -0.021  85/ 85 12%  3%  1.2% 0 0 88%

      ANS_PERCENT_POSITION=79 A-V:  0.032 ct: -0.017  86/ 86 12%  3%  1.1% 0 0 88%

      A:   6.4 V:   6.4 A-V:  0.016 ct: -0.023  99/ 99 11   3%  1.1% 0 0 87%
      ANS_PERCENT_POSITION=9  0.029 ct: -0.020 100/100 11%  3%  1.1% 0 0 86%

      ANS_PERCENT_POSITION=94 A-V:  0.031 ct: -0.017 101/101 11%  3%  1.1% 0 0 86%

      A:   6.7 V:   6.8 A-V: -0.057 ct: -0.020 112/112 10   3%  1.0% 0 0 85%
      ANS_PERCENT_POSITION=9 -0.023 ct: -0.022 112/112 10%  3%  1.0% 0 0 85%

      ANS_PERCENT_POSITION=10 0.024 ct: -0.018 114/114 11%  3%  1.0% 0 0 85%

      ANS_PERCENT_POSITION=10 A-V: -0.018 ct: -0.018 115/115 10%  3%  1.0% 0 0 85%

      A:   7.2 V:   7.2 A-V: -0.017 ct: -0.027 124/124 10   3%  1.0% 0 0 83%
      ANS_PERCENT_POSITION=11-0.015 ct: -0.029 125/125 10%  3%  1.0% 0 0 83%

      ANS_PERCENT_POSITION=11 A-V: -0.013 ct: -0.030 126/126 10%  3%  1.0% 0 0 83%

      A:   7.7 V:   7.7 A-V: -0.006 ct: -0.033 139/139  9   3%  0.9% 0 0 82%
      ANS_PERCENT_POSITION=12-0.004 ct: -0.034 140/140  9%  3%  0.9% 0 0 82%

      ANS_PERCENT_POSITION=12 A-V: -0.015 ct: -0.035 141/141  9%  3%  0.9% 0 0 82%

      A:   8.3 V:   8.2 A-V:  0.073 ct: -0.036 154/154  9   3%  0.9% 0 0 81%
      ANS_PERCENT_POSITION=13 0.075 ct: -0.032 155/155  9%  3%  0.9% 0 0 81%

      ANS_PERCENT_POSITION=13 A-V:  0.088 ct: -0.029 156/156  9%  3%  0.9% 0 0 81%

      A:   8.7 V:   8.7 A-V: -0.033 ct: -0.012 169/169  9   3%  0.9% 0 0 78%
      ANS_PERCENT_POSITION=15-0.042 ct: -0.015 170/170  8%  3%  0.9% 0 0 78%

      ANS_PERCENT_POSITION=15 A-V: -0.030 ct: -0.018 171/171  8%  3%  0.9% 0 0 78%

      A:   9.2 V:   9.2 A-V: -0.011 ct: -0.040 184/184  8   3%  0.9% 0 0 76%
      ANS_PERCENT_POSITION=16-0.009 ct: -0.041 185/185  8%  3%  0.9% 0 0 76%

      ANS_PERCENT_POSITION=16 A-V:  0.004 ct: -0.040 186/186  8%  3%  0.9% 0 0 76%

      A:   9.6 V:   9.7 A-V: -0.104 ct: -0.076 199/199  8   3%  0.8% 0 0 75%
      ANS_PERCENT_POSITION=18-0.103 ct: -0.080 200/200  8%  3%  0.8% 0 0 74%

      ANS_PERCENT_POSITION=18 A-V: -0.102 ct: -0.083 201/201  8%  3%  0.8% 0 0 74%

      A:  10.2 V:  10.2 A-V: -0.048 ct: -0.102 214/214  8   3%  0.8% 0 0 73%
      ANS_PERCENT_POSITION=19-0.035 ct: -0.105 215/215  8%  3%  0.8% 0 0 73%

      ANS_PERCENT_POSITION=19 A-V: -0.022 ct: -0.108 216/216  8%  3%  0.8% 0 0 73%

      A:  10.8 V:  10.7 A-V:  0.068 ct: -0.117 229/229  8   3%  0.8% 0 0 71%
      ANS_PERCENT_POSITION=20 0.069 ct: -0.113 230/230  8%  3%  0.8% 0 0 71%

      ANS_PERCENT_POSITION=20 A-V:  0.082 ct: -0.110 231/231  8%  3%  0.8% 0 0 71%

      A:  11.1 V:  11.2 A-V: -0.062 ct: -0.118 244/244  7   3%  0.8% 0 0 70%
      ANS_PERCENT_POSITION=21-0.060 ct: -0.121 245/245  7%  3%  0.8% 0 0 70%

      ANS_PERCENT_POSITION=21 A-V: -0.058 ct: -0.125 246/246  7%  3%  0.8% 0 0 70%

      A:  11.8 V:  11.7 A-V:  0.065 ct: -0.097 259/259  7   3%  0.8% 0 0 69%
      ANS_PERCENT_POSITION=22 0.055 ct: -0.094 260/260  7%  3%  0.8% 0 0 68%

      ANS_PERCENT_POSITION=22 A-V:  0.056 ct: -0.090 261/261  7%  3%  0.8% 0 0 68%

      A:  12.2 V:  12.2 A-V:  0.039 ct: -0.074 273/273  7   3%  0.8% 0 0 67%
      ANS_PERCENT_POSITION=23 0.017 ct: -0.072 274/274  7%  3%  0.8% 0 0 67%

      ANS_PERCENT_POSITION=23 A-V:  0.030 ct: -0.069 275/275  7%  3%  0.8% 0 0 67%

      shut called
      A:  12.7 V:  12.6 A-V:  0.048 ct: -0.049 287/287  7%  3%  0.7% 0 0 66%

      READ: Exiting... (Quit)

      ----player thread: breaking read loop - Quit
      ----player thread: tryagain = 0
      ----player thread: playNode returned = 0
      ----player thread: close done
      ----player thread: transitioning to next item
      ----player thread: entering loop
      ----player thread: looking for node to play
      ----player thread: nothing on the list to play
      ----player thread: nothing to play
      ----player thread: callbacks complete
      ----player thread: normal exit
      Trying to kill mplayer process(26439), if it still exists
      mplayer dead
      Entering deleteList
      DELETE http://images.linspire.com/file_types/clips.wmv
      File to delete /tmp/mplayI7eUNw
      size: 1388366
      remove: 1
      play: 1
      playlist: 0
      speed: -1
      cancelled: 0
      retrieved: 1
      mms stream: 0
      cache bytes: 1048576
      Actual Size: 256x192
      Play Size: 320x240
      fname: /tmp/mplayI7eUNw deleted
      memory free
      ~nsPluginInstance called

       
      • Kevin DeKorte
        Kevin DeKorte
        2005-01-26

        please create a backtrace using gdb/ddd and post that. Instructions on how to do that should be above or in the mailing list archive

         
      • Kevin DeKorte
        Kevin DeKorte
        2005-01-29

        If you are using Debian and your glibc version is 2.3.2 you need to upgrade to at least 2.3.3 for mplayerplug-in to not crash.

         
    • M Silent One
      M Silent One
      2005-04-08

      I have 'crashing' problems with FC3 2.6.10-777 also
      Many video's will play.
      Some videos, after they finish, if I close the window the browser locks up.

      The news.bbc.co.uk video's lock my browser up when try try to fetch the stream from the site.

      Since the browser is locking up, not core dumping, it may be more difficult to grab a stack trace.

       
      • Kevin DeKorte
        Kevin DeKorte
        2005-04-08

        I have tested this with my machine and I don't experience any crashing. I would suggest that perhaps you should get a current version of mplayer. That may help.

        My test machine:
        Fedora Core 3 all uptodate
        firefox 1.0.2
        mplayerplug-in CVS basically 2.80
        mplayer CVS-050330 (basically 1.0pre6a)

         
    • M Silent One
      M Silent One
      2005-04-09

      Here is a stack trace

      I was trying to view a video file from the news.bbc.co.uk site
      I am using

      MPlayer 1.0pre6-3.4.2 (C) 2000-2004 MPlayer Team
      CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
      Detected cache-line size is 64 bytes
      CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
      Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

      mplayer-plug mplayerplug-in-2.80

      and firefox 1.0.2

      FC3, with the 2.6.10-777 kernel on a P4 ht, uniprocessor kernel

      #0  0x00dc67a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
      #1  0x00c95404 in poll () from /lib/tls/libc.so.6
      #2  0x002c50b4 in PR_Poll () from /usr/lib/firefox-1.0.2/libnspr4.so
      #3  0x00e7e5b4 in NSGetModule ()
         from /usr/lib/firefox-1.0.2/components/libnecko.so
      #4  0x00e7eaef in NSGetModule ()
         from /usr/lib/firefox-1.0.2/components/libnecko.so
      #5  0x001df930 in nsThread::Main () from /usr/lib/firefox-1.0.2/libxpcom.so
      #6  0x002c5fd3 in PR_Select () from /usr/lib/firefox-1.0.2/libnspr4.so
      #7  0x007fb341 in start_thread () from /lib/tls/libpthread.so.0
      #8  0x00c9efee in clone () from /lib/tls/libc.so.6

      http://news.bbc.co.uk/#

      Message is
      mplayer plug-in
      embeddedvideo player for mozilla

      Connecting to server wm.bbc.net.uk [212.58.240.196]:80 ...

      There is a status bar below

      If I attempt to close the window, the browser is dead.

       
      • Kevin DeKorte
        Kevin DeKorte
        2005-04-10

        The backtrace you sent does not show mplayerplug-in as being the component that crashes. So I would suggest you try a couple of things...

        Disable SELinux in the security panel.

        Experiment with the /etc/sysctl.conf files with these settings

        # Disable Exec-shield
        kernel.exec-shield = 0

        # Kernel config setting to make mach work
        kernel.vdso = 0

        # setting to fix wine and winex
        vm.legacy_va_layout = 1

         
    • junrenshi
      junrenshi
      2005-04-30

      I have the same problem of browser crashing after playing.  I am using Debian Sarge and firefox.   Some observations:

      (1) I suspect this is caused by subtle timing issue.  If I start the firefox by "strace -f mozilla-firefox", then everything will work just fine.

      (2) If I start the plugin in non-embeded mode, the browser will crash if I close the mplayer window AFTER closing the corresponding browser window where the plugin resides in.

      (3) If I press the stop button of the plugin befeore leaving the web page, then the browser will not crash.

       
1 2 > >> (Page 1 of 2)