Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

video and audio are OK but no mouse, controls

Help
2006-03-06
2013-05-13
  • Serge Matovic
    Serge Matovic
    2006-03-06

    Sorry for this probably stupid question: I compiled latest mplayerplug-in and mplayer from cvs, and it works great. But, clicking right mouse does nothing, nor do I get any control buttons displayed. What am I missing.
    Many thanks.
    serge.

     
    • Lars Tunkrans
      Lars Tunkrans
      2006-03-06

      I built mplayer plugin with the Gecko-SDK  
      and had it working with conltrols first time
      around.

        //Lars

       
    • Serge Matovic
      Serge Matovic
      2006-03-06

      Thank you Lars: Yes I had both: gecko-sdk from source and mozilla-devel from rpm installed.
      serge.

       
    • Kevin DeKorte
      Kevin DeKorte
      2006-03-07

      You need the gtk2 development kit installed. On Fedora this is the gtk2-devel package and on debian I believe it is libgtk2-dev or something like that. Configure should have warned you that X mode was enabled and that the features would be limited.

       
    • Serge Matovic
      Serge Matovic
      2006-03-07

      Thank you Kevin. After swetting all weekend over such a minor thing like this, I can only imagine what effort is required to write/maintain a major project like mplayerplug-in or similar !!!

      Any way, I do have libgtk+2.0_0-devel installed, and  configure for mplayerplug-in says:

      checking for gtk+-2.0... yes
      checking GTK_CFLAGS... -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
      checking GTK_LIBS... -L/usr/X11R6/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lfreetype -lfontconfig -lXrender -lX11 -lXext -lpng12 -lz -lm
      checking for gtk+-2.0 >= 2.4.0... yes
      checking GTK_CFLAGS... -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
      checking GTK_LIBS... -L/usr/X11R6/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lfreetype -lfontconfig -lXrender -lX11 -lXext -lpng12 -lz -lm

      Again, I'm sorry to bug you with this, but I'm stuck.

       
      • Kevin DeKorte
        Kevin DeKorte
        2006-03-07

        So I am confused, did you get it to work or not? If you didn't get it to work can you do this...

        make clean
        ./configure [with whatever options you need]
        make
        make install

         
    • Serge Matovic
      Serge Matovic
      2006-03-07

      No, it didn't work. But, then, I followed all the steps in your last post, i.e.

      $make clean
      $./configure
      $make
      #make install

      and, it WORKS now !!!

      The only difference here is the last command, i.e. #make install, which I didn't do before, but instead I copied all *.so and *.xpt to mozilla's plugins directory by hand. Was that the problem?

      Any way, many, many thanks Kevin.
      serge.

       
      • Kevin DeKorte
        Kevin DeKorte
        2006-03-07

        Interesting that make install would work and just copying the files into the right spot should have worked as well...

        Anyway, glad you got it working.

        Kevin