Re: message "Issue Check"

Help
ksandre
2004-09-18
2004-09-19
  • ksandre
    ksandre
    2004-09-18

    From: Kevin DeKorte  - Issue Check - 2004-09-17 15:04

    https://sourceforge.net/mailarchive/forum.php?thread_id=5591481&forum_id=21800

    "I would like to start preparing the code for release as the next version. As a  lot of features and fixes have went in.

    So far I am waiting to hear on status of

    Xinerama support with the gtk2 widgets
    gtk1 support (random crashes) ...."

    AND this message:

    From: Anton Solovyev - Still uncoditionally crahes with gtk1 - 2004-09-15 16:55

    https://sourceforge.net/mailarchive/forum.php?thread_id=5578808&forum_id=21800

    "...Gtk-WARNING **: invalid cast from `GtkSuperWin" to `GtkWidget"  New window! old: 0x0    new 0x2200001...."

    =====

    Currently I have upgraded to Mozilla-1.7.3 (with that gecko-sdk) and have been using mplayerplug-in-2.66 to avoid the constant crashes with the CVS version described in the my previousl thread.  Now [today], I am going to try CVS again and see if I can get a trace as you have requested.  (I get the same error, you will notice, as the ones described by Anton Solovyev in the messages thread listed above.)

    Just now, with 2.66 I get a crash [totally wipes out Mozilla] when going from a QT site to a flash site thus:

    from:

    http://www.apple.com/trailers/miramax/im_not_scared.html

    to:

    http://www.controlroommovie.com/site/01.html

    This is not new (it occured in previous versions of Mozilla too).

    Additionally, Real clips still play double (ie., two audio  and two tool bars on the bottom with NO controls showing).

    I know this does not get you what you need about the CVS version, but I will do that now.  (It is Saturday, 09/18/04 at 11:25 [15:25 GMT].)

    If I still get the same problems as I described in the previous thread- crashing at ALL sites with ALL media types-  I will do my best to figure out howto get you a trace for it.   (I have never done that before, but I guess I can figure it out from the details you have given elsewhere in these forums.)

    system:  Linux Kernel 2.4.27, XFree86 4.4.0, Mozilla-1.7.3, MPlayer-20040918 (with extra codecs "all-20040915" and Live.com 09/09/04), and mplayerplug-in-2.66, but wil do CVS next.  (Though I have not been able to update from SF in a few days - currently have 09/16/04 CVS.

     
    • ksandre
      ksandre
      2004-09-18

      ;>

      apropos CVS fetching problems:

      (  2004-09-17 10:27:57 - Project CVS Service )   As of 2004-09-17 there is a problem with the CVS host serving anonymous CVS, nightly tarballs and ViewCVS for projects that start with the letters m, n, p, q, t, y and z. We currently do not have an estimate on when they will be back up."

      http://sourceforge.net/docman/display_doc.php?docid=2352&group_id=1

       
    • ksandre
      ksandre
      2004-09-18

      With CVS dated 09/16/04 compiled with GTK1 Mozilla *always* crashes with *all* file types.  This is either AFTER playing the clip or when pushing the stop button then moving to another web location (or "back" or local directory).  By "crash," I mean that Mozilla totally disappears.

      I still think this is an MPlayer and/or [sometimes] ALSA related problem as I said before.  These crashes are new since around mid-August.  Before that, it all worked pretty well (it being MPlayer most notably).

      I will try now to coax a back trace if I can figure out how to do it.

      Here is the console remainder of the error message (there is really no change from the previous thread):

      Gdk-WARNING **: GdkWindow 0x800311 unexpectedly destroyed
      Gdk-WARNING **: GdkWindow 0x8002d5 unexpectedly destroyed
      Gdk-WARNING **: GdkWindow 0x8002d4 unexpectedly destroyed
      Gdk-WARNING **: GdkWindow 0x8002d0 unexpectedly destroyed

      Unknown Mozilla toolkit (1718576496), assuming toolkit is GTK1
      This may cause Mozilla to crash. If it crashes recompile mplayerplug-in
      with a different toolkit.

      Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'
      Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'
      Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'

      ADDED URL: im_not_scared_m240.mov
      code: 39
      speed 2800
      ADDED URL: im_not_scared_m240.mov
      code: 39
      speed 2800
      ADDED URL: im_not_scared_m320.mov
      code: 39
      speed 38400
      ADDED URL: im_not_scared_m320.mov
      code: 39
      speed 38400
      ADDED URL: im_not_scared_m480.mov
      code: 39
      speed 51200
      ADDED URL: im_not_scared_m480.mov
      code: 39
      speed 51200

      GetModeLine - scrn: 0 clock: 94500
      GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
                    vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
      GetModeLine - scrn: 0 clock: 94500
      GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
                    vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5

      /usr/local/lib/mozilla-1.7.3/mozilla/run-mozilla.sh: line 72:  2585
      Segmentation fault      "$prog" ${1+"$@"}

       
      • ksandre
        ksandre
        2004-09-18

        From: Kevin DeKorte
        https://sourceforge.net/mailarchive/message.php?msg_id=9565286
        Re: Issue Check 
        2004-09-18 18:11

        I"m going to respond to
        https://sourceforge.net/forum/message.php?msg_id=2765359

        here rather than in the forum as I prefer all of this be tracked in the  mailing list.

        I just downloaded mozilla 1.7.3 gtk1 and everything seems to be working well.

        ------

        Sorry I am not responding on the mailling list, but it is read-only and I am not a developer, so it would not be appropriate for me to join.

        Mozilla-1.7.3 and its gecko-sdk is exactly what I am using .

        I did manage to get gdb working (more or less) and tried several different clip types both local and from internet streams.  Basically they all look like this:

        -----< begin >------
        "I'm Not Scared" [apple.com]
        ============================

        A:  85.5 V:  85.5 A-V:  0.000 ct:  0.000  2054/2 53  25%  3%  9.5% 0 0 16%
        0 34%ANS_PERCENT_POSITION=0% 0 0 14%

        A:  86.1 V:  86.1 A-V:  0.000 ct:  0.000  2068/2068  25%  3   9.5% 0 0 2%%
        0 12%ANS_PERCENT_POSITION=0

        alsa-space: xrun of at least 30.567 msecs. resetting stream%  9.5% 0 0 0%0
        0 1%

        ANS_PERCENT_POSITION=05 A-V:  0.000 ct:  0.000  2078/2078  25%  3%  9.5% 0
        0 0%

        READ: A:  86.5 V:  86.5 A-V:  0.000 ct:  0.000  2078/2078  25%  3%  9.5% 0
        0 0%

        READ: alsa-uninit: pcm closed

        READ:

        READ: Exiting... (End of file)

        ----player thread: breaking read loop - Exiting
        ----player thread: tryagain = 0

        Program received signal SIGSEGV, Segmentation fault.
        [Switching to Thread 6151 (LWP 4807)]
        _IO_vfprintf (s=0xbedfbf10,
            format=0x3a410d25 <Address 0x3a410d25 out of bounds>, ap=0xbedfe610)
            at printf-parse.h:103
        103     printf-parse.h: No such file or directory.
                in printf-parse.h
        (gdb) bt
        #0  _IO_vfprintf (s=0xbedfbf10,
            format=0x3a410d25 <Address 0x3a410d25 out of bounds>, ap=0xbedfe610)
            at printf-parse.h:103
        #1  0x403b3270 in buffered_vfprintf (s=0x4047e1e0,
            format=0x3a410d25 <Address 0x3a410d25 out of bounds>, args=0xbedfe610)
            at vfprintf.c:2086
        #2  0x403ae9bf in _IO_vfprintf (s=0x4047e1e0,
            format=0x3a410d25 <Address 0x3a410d25 out of bounds>, ap=0xbedfe610)
            at vfprintf.c:1272
        #3  0x403b7867 in printf (format=0x3a410d25 <Address 0x3a410d25 out of
        bounds>)
            at printf.c:33
        #4  0x41258593 in playPlaylist (td=0x0) at Source/plugin-threads.cpp:1362

        (gdb) X connection to :0.0 broken (explicit kill or server shutdown).

        xinit:  connection to X server lost.

        waiting for X server to shut down .

        -----< end >-----

        NOTE:  Mozilla did not exactly crash as it does normally with debugging enabled.  It just locked solid and could not be closed.  (But I am pretty doubtful that I did the right thing as far as debugging goes.  I followed the instructions given here and in the forums.  I did change the "mozilla" script, though I did not find the exact stanza you quoted  in the other thread.)

        I ran eight different clips and they all came our as above.

        However, there are some other "issues" that showed up, and I will list them next. 

        Yes, I know that older versions of MPlayer did work, as I have happily been running MPlayer and mplayerplug-in without too much problem until around mid-August.   (Aside from MPlayer, codecs, and plugin updates - there was a new version of ALSA and upgrade to current Mozilla - and security patches here&there for other things.)

         
    • ksandre
      ksandre
      2004-09-18

      Also worthy of note is that the controls when the plugin was playing and after were non-functional.  Ultimately, they disappeared, leaving just an empty horizontal bar.

      It seems the debugger prevented Mozilla from disappearing as is the normal behavior.

       
    • ksandre
      ksandre
      2004-09-18

      And then, playing a clip locally, it failed to play but I got this, which seems to be relatd to mozilla:

      *****sendCommand Truncated*****
      Trying to kill mplayer process(5659), if it still exists
      mplayer dead
      Entering deleteList
      DELETE file:///usr/local/share/movies/mov/rendezvous.mov
      File to delete /tmp/mplayQGRMNH
      size: 5597452
      remove: 1
      play: 1
      playlist: 0
      speed: -1
      cancelled: 0
      retrieved: 1
      mms stream: 0
      cache bytes: 1399363
      Actual Size: 320x240
      Play Size: 320x240
      fname: /tmp/mplayQGRMNH deleted
      memory free
      ~nsPluginInstance called

      Gdk-WARNING **: GdkWindow 0x801771 unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x80176f unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x80176e unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x80176d unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x80176c unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x80176b unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x80176a unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x801752 unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x80172a unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x801729 unexpectedly destroyed

      Gdk-WARNING **: GdkWindow 0x801725 unexpectedly destroyed
      [tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
      [tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
      bt

      refusal to play - just jumps to stop button

      ============

      then "bt"
      nada
      then close mozilla

      after close mozilla:

      =====================

      Program received signal SIGSEGV, Segmentation fault.
      [Switching to Thread 1024 (LWP 5546)]
      0x414cb1d0 in ?? ()
      (gdb) bt
      #0  0x414cb1d0 in ?? ()
      #1  <signal handler called>
      #2  0x40429694 in __libc_write () at __libc_write:-1
      #3  0x400f2abc in __DTOR_END__ () from /lib/libpthread.so.0
      #4  0x4038fb14 in exit (status=0) at exit.c:60
      #5  0x4037c183 in Letext () at ../sysdeps/generic/libc-start.c:129
      (gdb)
      #0  0x414cb1d0 in ?? ()
      #1  <signal handler called>
      #2  0x40429694 in __libc_write () at __libc_write:-1
      #3  0x400f2abc in __DTOR_END__ () from /lib/libpthread.so.0
      #4  0x4038fb14 in exit (status=0) at exit.c:60
      #5  0x4037c183 in Letext () at ../sysdeps/generic/libc-start.c:129
      (gdb)
      #0  0x414cb1d0 in ?? ()
      #1  <signal handler called>
      #2  0x40429694 in __libc_write () at __libc_write:-1
      #3  0x400f2abc in __DTOR_END__ () from /lib/libpthread.so.0
      #4  0x4038fb14 in exit (status=0) at exit.c:60
      #5  0x4037c183 in Letext () at ../sysdeps/generic/libc-start.c:129
      (gdb) bt
      (gdb) bt
      #0  0x414cb1d0 in ?? ()
      #1  <signal handler called>
      #2  0x40429694 in __libc_write () at __libc_write:-1
      #3  0x400f2abc in __DTOR_END__ () from /lib/libpthread.so.0
      #4  0x4038fb14 in exit (status=0) at exit.c:60
      #5  0x4037c183 in Letext () at ../sysdeps/generic/libc-start.c:129
      (gdb)
      (gdb) quit

      The program is running.  Exit anyway? (y or n) + exitcode=0
      + moz_pis_startstop_scripts stop
      + MOZ_USER_DIR=.mozilla
      + MOZ_PIS_API=2
      + MOZ_PIS_MOZBINDIR=/usr/local/lib/mozilla-1.7.3/mozilla
      + MOZ_PIS_SESSION_PID=5525
      + MOZ_PIS_USER_DIR=.mozilla
      + export MOZ_PIS_API MOZ_PIS_MOZBINDIR MOZ_PIS_SESSION_PID
      MOZ_PIS_USER_DIR
      + '[' -x '/home/ksandre/.mozilla/init.d/K*' ']'
      + '[' -x '/usr/local/lib/mozilla-1.7.3/mozilla/init.d/K*' ']'
      + exit 0
      y

      =====

      I guess I should have let it keep running,  but I am really not sure that I was doing it right.

       
    • ksandre
      ksandre
      2004-09-18

      kdekorte said:

      "5. If you are seeing this:

      GetModeLine - scrn: 0 clock: 94500
      GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
                     vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5  "

      These riffs look like similiar messages I see in /var/log/XFree*.log sometimes, especially if xscreensaver is running and I have not turned off verbose mode.

      kdekorte said:

      " 3. This error: Unknown Mozilla toolkit (1718576496), assuming toolkit is GTK1
      This may cause Mozilla to crash. If it crashes recompile mplayerplug-in
      with a different toolkit. 

           Means the mozilla you are using is totally unsupported by me. I do not see
      this error with any official mozilla."

      But I am using Mozilla-1.7.3 - the one you said you just tried....

       
    • ksandre
      ksandre
      2004-09-19

      Sorry, but one last thing - because there is one glaring absence that I see here.  This is the start of debug:

      -----< begin >-----

      + eval 'set -- '
      ++ set --
      + moz_pis_startstop_scripts start
      + MOZ_USER_DIR=.mozilla
      + MOZ_PIS_API=2
      + MOZ_PIS_MOZBINDIR=/usr/local/lib/mozilla-1.7.3/mozilla
      + MOZ_PIS_SESSION_PID=5525
      + MOZ_PIS_USER_DIR=.mozilla
      + export MOZ_PIS_API MOZ_PIS_MOZBINDIR MOZ_PIS_SESSION_PID
      MOZ_PIS_USER_DIR
      + '[' -x '/usr/local/lib/mozilla-1.7.3/mozilla/init.d/S*' ']'
      + '[' -x '/home/ksandre/.mozilla/init.d/S*' ']'
      + '[' 1 = 1 ']'
      + echo /usr/local/lib/mozilla-1.7.3/mozilla/run-mozilla.sh -g
      /usr/local/lib/mozilla-1.7.3/mozilla/mozilla-bin
      /usr/local/lib/mozilla-1.7.3/mozilla/run-mozilla.sh -g
      /usr/local/lib/mozilla-1.7.3/mozilla/mozilla-bin
      + /usr/local/lib/mozilla-1.7.3/mozilla/run-mozilla.sh -g
      /usr/local/lib/mozilla-1.7.3/mozilla/mozilla-bin
      MOZILLA_FIVE_HOME=/usr/local/lib/mozilla-1.7.3/mozilla

      LD_LIBRARY_PATH=/usr/local/lib/mozilla-1.7.3/mozilla:/usr/local/lib/mozilla-1.7.3/mozilla/plugins:/usr
      /local/lib/mre/mre-1.7.3
      DISPLAY=:0.0
      DYLD_LIBRARY_PATH=/usr/local/lib/mozilla-1.7.3/mozilla:/usr/local/lib/mre/mre-1.7.3
          
      LIBRARY_PATH=/usr/local/lib/mozilla-1.7.3/mozilla:/usr/local/lib/mozilla-1.7.3/mozilla/components:/usr
      /local/lib/mre/mre-1.7.3
            
      SHLIB_PATH=/usr/local/lib/mozilla-1.7.3/mozilla:/usr/local/lib/mre/mre-1.7.3
               
      LIBPATH=/usr/local/lib/mozilla-1.7.3/mozilla:/usr/local/lib/mre/mre-1.7.3
             ADDON_PATH=/usr/local/lib/mozilla-1.7.3/mozilla
            MOZ_PROGRAM=/usr/local/lib/mozilla-1.7.3/mozilla/mozilla-bin
            MOZ_TOOLKIT=
              moz_debug=1
           moz_debugger=
      which: no ddd in
      (/bin:/usr/bin:/usr/local/bin:/usr/games:/usr/local/games:/usr/X11R6/bin:.)
      /usr/bin/gdb /usr/local/lib/mozilla-1.7.3/mozilla/mozilla-bin -x
      /tmp/mozargs5535
      GNU gdb 5.2
      Copyright 2002 Free Software Foundation, Inc.
      GDB is free software, covered by the GNU General Public License, and you
      are
      welcome to change it and/or distribute copies of it under certain
      conditions.
      Type "show copying" to see the conditions.
      There is absolutely no warranty for GDB.  Type "show warranty" for
      details.
      This GDB was configured as "i386-slackware-linux"...
      (no debugging symbols found)...

      ------< end >------

      "MOZ_TOOLKIT= " has nothing defined, I see.

      The ../mozilla/init.d/ direcotory above is empty except for the "README" that was distributed.  I have made no "init.d" in my $HOME/.mozilla/ directory.

      ------

      And yes, "ldd" on mozilla-bin does show Gtk1.

      libmozjs.so => /usr/local/lib/mozilla-1.7.3/mozilla/libmozjs.so (0x40021000)
              libplds4.so => /usr/local/lib/mozilla-1.7.3/gecko-sdk/bin/libplds4.so (0x400a1000)
              libplc4.so => /usr/local/lib/mozilla-1.7.3/gecko-sdk/bin/libplc4.so (0x400a4000)
              libnspr4.so => /usr/local/lib/mozilla-1.7.3/gecko-sdk/bin/libnspr4.so (0x400a9000)
              libpthread.so.0 => /lib/libpthread.so.0 (0x400de000)
              libdl.so.2 => /lib/libdl.so.2 (0x400f3000)
              libgtk-1.2.so.0 => /usr/local/lib/libgtk-1.2.so.0 (0x400f6000)
              libgdk-1.2.so.0 => /usr/local/lib/libgdk-1.2.so.0 (0x4021b000)
              libgmodule-1.2.so.0 =>
      /usr/local/lib/libgmodule-1.2.so.0 (0x4024d000)
              libglib-1.2.so.0 => /usr/local/lib/libglib-1.2.so.0 (0x40250000)
              libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x40272000)
              libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4027a000)
              libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40287000)
              libm.so.6 => /lib/libm.so.6 (0x40342000)
              libc.so.6 => /lib/libc.so.6 (0x40363000)
              /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

      I have no ldd "not found" errors with any libs in this mozilla version.

      Well, anyway.  I guess I really need to figure out how to use the "gdb" better.  Sorry for the lack of focus above.

      BTW, using "debug=1" in mplayerplug-in.conf did not seem to produce anything I could see and adding the "logfile=$HOME/mpp.log"  produced nothing.  (Though did I not see that option is now depreciated?)

      argh...  I will go away now.  I wish I could help more efficiently.  :)

       
    • ksandre
      ksandre
      2004-09-19

      From: Kevin DeKorte
      Re: Issue Check 

      https://sourceforge.net/mailarchive/message.php?msg_id=9568532

      2004-09-19 11:07

      Can all of you that are using GTK1 please send me the output of this command

      pkg-config gtk+ --modversion

      I get "1.2.10"

      =====

      Sorry, I missed this previously.  Yes, I get the same.

      I saw the rest of the message just now, and will join the m/l.

      =AuntTillie=
      ;>