Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

video buffers and does not play

Help
anton3s
2007-03-20
2013-05-13
  • anton3s
    anton3s
    2007-03-20

    When I visit a website with embedded video, the mplayerplug-in buffers the video and then stops.
    Clicking on the play button has no effect.

    I have turned on debugging for the plugin and got the following output:
    (copied the part I think is important)

    Starting: mplayer -wid 0x2800420 -vf scale=200:-3 -vo x11 -zoom -ao oss -osdlevel 1 -nojoystick -noconsolecontrols -cookies -softvol  -slave -user-agent NSPlayer -nomouseinput -nocache /tmp/mplayJAl4K6
    Getting file mode flags
    READ: execv: No such file or directory

    ----player thread: breaking read loop - execv failed
    ----player thread: tryagain = 0
    ----player thread: playNode returned = 0
    markPlayed
    marking http://fredrik.hubbe.net/plugger/test.mov as played

    I guess the problem is that the mplayerplug-in can not find the mplayer executable.
    This is probably due to the fact that I have installed mplayer in my homedirectory.

    This problem only occurs when I start firefox from the gnome window.
    When I start it from a terminal, everything works perfectly.

    The path to the mplayer executable is not in the PATH variable used by gnome (and it is in the PATH variable used by the terminal).
    So I guess I figured out what the problem is, but I don't know how to solve it.

    My question is:
    how can I add the path to my mplayer executable to the gnome PATH-variable (without having root access) ?
    OR
    how can I tell the mplayerplug-in where to look for the mplayer executable ?

    mplayerplug-in version 3.35
    mplayer 1.0rc-1
    firefox 1.5.0.7
    debian sarge

    thanks in advance,

    anton

    PS: I noticed some messages on this forum about the same symptoms, but I don't know if they are caused by the same problem,
    so I started a new thread

     
    • Kevin DeKorte
      Kevin DeKorte
      2007-03-20

      Definitely not a plug in issue. But you should be able to solve it pretty easily.

      For example if you have bash as your default shell (you can check it by running "finger {userid}")

      Add this line to the end of your .bash_profile

      PATH=$PATH:$HOME/mplayer

      Where $HOME/mplayer is the location of your mplayer binary. On my machine I have $HOME/bin and all my executables get installed into $HOME/bin.

      After you save that file, logout and log back in and it should work.

       
      • anton3s
        anton3s
        2007-03-20

        I tried that before (and I tried it again now) and it doesn't work.
        Gnome doesn't use the path that was set by bash.
        The changes in the bash startup scripts don't get through to gnome.

        By the way:
        I don't see why this is not a plugin issue.
        The plugin doesn't work because it can not find the mplayer executable and there is no way to specify where it has to look. (right?)
        (ok I see how you could classify it as a gnome-issue)

        but thanks anyway ;)

        anton

         
        • Kevin DeKorte
          Kevin DeKorte
          2007-03-20

          It looks in your path for mplayer. If you path is wrong then it won't find it.

          Gnome is not the problem either, the problem is your default shell not setting up the path. Set up your shell properly and it will work.