#85 No progress bar with >= 3.15

closed
Kevin DeKorte
Plugin (92)
5
2006-03-17
2005-12-26
Ville Skyttä
No

On my Fedora Core 5 test1 box with GTK2, Firefox 1.5, I
don't get any progress bar whatsoever while playing a
movie with mplayerplug-in >= 3.15. The progress bar
shows as expected in 3.11 and 3.05 in the same
configuration. hidestatus or showtime in
mplayerplug-in.conf don't seem to have any effect.

Discussion

  • Kevin DeKorte
    Kevin DeKorte
    2005-12-27

    Logged In: YES
    user_id=685413

    Works fine on FC4. Perhaps there is some problem when you
    compile it? When FC5 comes out I will be upgrading to it, so
    if there is a problem with it, it will be resolved.

     
  • Kevin DeKorte
    Kevin DeKorte
    2005-12-27

    • status: open --> closed
     
  • Ville Skyttä
    Ville Skyttä
    2005-12-27

    Compilation warnings from g++ 4.1.0

     
    Attachments
  • Ville Skyttä
    Ville Skyttä
    2005-12-27

    Logged In: YES
    user_id=32457

    Well, as said, the system is exactly the same when I'm
    trying to compile different versions of the plugin, so
    something in the plugin code most likely triggers the bug,
    wherever it is.

    FYI, attached is the list of warnings (plugin code only) I'm
    getting when compiling the plugin with g++ 4.1.0-0.12.

     
  • Kevin DeKorte
    Kevin DeKorte
    2005-12-27

    Logged In: YES
    user_id=685413

    Nothing in those warning should trigger the effect you are
    seeing most of those are errors from the mozilla package as
    well.

    If I have a chance I may set up a FC5 box, but no guarantees
    at this point.

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-01-11

    • assigned_to: nobody --> kdekorte
     
  • Ville Skyttä
    Ville Skyttä
    2006-03-17

    • status: closed --> open
     
  • Ville Skyttä
    Ville Skyttä
    2006-03-17

    Logged In: YES
    user_id=32457

    The exact same thing still happens on another box which has
    nothing (old was i386, this is x86_64, completely different
    hardware) to do with the one I used when I originally
    reported this.

    The only thing that's the same is that I'm running the
    plugin with firefox under KDE, and using the latest FC5 test
    version.

    With 3.11 I get a progress bar, with 3.21 not. Could the
    fact that I'm running under KDE affect this?

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-03-17

    • status: open --> closed
     
  • Kevin DeKorte
    Kevin DeKorte
    2006-03-17

    Logged In: YES
    user_id=685413

    I did some testing on FC5 with mplayerplug-in 3.21 and
    mplayer CVS and I did not see the problem you are seeing.
    Perhaps there is something wrong with the way you built
    mplayer. I would recommend upgrading to a version of mplayer
    from CVS as version 1.0pre7 has problems. I ran it under KDE
    and GNOME and had no issues either way.

     
  • Ville Skyttä
    Ville Skyttä
    2006-03-17

    Logged In: YES
    user_id=32457

    The mplayer packages I use are the ones from rpm.livna.org
    (FC5 not yet public, but will soon be). I highly doubt the
    mplayer build being at fault because things work properly
    with the older mplayerplug-in.

    Also, I'm wondering why this bug report was again closed
    without a resolution. That will effectively prevent folks
    who may be experiencing the same problem that I see or who
    may have solved it some way from noticing it and offering
    some insight in tracking the issue down.

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-03-17

    Logged In: YES
    user_id=685413

    It was closed cause there is no problem. The reason it
    probably works in older versions is that the way of getting
    the progress of the media was changed and it was changed in
    version 3.15. It was changed to a newer method that is
    supported by newer versions of mplayer. So if you upgrade
    you mplayer the problem will most likely be resolved.

    Do you have the version id of the mplayer from livna?

     
  • Ville Skyttä
    Ville Skyttä
    2006-03-17

    Logged In: YES
    user_id=32457

    Well, I disagree with "there is no problem", because there
    is a problem with the progress bar, and I'm running mplayer
    1.0pre7try2 which is the latest mplayer release, and newer
    than the minimum version mentioned in mplayerplug-in's docs
    (1.0pre5 on the homepage, 0.92 in README).

    Anyway, you're right, meanwhile I've backported the
    get_time_pos command to the livna mplayer package from CVS,
    and the progress bar works now.

    By the way, 3.21 still contains code to parse
    ANS_PERCENT_POSITION from mplayer, but the get_percent_pos
    command is never sent, so I guess that code could be just
    removed.

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-03-17

    Logged In: YES
    user_id=685413

    Think of this requirement as a push to get people on a
    recent mplayer. The version you have will also not support
    Apple HD trailers and has problems with other formats as
    well. Just because the progress bar does not work does not
    mean it is broken, it just means that functionality requires
    a higher version of mplayer. If it didn't play at all, that
    would be another issue. Mplayerplug-in alters itself alot to
    try an work with all the various versions that are out there
    of GTK and mplayer and X and mozilla. Usually, features are
    just disabled with older things.

    I know that code is in there. I left it in on purpose as
    there was always the option of switching it back. Which you
    could have done rather than hacking mplayer.

    mplayer 1.0pre7try3 which is the latest is over a year old.
    (try3 = try2 + a minor security fix). I have asked the
    mplayer developers to cut a new release due this this
    problem of "I have the latest" version but the general
    comment is, you can make a release anytime you want, just
    pull CVS. Personally I find that response unacceptable, but
    it is their product and they can do what they want. So I
    have to pass that response along.

    As for the minimum versions yes, you are correct. And I may
    change that info on the webpage. But I also state that the
    CVS version is highly recommended.

     
  • Ville Skyttä
    Ville Skyttä
    2006-03-18

    Logged In: YES
    user_id=32457

    I initially tried switching 3.21 to use the get_percent_pos
    method by reverting the changes that occurred between 3.14
    and 3.15 that broke the progress bar here, but the 5 minutes
    I spent with it didn't bring it back, and extracting
    get_time_pos from mplayer CVS was easy enough.

    And yes, I know the problems with the mplayer (non-)release
    process all too well already from personal experience.

    Sorry about the whining and thanks for your time, but I
    would have appreciated it if the information in your latest
    comment about some features possibly (and maybe knowingly)
    being non-functional with older mplayer versions would have
    been available somewhere before starting to take a closer
    look at this; it would have saved me quite a bit of time.