Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#63 Realplayer and mplayerplug-in-2.70 fight over Real streams

closed-fixed
nobody
None
5
2004-12-10
2004-12-07
Wilbur Pan
No

On a Gentoo Linux system, I use Firefox for browsing.
If I go to this NPR page:

http://www.npr.org/rundowns/rundown.php?prgDate=06-Dec-2004&prgId=3

and try to listen to audio using Realplayer 10, the
mplayerplug-in tries to play the Realaudio stream even
though I want Realplayer to play the stream. I've
played with taking out Real support and network support
out of mplayerplug-in-2.70 with Gentoo USE flags, and
by playing around with /etc/mplayerplug-in.conf, but to
no avail.

This is not an issue with mplayerplug-in-2.66.

Discussion

  • Kevin DeKorte
    Kevin DeKorte
    2004-12-09

    • status: open --> closed-works-for-me
     
  • Kevin DeKorte
    Kevin DeKorte
    2004-12-09

    Logged In: YES
    user_id=685413

    Local config error.
    Stop firefox
    Make sure you set enable-real=0 in the mplayerplug-in.conf
    file or comment out the line and then delete pluginreg.dat in
    $HOME/.mozilla and $HOME/.mozilla/firefox
    Start firefox
    about:plugins should not show mplayerplug-in associated with
    Real Media

     
  • Wilbur Pan
    Wilbur Pan
    2004-12-10

    • status: closed-works-for-me --> open-works-for-me
     
  • Wilbur Pan
    Wilbur Pan
    2004-12-10

    Logged In: YES
    user_id=795936

    I already tried the above suggestions before opening this
    bug. about:plugins shows that nphelix.so should be handling
    Real media streams, but mplayerplug-in-2.70 intercepts them
    anyway.

    This was not a problem with mplayerplug-in-2.66

     
  • Kevin DeKorte
    Kevin DeKorte
    2004-12-10

    Logged In: YES
    user_id=685413

    I see the problem now. Looks like npr is using SMIL. The problem is, that
    SMIL is not particular to realplayer, quicktime uses it to.. I guess I'll have
    to make a disable SMIL option. Or you can use the custom mime type
    option to work around it.

     
  • Kevin DeKorte
    Kevin DeKorte
    2004-12-10

    Logged In: YES
    user_id=685413

    Just committed a fix to CVS that has the following config option.
    enable-smil=1. You can set this equal to 0 in your mplayerplug-in.conf
    file and then clear the pluginreg.dat file and that should give you the
    features you want.

     
  • Kevin DeKorte
    Kevin DeKorte
    2004-12-10

    • status: open-works-for-me --> closed-fixed
     
  • Wilbur Pan
    Wilbur Pan
    2004-12-14

    Logged In: YES
    user_id=795936

    Thanks for the fix -- I'll wait for the next release of
    mplayerplug-in to test.