#142 mplayerplugin leaves zombies

open
nobody
None
5
2008-01-31
2007-11-21
dBera
No

View any embedded media files in firefox using Using mplayerplugin-3.45 and mplayer-1.0-1.rc1.20plf2008.0. After watching the video, move to a different webpage.

Notice that there are zombie processes (possibly of mplayer).

Possibly related discussion:
http://sourceforge.net/mailarchive/forum.php?thread_name=20071001144357.GA13036%40storm.local.network&forum_name=mplayerplug-in-devel

Discussion

  • Logged In: NO

    please upgrade your mplayer. I have seen this happen on several machines and usually a reinstall of mplayer fixes it.

     
  • Kevin DeKorte
    Kevin DeKorte
    2008-01-30

    • status: open --> closed
     
  • Logged In: NO

    Tested with the latest,
    [root@dbera debajyoti]# rpm -qa mplayer*
    mplayer-1.0-1.rc2.3plf2008.0
    mplayerplugin-3.45-1mdv2008.0

    Visited http://fredrik.hubbe.net/plugger/test.html

    [debajyoti@dbera kio-beagle]$ ps aux | grep mpla
    502 7897 6.6 6.6 67004 16568 ? SLs 20:42 0:02 mplayer -wid 0x3e1fc8f -vf scale=400:-3 -vo gl2 -ao alsa -osdlevel 3 -nojoystick -noconsolecontrols -cookies -softvol -slave -user-agent NSPlayer -nomouseinput -cache 2048 /home/debajyoti/tmp/mplayfRzmi2
    502 7906 0.0 0.9 43484 2308 ? S 20:43 0:00 mplayer -wid 0x3e1fc8f -vf scale=400:-3 -vo gl2 -ao alsa -osdlevel 3 -nojoystick -noconsolecontrols -cookies -softvol -slave -user-agent NSPlayer -nomouseinput -cache 2048 /home/debajyoti/tmp/mplayfRzmi2
    502 7917 0.0 0.2 3072 716 pts/2 R+ 20:43 0:00 grep --color=tty mpla

    Once the video is finished (this stays like this even after I move to a different webpage):

    [debajyoti@dbera kio-beagle]$ ps aux | grep mpla
    502 7897 6.7 0.0 0 0 ? Zs 20:42 0:03 [mplayer] <defunct>
    502 7921 0.0 0.2 3072 724 pts/2 R+ 20:43 0:00 grep --color=tty mpla

     
  • dBera
    dBera
    2008-01-31

    • status: closed --> open
     
  • dBera
    dBera
    2008-01-31

    Logged In: YES
    user_id=350837
    Originator: YES

    Reopening.
    Tested also with MPlayer 1.0-1.rc2.5mdv2008.1-4.2.2 which is the latest from mplayer. Problem exists. I started firefox from a console and found these debug messages:

    ---------------
    Cannot sync MAD frame.2 A-V: -0.643 ct: -0.042 303/303 10% 66% 4.5% 8 0 0%
    Cannot sync MAD frame.3 A-V: -0.643 ct: -0.051 304/304 10% 65% 4.5% 8 0 0%
    READ: A: 24.6 V: 25.3 A-V: -0.641 ct: -0.059 304/304 10% 65% 4.5% 8 0 0%
    READ:
    READ: Exiting... (End of file)
    ----player thread: breaking read loop - Exiting
    ----player thread: tryagain = 0
    ----player thread: playNode returned = 0
    markPlayed
    marking http://fredrik.hubbe.net/plugger/xvidtest.avi as played
    ----player thread: played = 1 - /home/debajyoti/tmp/mplayeQHBAM
    ----player thread: close done
    mmsstream = 0 errorcode = 0
    ----player thread: transitioning to next item
    ----player thread: entering loop. loop_count = -1
    ----player thread: looking for node to play
    ----player thread: play = 1 played = 1 entry = -1 fname = /home/debajyoti/tmp/mplayeQHBAM
    ----player thread: local_list is NULL loop_count = -1
    ----player thread: loop_count = -2 loop_single = 0
    ----player thread: nothing on the list to play
    ----player thread: nothing to play
    ----player thread: callbacks complete
    ----player thread: normal exit
    stop clickd
    in SetFullscreen with 0
    fullscreen = 0
    height = 300 and width = 400
    shut called
    shutdown called
    Trying to kill mplayer process(9114), if it still exists
    mplayer dead
    Window Cleaned up
    Entering deleteList
    DELETE http://fredrik.hubbe.net/plugger/xvidtest.avi
    File to delete /home/debajyoti/tmp/mplayeQHBAM
    size: 403456
    remove: 1
    play: 1
    played: 1
    playlist: 0
    speed: -1
    cancelled: 0
    retrieved: 1
    entry: -1
    mms stream: 0
    cache bytes: 2097152
    Actual Size: 400x250
    Play Size: 400x250
    fname: /home/debajyoti/tmp/mplayeQHBAM deleted
    memory free
    ~nsPluginInstance called

    ---------------------------------
    Note that the process 9114 mentioned above exists even after moving to a different page as a zombie (which is why it could not be killed).

     
  • Cerin
    Cerin
    2008-02-13

    Logged In: YES
    user_id=721519
    Originator: NO

    I'm not sure it's an identical problem, but I experience something similar. I'm on Fedora 8, and whenever I view media with mplayerplug-in in Firefox, and then close the tab, Firefox completely locks up until I kill the corresponding instance of mplayer running in the background. This isn't technically a zombie, since it's killable, but it's still annoying all the same.

     
  • Miklos Vajna
    Miklos Vajna
    2008-07-01

    Logged In: YES
    user_id=751546
    Originator: NO

    i can still reproduce this problem. :/

     
  • Hi,

    I'm using OpenBSD and I can confirm similar problem. Watching viedo and closing tab in firefox before movie ends (during mplayer is running) freezes the browser. You need to pkill(1) mplayer and browser is back to normal again.

    # pkg_info | grep mplayer
    mplayer-1.0rc2p8 movie player supporting MPEG, DivX, AVI, ASF, MOV & more
    mplayerplug-in-3.55 embedded video player for mozilla