#138 Quicktime crashes in mplayerplug-in ver 3.45

closed-works-for-me
Kevin DeKorte
Plugin (92)
1
2007-08-26
2007-08-14
Richard
No

Every quicktime movie trailer at apple.com crashes mplayerplug-in version 3.45.
To demonstrate, go to http://www.apple.com/trailers/independent/goyasghosts/
Play the "Trailer".

WMV, DIVX, and Real media play without issues.

I just reproduced this issue by downloading the source tar.gz and reinstalling.

The previous version that I had (3.31), packaged as Ubuntu "mozilla-mplayer" didn't crash but had very grainy video compared to downloading and playing it in the mplayer command line which was quite clear.

Audio has never been an issue.

I have the latest w32codecs installed.

-Richard (elk_88@yahoo.com)

Discussion

  • Kevin DeKorte
    Kevin DeKorte
    2007-08-19

    Logged In: YES
    user_id=685413
    Originator: NO

    Unable to duplicate the problem here with CVS in GTK2 mode. Can you please provide a log of the run by setting "debug=1" in the mplayerplug-in.conf file and then running firefox from a terminal and then duplicating the bug.

     
  • Kevin DeKorte
    Kevin DeKorte
    2007-08-22

    • status: open --> pending-works-for-me
     
  • Kevin DeKorte
    Kevin DeKorte
    2007-08-22

    Logged In: YES
    user_id=685413
    Originator: NO

    Switching to pending, due to non-response

     
  • Richard
    Richard
    2007-08-25

    Logged In: YES
    user_id=1867141
    Originator: YES

    Here is what I did to try to reproduce the previously reported crash.
    From scratch, I re-installed Ubuntustudio Linux 7.04 on my Shuttle SB61V40 and brought Linux completely up to date.
    The package mplayer (MPlayer 2:1.0~rc1-0ubuntu9.1) is included in the distribution.
    I downloaded the movie http://www.apple.com/trailers/independent/thelastwinter/.
    2007-08-24
    It plays fine on mplayer from the command line.
    When I try to play it in Firefox (I re-installed ) with mplayerplug-in, it no longer crashes but it is very grainy (ugly).
    The sound is fine; only the picture is subpar.
    Attached is a log (mplayerplug-in-3.45-log.txt) when running mplayerplug-in 3.45
    which I downloaded as an RPM from the mplayerplug-in site.

    When I replace mplayerplug-in with mozplugger (1.7.3-6ubuntu2), there is no graininess i.e. the picture is just as good
    as using the mplayer command line.
    File Added: mplayerplug-in-3.45-log.txt

     
  • Richard
    Richard
    2007-08-25

    See comments above marked 2007-08-24.

     
  • Richard
    Richard
    2007-08-25

    • status: pending-works-for-me --> open-works-for-me
     
  • Richard
    Richard
    2007-08-25

    Logged In: YES
    user_id=1867141
    Originator: YES

    Implemented qt-speed=high ("QT Speed: 3") ==> no difference in video quality.
    Thanks for your assistance.
    I guess that I'll stick to mozplugger for the moment.

     
  • Richard
    Richard
    2007-08-26

    • priority: 5 --> 1
    • status: open-works-for-me --> closed-works-for-me