Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#110 can't view archived games on mlb.com

closed-fixed
Kevin DeKorte
Plugin (92)
5
2006-08-22
2006-08-06
Tzadik
No

I have a subscription to mlb.com which allows me to
view both live and archived baseball games. The *live*
games work fine with mplayerplug-in. However, when I
try to view an *archived* game, I just see a screen
from mlb.com that says a commercial break is in
progress, which lasts forever.

I am able to view both archived and live games fine in
Windows.

I am willing to pay for a subscription to mlb.com if
necessary.

Discussion

<< < 1 2 (Page 2 of 2)
  • Tzadik
    Tzadik
    2006-08-07

    • status: pending-rejected --> open-rejected
     
  • Tzadik
    Tzadik
    2006-08-07

    Logged In: YES
    user_id=1569655

    It uses Flash to launch Windows Media streams. Once the
    Windows Media stream is launched, mplayer takes over. I
    forgot to tell you that you need to put:

    noembed=1

    in the mplayerplug-in.conf file. You also have to allow
    popups for mlb.com in Firefox.

    Flash is not the problem... the whole mlb site uses flash to
    launch Windows Media streams, and all the videos work fine
    for me except archived games.

    Once you do the "noembed" and popup adjustments, you should
    be able to play all the "free" content on the site, even
    though you don't have a subscription. For example, on the
    top of the home page, there is a flash animation that
    switches through various images, some of which have the word
    "play" with an arrow. (There are small pictures below the
    animation that let you go through all the images manually
    instead of waiting) When I click on "Play", the video works
    fine. (That does not seem to use mlayer... I guess it is
    just Flash, but it works)

    On the home page, right below that animation, there is a
    section called "Video". When you click on any of the links,
    it opens an "mplayer" window and plays the video just fine.

    As for the paid content, the live games are working fine,
    and they launch mplayer from a flash "launcher" window.

    So, it really does not seem that Flash is the issue.

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-08-07

    Logged In: YES
    user_id=685413

    So far, I still have not seen mplayerplug-in load...

    On the home page, when you click play, all the ones I have
    seen are all flash based. I'm going to need an exact link to
    see what you are seeing.

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-08-07

    Logged In: YES
    user_id=685413

    ok, I put a small patch in the code that may help with your
    problem. Give CVS a try or the daily code drop tomorrow

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-08-07

    • status: open-rejected --> pending-rejected
     
  • Kevin DeKorte
    Kevin DeKorte
    2006-08-07

    • status: pending-rejected --> pending-fixed
     
  • Logged In: YES
    user_id=1312539

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending-fixed --> closed-fixed
     
  • Tzadik
    Tzadik
    2007-01-04

    Logged In: YES
    user_id=1569655
    Originator: YES

    I have just discovered that there is actually no defect in mplayerplug-in. The message "commercial break is in progress" does in fact show for a long time when you view an archived game, but not "forever". That message is actually covering up the T.V. programming that occurred before the game. It varies from game-to-game, but it is usually around 10 - 15 minutes.

    I had originally contributed a patch (by email) to fix up the mms URL (changing "&amp;" to "&", etc), thinking that would help, which it didn't. However, I think that patch made it into the build. Please back it out... the URL should remain unchanged.

     
  • Kevin DeKorte
    Kevin DeKorte
    2007-01-04

    Logged In: YES
    user_id=685413
    Originator: NO

    Ok, I have disabled this code in CVS. However, the code actually looks like the right thing to do to me. So I have left it in, but commented out for now.

     
<< < 1 2 (Page 2 of 2)