#110 can't view archived games on mlb.com

closed-fixed
Kevin DeKorte
Plugin (92)
5
2006-08-22
2006-08-06
Tzadik
No

I have a subscription to mlb.com which allows me to
view both live and archived baseball games. The *live*
games work fine with mplayerplug-in. However, when I
try to view an *archived* game, I just see a screen
from mlb.com that says a commercial break is in
progress, which lasts forever.

I am able to view both archived and live games fine in
Windows.

I am willing to pay for a subscription to mlb.com if
necessary.

Discussion

1 2 > >> (Page 1 of 2)
  • Kevin DeKorte
    Kevin DeKorte
    2006-08-06

    Logged In: YES
    user_id=685413

    Please send a debug log of the problem site.

    1. Set debug=1 in the mplayerplug-in.conf file
    2. Close all instances of your browser
    3. Open a terminal
    4. Start your browser in terminal window
    5. Open the media at the problem site.
    6. You should see a lot of text come out
    7. Attach that text to this bug

     
  • Tzadik
    Tzadik
    2006-08-06

    debug file - archived game (does not work)

     
    Attachments
  • Tzadik
    Tzadik
    2006-08-06

    Logged In: YES
    user_id=1569655

    I noticed that the debug file for the archived games (which
    do *not* work) includes URLs that contain "&" which
    seems strange for a URL. By contrast, the debug file for
    the live games (which *do* work) do not contain any "&"
    sequences.

    I went onto Windows and ran a protocol analyzer while
    viewing an archived game (they play fine on Windows). I
    noticed URLs in the log that sometimes contained "&" and
    other ones (later in the log) which are the same except for
    "&" being replaced by "&" (which produces a URL that
    looks much more normal). I also found some XML tags in the
    log. That would lead me to believe that the "&"
    sequences are URLs embedded in XML. Perhaps mplayerplug-in
    is picking these up without resolving the XML escape
    sequences. Just a theory.

     
  • Tzadik
    Tzadik
    2006-08-06

    debug file - live game (does work)

     
    Attachments
  • Tzadik
    Tzadik
    2006-08-06

    Logged In: YES
    user_id=1569655

    1 additional point... in the debug files (on Linux) for the
    archived games, I *never* see URLs that contain just "&"...
    they always have "&". (Whereas on Windows, the analyzer
    log file contains some with "&" and some with the same
    URL, except "&" is replaced by "&".)

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-08-06

    Logged In: YES
    user_id=685413

    Can you post the logs so I can see what you are seeing. If
    what you are saying is correct, then this should be pretty
    easy to correct. I just need to verify the issue.

     
  • Tzadik
    Tzadik
    2006-08-06

    2 log files from protocal analysis on windows -- see comment

     
    Attachments
  • Tzadik
    Tzadik
    2006-08-06

    Logged In: YES
    user_id=1569655

    I did another run of the Ethereal protocol analyzer on
    Windows. The tar.gz file has 2 files, both of which are the
    output of the protocol analyzer while I was watching an
    archived game (the same game in the mplayer debug logs)
    successfully.

    #1) ethereal.out.arch-just-start
    I simply started the game and played it from the beginning

    #2) ethereal.out.arch-start-then-jump
    I started the game and played it for a few seconds, then I
    used the "jump to inning" feature of the mlb.com site to
    jump to a later part of the game.

    In both files, you can search for "072406_nyatex" (which
    represents the date of the game and the 2 teams) to see the
    URLs.

    In the #1 output, I noticed that there are many URLs where
    there are "&" sequences and there are none where the
    "&" is replaced by an "&". However there is a URL
    containing "%26aifp%3Dv0004%26ct1%3Dmlb" which if you expand
    the % sequences comes out to "&ifp=v0004&ct1=mlb" which uses
    "&" not "&".

    In the #2, there are actual URLs that do have actual
    sequences like "&aifp=v0004&ct1=mlb" (without either "%"
    escapes or "&" escapes)

    I don't know if any of these things are important.

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-08-07

    Logged In: YES
    user_id=685413

    mlb appears to use flash video. So therefore it is unsupported.

    Can you show me a link that does not use flash video?

     
  • Kevin DeKorte
    Kevin DeKorte
    2006-08-07

    • status: open --> pending-rejected
     
1 2 > >> (Page 1 of 2)