Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#174 Crash on mkv files (0V40)

open
nobody
None
5
2014-08-15
2005-07-10
Matthieu Brunet
No

I've installed the last binaries from helix, and try the ones from
playerhq.hu too, into /usr/local/lib/mplayer.
Try 2 mkv files, which work on windows.
This is my output :
MPlayer dev-CVS-0500May-17:40-3.3 (C) 2000-2005 MPlayer
Team
AltiVec found
CPU: PowerPC
Creating config file: /var/root/.mplayer/config

Playing /Volumes/gros/films/Kitano/1999 - L'Été de Kikujiro
(Kikujiro no natsu).vostf.mkv.
[mkv] Track ID 1: video (V_REAL/RV40), -vid 0
[mkv] Track ID 2: audio (A_AAC/MPEG2/LC/SBR), -aid 0, -alang
fre
[mkv] Track ID 3: audio (A_AAC/MPEG2/LC/SBR), -aid 1, -alang
jpn
[mkv] Track ID 4: subtitles (S_TEXT/SSA), -sid 0, -slang mis
[mkv] Track ID 5: subtitles (S_VOBSUB), -sid 1, -slang fre
[mkv] Track ID 6: subtitles (S_VOBSUB), -sid 2, -slang dut
[mkv] Will play video track 1
[mkv] Will play audio track 2
Matroska file format detected.
VIDEO: [04VR] 576x304 24bpp 25.000 fps 0.0 kbps ( 0.0
kbyte/s)
================================================
==========================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio
Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16be, 128.0 kbit/8.33% (ratio: 16000-
>192000)
Selected audio codec: [faad] afm:faad (FAAD AAC (MPEG2/
MPEG4 Audio) decoder)
================================================
==========================
================================================
==========================
Opening video decoder: [realvid] RealVideo decoder
opening shared obj '/usr/local/lib/mplayer//drvc.so'
Error: dlopen(/usr/local/lib/mplayer//drvc.so, 1): image not found
ERROR: Could not open required DirectShow codec drvc.so.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
opening shared obj '/usr/local/lib/mplayer//drv4.so.6.0'
Error: dlopen(/usr/local/lib/mplayer//drv4.so.6.0, 1): image not
found
ERROR: Could not open required DirectShow codec drv4.so.6.0.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
ERROR: Could not open required DirectShow codec drv43260.dll.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
opening shared obj '/usr/local/lib/mplayer//drvc.bundle/Contents/
MacOS/drvc'
Selected video codec: [rv40mac] vfm:realvid (Mac OS X
RealPlayer 9 RV40 decoder)
================================================
==========================
Checking audio filter chain for 48000Hz/2ch/s16be -> 48000Hz/
2ch/s16be...
AF_pre: 48000Hz/2ch/s16be
AO: [macosx] 48000Hz 2ch floatbe (4 bps)
Building audio filter chain for 48000Hz/2ch/s16be -> 48000Hz/2ch/
floatbe...
Starting playback...

MPlayer interrupted by signal 11 in module: decode_video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb'
backtrace and
disassembly. Details in DOCS/HTML/en/
bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in
your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions
there. We can't and
won't help unless you provide this information when reporting a
possible bug.

the second files give this :
(-------- cut the same ----------)
Playing /Volumes/gros/films/L'enquęte corse (Alain Berberian -
2004).mkv.
[mkv] Track ID 1: video (V_REAL/RV40), -vid 0
[mkv] Track ID 2: audio (A_VORBIS), -aid 0, -alang fre
[mkv] Track ID 3: subtitles (S_TEXT/SSA), -sid 0, -slang mul
[mkv] Track ID 4: subtitles (S_VOBSUB), -sid 1, -slang fre
[mkv] Track ID 5: subtitles (S_VOBSUB), -sid 2, -slang eng
[mkv] Track ID 6: subtitles (S_VOBSUB), -sid 3, -slang cos
[mkv] Will play video track 1
[mkv] Will play audio track 2
Matroska file format detected.
VIDEO: [04VR] 640x272 24bpp 30.000 fps 0.0 kbps ( 0.0
kbyte/s)
================================================
==========================
Opening audio decoder: [libvorbis] Ogg/Vorbis audio decoder
AUDIO: 48000 Hz, 2 ch, s16be, 96.0 kbit/6.25% (ratio: 12000-
>192000)
Selected audio codec: [vorbis] afm:libvorbis (OggVorbis Audio
Decoder)
================================================
==========================
================================================
==========================
Opening video decoder: [realvid] RealVideo decoder
(---- cut the same -----)
================================================
==========================
Checking audio filter chain for 48000Hz/2ch/s16be -> 48000Hz/
2ch/s16be...
AF_pre: 48000Hz/2ch/s16be
AO: [macosx] 48000Hz 2ch floatbe (4 bps)
Building audio filter chain for 48000Hz/2ch/s16be -> 48000Hz/2ch/
floatbe...
Starting playback...
VDec: vo config request - 640 x 272 (preferred csp: Planar I420)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar I420 as output csp (no 0)
Movie-Aspect is 2.35:1 - prescaling to correct movie aspect.
SwScaler: using unscaled Planar YV12 -> Packed YUY2 special
converter
VO: [macosx] 640x272 => 640x272 Packed YUY2
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A: 2.2 V: 2.3 A-V: -0.091 ct: -0.112 59/ 59 14% 4% 3.4% 0 0

MPlayer interrupted by signal 11 in module: decode_video
(------- cut the same --------)

Discussion