#1 svn 26334 crash when playing type of .mkv file

closed
MPlayer (86)
5
2008-04-14
2008-04-06
Anonymous
No

I found svn 26334 can't play all .mkv files in my computer and it always crashs when start playing. But svn 25962 plays well on those .mkv files.

Discussion

  • Logged In: YES
    user_id=38409
    Originator: NO

    Oo
    what flavor? It plays fine here athlon build on amd 64 x2
    more infos? mplayer -v etc

     
  • Logged In: NO

    Hi,

    The issue does happend every time when I am trying to play .mkv file even without using SMPayer. As it's not easy to get logs in Windows XP, so I used SMPayer 0.60 RC3 to get logs form MPlayer. Please take a look. Thanks.

    C:/Program Files/SMPlayer/mplayer/mplayer.exe -noquiet -nofs -sub-fuzziness 1 -identify -msglevel demux=6 -slave -vo directx -ao dsound -zoom -nokeepaspect -priority abovenormal -framedrop -wid 1967758 -colorkey 0x020202 -monitorpixelaspect 1 -ass -embeddedfonts -ass-color ffff0000 -ass-border-color 00000000 -subfont-autoscale 3 -ass-font-scale 1 -subcp BIG5 -aid 0 -subpos 100 -contrast 0 -hue 0 -saturation 0 -nocache -osdlevel 0 -vf-add screenshot -channels 2 -af scaletempo D:/Movies/SCRATN~1.MKV

    MPlayer Sherpya-SVN-r26334-4.2.3 (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz (Family: 6, Model: 23, Stepping: 6)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    Setting process priority: abovenormal

    Playing D:/Movies/SCRATN~1.MKV.
    Checking for YUV4MPEG2
    Checking for NuppelVideo
    Checking for REAL
    Checking for SMJPEG
    [mkv] Found the head...
    [mkv] + a segment...
    [mkv] /---- [ parsing seek head ] ---------
    [mkv] /---- [ parsing seek head ] ---------
    [mkv] \---- [ parsing seek head ] ---------
    [mkv] /---- [ parsing cues ] -----------
    [mkv] \---- [ parsing cues ] -----------
    [mkv] \---- [ parsing seek head ] ---------
    [mkv] |+ segment information...
    [mkv] | + timecode scale: 1000000
    [mkv] | + duration: 452.960s
    [mkv] |+ segment tracks...
    [mkv] | + a track...
    [mkv] | + Track number: 1
    [mkv] | + Track type: Video
    [mkv] | + Default flag: 1
    [mkv] | + Codec ID: V_MPEG4/ISO/AVC
    [mkv] | + CodecPrivate, length 130
    [mkv] | + Default duration: 41.708ms ( = 23.976 fps)
    [mkv] | + Language: eng
    [mkv] | + Name: Scrat - No Time For Nuts
    [mkv] | + Video track
    [mkv] | + Pixel width: 1280
    [mkv] | + Pixel height: 720
    [mkv] | + Display width: 16
    [mkv] | + Display height: 9
    [mkv] | + a track...
    [mkv] | + Track number: 2
    [mkv] | + Track type: Audio
    [mkv] | + Default flag: 1
    [mkv] | + Codec ID: A_AC3
    [mkv] | + Default duration: 32.000ms ( = 31.250 fps)
    [mkv] | + Language: eng
    [mkv] | + Name: AC3 5.1
    [mkv] | + Audio track
    [mkv] | + Sampling frequency: 48000.000000
    [mkv] | + Channels: 6
    [mkv] |+ found cluster, headers are parsed completely :)
    ID_VIDEO_ID=0
    [mkv] Aspect: 1.777778
    ID_VID_0_NAME=Scrat - No Time For Nuts
    [mkv] Track ID 1: video (V_MPEG4/ISO/AVC) "Scrat - No Time For Nuts", -vid 0
    ID_AUDIO_ID=0
    ID_AID_0_NAME=AC3 5.1
    ID_AID_0_LANG=eng
    [mkv] Track ID 2: audio (A_AC3) "AC3 5.1", -aid 0, -alang eng
    [mkv] Will play video track 1.
    Matroska file format detected.
    VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
    ID_FILENAME=D:/Movies/SCRATN~1.MKV
    ID_DEMUXER=mkv
    ID_VIDEO_FORMAT=avc1
    ID_VIDEO_BITRATE=0
    ID_VIDEO_WIDTH=1280
    ID_VIDEO_HEIGHT=720
    ID_VIDEO_FPS=23.976
    ID_VIDEO_ASPECT=1.7778
    ID_AUDIO_FORMAT=8192
    ID_AUDIO_BITRATE=0
    ID_AUDIO_RATE=48000
    ID_AUDIO_NCH=6
    ID_LENGTH=452.96
    ID_SEEKABLE=1
    [ass] auto-open
    Opening video filter: [screenshot]
    [ass] Init
    [ass] Fontconfig disabled, only default font will be used.
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ==========================================================================
    ID_VIDEO_CODEC=ffh264
    ==========================================================================
    Opening audio decoder: [liba52] AC3 decoding with liba52
    AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
    ID_AUDIO_BITRATE=448000
    ID_AUDIO_RATE=48000
    ID_AUDIO_NCH=2
    Selected audio codec: [a52] afm: liba52 (AC3-liba52)
    ==========================================================================
    AO: [dsound] 48000Hz 2ch s16le (2 bytes per sample)
    ID_AUDIO_CODEC=a52
    Starting playback...
    Using SSE optimized IMDCT transform
    Using MMX optimized resampler

    MPlayer interrupted by signal 11 in module: decode_audio
    ID_SIGNAL=11
    - MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
    disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
    - MPlayer crashed. This shouldn't happen.
    It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
    gcc version. If you think it's MPlayer's fault, please read
    DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
    won't help unless you provide this information when reporting a possible bug.

     
  • Logged In: YES
    user_id=38409
    Originator: NO

    nothing to do with matroska container, the problem is in the ac3 audio decoder, I'll make some tests to reproduce it

     
  • Logged In: YES
    user_id=38409
    Originator: NO

    just to be sure can you try please disabling audio by adding -nosound to the cmdline?

     
  • Logged In: NO

    Hi Sherpya,

    I think you're right that the issue is related to the AC3 decoder. When I added -nosound to the cmdline to play the file, the MPlayer didn't crash and played very well.

    C:\Program Files\SMPlayer\mplayer>mplayer -nosound D:/Movies/SCRATN~1.MKV
    MPlayer Sherpya-SVN-r26334-4.2.3 (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz (Family: 6, Model: 23, Step
    ping: 6)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

    Playing D:/Movies/SCRATN~1.MKV.
    [mkv] Track ID 1: video (V_MPEG4/ISO/AVC) "Scrat - No Time For Nuts", -vid 0
    [mkv] Track ID 2: audio (A_AC3) "AC3 5.1", -aid 0, -alang eng
    [mkv] Will play video track 1.
    Matroska file format detected.
    VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ==========================================================================
    Audio: no sound
    Starting playback...
    VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    VO: [directx] 1280x720 => 1280x720 Planar YV12

    Exiting... (Quit)

     
  • Logged In: YES
    user_id=38409
    Originator: NO

    Please check latest rev 26430, the SSE problem should be gone (downgraded binutils to 2.17)

     
  • Logged In: NO

    Hi Sherpya,

    Thank you very much. The issue has been fixed in the rev 26430.

     
  • Logged In: YES
    user_id=38409
    Originator: NO

    it should be solved now, if not report please

     
    • status: open --> closed