Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#174 --wav not working anymore with stdout

1.14.x
closed-fixed
nobody
mpg123 (103)
5
2012-05-12
2012-05-09
Nort Obor
No

don't know, if i'm missing something (manpage at least reports no changes) or not...

i always used to encode mp3 -> mp4 using a command like:
mpg123 -r 44100 -s --wav - xxx.mp3 | neroAacEnc -br 65535 -ignorelength -if - -of xxx.mp4

but starting with 14.0 '--wav' isn't working anymore, it gives me an error like:

[audio.c:630] error: failed to open audio device
[mpg123.c:542] error: failed to reset audio device: Illegal seek

Discussion

  • Nort Obor
    Nort Obor
    2012-05-09

    • summary: --wav not working anymore --> --wav not working anymore with stdout
     
  • Thomas Orgis
    Thomas Orgis
    2012-05-09

    Please try http://mpg123.org/snapshot and report back.

    The wav writer logic got changed to catch out-of-disk errors (to some extend). WAV writing to stdout was a collateral.

    Though, you should not only fix the sample rate, but also the channel count to make sure the format is consistent with the header.

     
  • Nort Obor
    Nort Obor
    2012-05-10

    > Please try http://mpg123.org/snapshot and report back.

    yay, today's snapshot is working fine for me.

    > Though, you should not only fix the sample rate, but also the channel count
    > to make sure the format is consistent with the header.

    right, thanks. (i always had sources with 2 channels so far)

    thx for your fast response and fixing! :)

     
  • Thomas Orgis
    Thomas Orgis
    2012-05-12

    fixed in 1.14.2

     
  • Thomas Orgis
    Thomas Orgis
    2012-05-12

    • status: open --> closed-fixed