An MP3 file is strange played

General
printer
2006-08-07
2013-04-16
  • printer
    printer
    2006-08-07

    I have a MP3 file that mp3blaster play very strange: it skipped a 7-8 second during playing

    This is about mp3blaster:
    mp3blaster version 3.2.2 - http://mp3blaster.sourceforge.net/
    Supported audio formats: mp3 wav ogg sid                     
    Supported audio output drivers: oss sdl esd                  
    Build features: pthreads                                     
    This is about OS:
    FreeBSD acc.acc.tula.ru 4.11-RELEASE-p4 FreeBSD 4.11-RELEASE-p4 #15: Wed Apr 19 16:56:37 MSD 2006
      acc107_3@acc.acc.tula.ru:/usr/obj/usr/src/sys/Z  i386                                          

     
    • Bram Avontuur
      Bram Avontuur
      2006-08-25

      Can you run mp3blaster with the -d option?
      By default, it dumps the debug info in ~/.mp3blaster

      Post the (relevant) bits here. Usually you'll see something about 'bad frames' at about the time the skipping occurs. This indicates that the mp3 data is damaged.

       
    • Danilo
      Danilo
      2007-07-05

      hey

      i have a similar (or the same?) problem. i installed mp3blaster today, and if i play my mp3 files, they are played too fast. it skips little chunks of the song.
      when i ran mp3blaster in debug mode it said:

      Found a bogus header (or EOF?) Resetting..
      Found a bogus header (or EOF?) Resetting..

      this goes on several pages.

      the mp3 files are OK, i tried several different ones. any idea what the problem is?

      my OS is openSUSE 10.2 and i have mp3blaster v3.2.3.

       
    • Michael Fuchs
      Michael Fuchs
      2008-05-07

      same problem here. many skips of 2-5 seconds

      same debug output.
      it also happens with ogg files.

      gentoo
      kernel 2.6.24 (tickless)
      mp3blaster 3.2.3

       
    • Tobien Rieper
      Tobien Rieper
      2008-05-08

      Try to increase number of threads ( using -t option ), from manual page:

      --threads/-t=<amount>
          Numbers of threads to use for buffering. Range is 0..500 in increments of 50. 0 threads means no buffering (thus no hickup prevention).

      Or 'on the fly' I think by using '[' and ']' keys...