Avoiding breakage after Ubuntu upgrades

2012-04-30
2012-09-15
  • Ubuntu upgrades often break the libraries MoreAmp uses and trigger at least
    the need for a recompilation.

    However, with the recently released Precise Pangolin, MoreAmp doesn't even
    start anymore, neither the self-compiled binary from the Oneiric release, nor
    the newly compiled version.

    I found a solution using a chroot with a basic Oneiric system. This way, all
    the working components from that release are preserved even when the main
    system is updated frequently.

    Info about debootstrap and schroot:

    https://help.ubuntu.com/community/DebootstrapChroot