Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#422 Home page is not showing correct

1.1.0
closed-duplicate
Gabriele
None
5
2014-09-12
2014-07-12
Anonymous
No

Home page is not showing correct. It looks like CSS are not loaded.
Version is 1.1.0 rc2 and rc3. OS Win 7 / 64-bit.
There is a screenshot attached.

1 Attachments

Discussion

  • Gabriele
    Gabriele
    2014-07-12

    Installed or portable version?
    What files do you have in "res" folder?

     

  • Anonymous
    2014-07-12

    Both installed and portable version. Installed version is installed with "make portable" checkmark.
    Files in res (installed version): Chart.js, home_page.htt, kaching.wav, master.css, mmex.ico. In portable version there was also sorttable.js. I've copied the last file to the installed dir, and the home page is same.
    I have the very same setup on my work PC (and same database) and it is OK. The problem is only on my home laptop.

     
  • Gabriele
    Gabriele
    2014-07-12

    If you open a browser at "http://localhost:8080" while MMEX is running, what do you see?

     

  • Anonymous
    2014-07-12

    In browser the home page is OK. Everything is OK. The css file is loaded OK.
    I've tried with 32-bit version, but the issue remains.

    Here is some progress, I have been able to get the home page like it should be, but with different user on the same PC.
    The PC is connected to a domain, when I log with my domain user, the home page is OK. But, when I log with my local administrator user, then the home page is missing the CSS file.
    IMHO, I think it has something to do with the folder path variables.

     
  • Nikolay
    Nikolay
    2014-07-13

    What is internet explore version on your system?
    May be incorrect value in registry
    Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION
    there value is 9000
    it's for Internet Explorer 9
    For more details:
    http://msdn.microsoft.com/en-us/library/ie/ee330730(v=vs.85).aspx

     

  • Anonymous
    2014-07-13

    The version of IE is 11, the value of the registry key was 9000, I've changed it to 11000, restarted and there were no changes to the home page. I've reinstalled MMEX, and the value of the key went back to 9000, changed it back to 11000, and no changes.
    I've looked into the registry setting of the other (domain) user, and the value of the key was 11000.

     
  • Gabriele
    Gabriele
    2014-07-13

    Try wiht RC3 only, because with it we force registry key at 9000 (the correct value) at every start-up, so I don't know how you could have 11000 after opening MMEX..

     
  • Nikolay
    Nikolay
    2014-07-13

    May be update registry only in case if no record found?
    Workaround is : rename mmex.exe into mmex_.exe and add mmex_.exe = 11000 into registry

     
  • Gabriele
    Gabriele
    2014-07-13

    IMHO it isn't a registry problem but some user options in IE.
    In screenshot Chart is OK, so registry is OK.

    Could you restore IE options to default? (Internet Options -> Advanced -> Reset)

    @Nikolay: Ok for registry mod

     

  • Anonymous
    2014-07-13

    @Gabriele, IE reset didn't do the trick.

    @Nikolay, Renaming the exe or the registry key DID SOLVE the issue, but when I renamed the registry key and started the mmex.exe a new registry key was created with the mmex.exe name, and on the next open of MMEX the issue returned.

    So my permanent workaround is to rename the exe and update the shortcuts.

     

  • Anonymous
    2014-07-13

    Update to my previus post:
    With renamed mmex.exe to mmex_.exe now the Income vs Expenses table is empty, no values in amount column and no bars are showing in the chart.

     
  • Gabriele
    Gabriele
    2014-07-13

    To show Income\Expenses table you need to set the key to 9000 (or bigger).
    By default Microsoft uses IE7 where webpage is showed in other software, and IE7 don't support Chart.js used for graphs, so this key means "use IE9 for mmex.exe"

    When you rename mmex.exe to mmex_.exe you need to create another key mmex_.exe and give value 11000 (if it works).

    I've updated code and, when mmex.exe value is found in registry, it isn't automatically updated to 9000.

    Real problem is that we don't know why 9000 seems to conflict with CSS. On all my Windows 7/8 machines seems to work fine..

     

  • Anonymous
    2014-09-12

    Hi,
    On my MMEX Home Page "Income vs Expenses: Current Month" graph shows correctly but just besides the graph the type does not show the amount for income and expenses and difference. Kindly Help.

    I opened the IE 10 browser at "http://localhost:8080" while MMEX is running and even that does not have the values
    Nagesh

     
    Attachments


Anonymous


Cancel   Add attachments