Dear Renato,
your problem is almost surely an apache configuration one, not a moinmoin.
a2ensite requires as argument the name of the site configuration file that you have already created in /etc/apache2/sites-available, so if you created a file called “wiki” in /etc/apache2/sites-available you need to enable the site using the command:

a2ensite wiki

If you type http://localhost/wiki in your browser and you get nothing, it can be caused by various problems in the configuration. Without seeing the apache “wiki” conf file it’s hard to know what the problem is.
You should start by examining the apache access and error logs in /var/log/apache.
The log files that you need to look into depend on how you configured the wiki apache file, as they should be specified in there.
Hope this helps…
Regards,

Davide
 


From: Renato <renato.pontefice@gmail.com>
Date: Saturday, 15 February 2014 12:16
To: moin-user <moin-user@lists.sourceforge.net>
Subject: [Moin-user] Debian wheezy: problem installing moin moin

Hi,
as on my previous mail, I do not went forward :-(
I'm still blocked on the installation.

My step ahead, it' s about one idea about my prob. I think my prob is the apache conf.
I mean: the moin moin installation, seems to be went ok, but, on the step where I add the wiki on my apache with command:
"a2ensite /etc/apache2/sites-available/wiki"I receive the error: "ERROR: No site found matching /etc/apache2/sites-available/wiki!
". If I omit the path, ad write the command "a2ensite wiki" I have no error.

But, on my browser, if I type "localhost/wiki"  I do not receive any answer from the web server.

can someone help me to solve this prob? it's some days that I'm struggling with it (and I lose every time :-( )


TIA

Renato