Hi,
First of all thanks for your quick reply.
you are right that my productive wiki is running on different account but I did not miss this step actually . i added the users of productive wiki account in the AdminGroup page. but it did not work. your 2nd suggestion was about CopyPage. Today i tried also this copy function. it copies the same page on same wiki. therefoe i have to again copy the page manually from the file system and put into the productive wiki. I have also delete the cache (using the feature from "action") and restarted the apache and started the new session of IE. but didn't  help.
 
The main restriction in our productive-wiki is that i cannot edit or create pages with the help of internet browser. i can only read there. I have written one batch script, which copy all those pages from local wiki to productive-wiki, in which we define this acl (#acl InternationalGroup:read). This script deletes all pages in productive-wiki before running. Therefore i have created all Group pages also in my local wiki.
 
Thanks for helping,
 
bye


 

> Date: Fri, 28 Aug 2009 21:50:49 +0200
> From: wtp@bsdserwis.com
> To: waqas805@hotmail.com
> CC: moin-user@lists.sourceforge.net
> Subject: Re: [Moin-user] Group Pages
>
> Hello,
>
> On Fri, Aug 28, 2009 at 05:09:43PM +0200, waqas ahmad wrote:
> >
> > I am using moinmoin184 with
> >
> > Apache/2.2.8 (Win32) mod_ssl/2.2.8 OpenSSL/0.9.8g mod_wsgi/2.3 Python/2.5.2
> > mod_auth_sspi/1.0.4:
> >
> > I have created some Group pages on my private wiki, which I am running on my
> > local computer. And then I simply went in the FileSystemArea of my local
> > moinmoin (moin\data\pages) and copy the GropPages (e.g AdminGroup). Now I
> > pasted the folder manually in the other wiki (productive wiki) and I also
> > mentioned this group under wikiconfig.py and restarted the Apache too. But this
> > wiki is not taking the users which I have described in this Group.
> >
> Did you create the same account on productive wiki as on your local
> copy? As I understood you missed this step.
>
> And maybe it's much easier to "copy" AdmonGroup page via browser?
> Specially if it is not so long.
>
> > I have created one AdminGroup with user Amd . Moinmoin is accessing this
> > AdminGroup and its user too according to given rights in wikiconfig to group.
> > Very Fine. Now I delete this group page (AdminGroup) manually from the file
> > system (moin\data\pages\AdminGroup) and restart the apache. Now this AdminGroup
> > page does not exist anymore in File System. But I can access the moinmoin wiki
> > with this user Amd till now. I don t know why, even I started the new session
> > of IE. Maybe moinmoin is caching the users some where or?
> >
> > Is it Bug in moinmoin or?
> >
> I think you should not only restart Apache but clean cache pages also.
> Specially when you delete pages "manually" :-)))
>
> Greetings
> --
> Krzysztof Stryjek
> UNIX administrator/Juniper Networks Specialist
> email: wtp (at) bsdserwis (dot) com
> http://www.linkedin.com/in/KrzysztofStryjek
> GPG fingerprint: 8BD7 40CE 8994 0BBE CE6C 91CD 1292 8959 DC61 0E76
>
> In theory, there is no difference between theory and practice.
> In practice, there is.


Share your memories online with anyone you want anyone you want.