Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#19 no valid html/xhtml

closed-wont-fix
nobody
None
6
2003-12-23
2002-03-18
Ronny Buchmann
No

as everybody knows moinmoin doesn't produce valid html.
i consider this a bug. i have a patch for valid html
4.01 transitional code.
the patch is safe (i think) and doesnt change look,
with one exception: the search buttons cant have
attributes like images (hspace, border etc), only css
is allowed, but netscape 4.x doesnt understand it
right, so it looks a bit different (borders!).

please test and apply (at least the other chunks)

ronny

Discussion

  • Ronny Buchmann
    Ronny Buchmann
    2002-03-18

    patch

     
    Attachments
    • status: open --> closed-fixed
     
  • Logged In: YES
    user_id=39128

    much easier to fix is at ONE place in url() and link_to()

    the inline search forms will NOT be fixed, because they are
    how they are intentionally

    for any remaining issues you might reopen the bug (do diffs
    against current CVS), but don't hold your breath; as we
    approach XHTML compliance and templating, the issue isn't
    worth any major effort on current code.

     
  • Ronny Buchmann
    Ronny Buchmann
    2002-03-19

    • priority: 5 --> 6
    • summary: no valid html --> no valid html/xhtml
    • status: closed-fixed --> open-wont-fix
     
  • Ronny Buchmann
    Ronny Buchmann
    2002-03-19

    Logged In: YES
    user_id=91363

    no, your change to Page.py isnt enough.
    and i dont think it makes sense to use string.replace to
    correct typos. (but if your going to actually use url() and
    link_to(), then i dont have a problem)

    and if you want xhtml, thats no problem.
    i'll start making some diffs

     
  • Ronny Buchmann
    Ronny Buchmann
    2002-03-19

    xhtml (pre)patch

     
  • Ronny Buchmann
    Ronny Buchmann
    2002-03-19

    Logged In: YES
    user_id=91363

    so heres the next patch: moinmoin-xhtml.1.patch

    issues adressed:
    * namespace for <html>
    * elements and attributes only lowercase
    * empty elements (br, hr, meta, img, input)
    * empty attributes (nowrap, checked)
    * all attribute values with quotes
    i hope to have found all occurences

    issues not adressed:
    * no closing tag for <p>
    (is there some magic involved? i dont find my way through
    the code here, but i assume it's easy for you, jrgen)
    * printing of xml header and dtd (trivial)

     
    • status: open-wont-fix --> closed-wont-fix
     
  • Logged In: YES
    user_id=100649

    this is currently being adressed in branch moin--main--1.2,
    together with themeing work and moving to css - most work
    done by Bastian Blank.

    some issues might not get fixed immediately as they are not
    possible with the current parser.

    but at least, I have already seen some pages validate at W3C
    validator ;)