Hi.

I am using ModSecurity version 2.6.8 with ruleset version 2.2.5, and am running Apache 2.2.26 on RedHat AS5 and Apache 2.4.7 on CentOS 5.10. Unfortunately, upgrading the OS and/or modsecurity is not an option, at this time. I have no problem with the Apache 2.2.26 servers, but I find that when I try to start the Apache 2.4.7 (I've also tried 2.4.9), I get this error:

AH00526: Syntax error on line 132 of /home/web/current/conf/crs/activated_rules/modsecurity_crs_50_outbound.conf:
Error parsing actions: Unknown action: \\

I have downloaded a fresh copy of the modsecurity_crs_50_outbound.conf from GitHub, just to be sure I had not accidentally changed my copy, and I have not. I did find that a server that's still running Apache 2.4.2 can start with no errors. Does anybody know if the 2.2.5 core ruleset is known to be incompatible with Apache versions higher than 2.4.2? I suppose that wouldn't surprise me, give the age of the ruleset I'm using, but I'm surprised not to have found anybody else using these version combos and reporting problems. Thanks for any insights you can offer!

- Michele