After muddling through the config file changes that were needed to get most of the way through the compiling of ngnix with modsecurity as an added module, I got the following error:

/tmp/modsecurity-apache_2.7.4/nginx/modsecurity//ngx_http_modsecurity.c: In function ‘ngx_http_modsecurity_handler’:
/tmp/modsecurity-apache_2.7.4/nginx/modsecurity//ngx_http_modsecurity.c:1362: error: array subscript is above array bounds
make[1]: *** [objs/addon/modsecurity/ngx_http_modsecurity.o] Error 1
make[1]: Leaving directory `/tmp/nginx-1.4.1'
make: *** [build] Error 2

Google was only able to provide the following:

http://sourceforge.net/mailarchive/message.php?msg_id=31039201

Which indicates it will be fixed, anyone run up against this and know what can be done in the meantime?

Thanks,
David