Do you have multiple apache versions in this box ? If so.. make sure you ara using the right apache version devel tools and code.

For some reason i think mod_security is using apache 2.3 or 2.4 files.

Thanks


On Thu, Jul 18, 2013 at 5:17 PM, Ian Webb <perelman42@gmail.com> wrote:
On Thu, Jul 18, 2013 at 3:29 PM, Breno Silva <breno.silva@gmail.com> wrote:
> Right. I tested it in my Ubuntu (mod_security 2.7.5 + nginx 1.5.2) and all
> compiled fine. Maybe some issue related to CentOS ?
>
> Did you run "make install"  after ./configure --enable-standalone-module ?
>
> Thanks
>
> Breno
>

That got me a lot closer to compiled. Now it still errors, but at the
very last part of the build:

cc -o objs/nginx \
        objs/src/core/nginx.o \
        objs/src/core/ngx_log.o \
        objs/src/core/ngx_palloc.o \
        objs/src/core/ngx_array.o \
<bunch more modules>
        objs/src/http/modules/ngx_http_upstream_keepalive_module.o \
        objs/src/http/modules/ngx_http_stub_status_module.o \
        objs/addon/modsecurity/ngx_http_modsecurity.o \
        objs/addon/modsecurity/apr_bucket_nginx.o \
        objs/addon/modsecurity/ngx_pool_context.o \
        objs/ngx_modules.o \
        -lpthread -lcrypt
/root/modsecurity-apache_2.7.5/nginx/modsecurity/../../standalone/.libs/standalone.a
-L/usr/lib64 -lapr-1 -L/usr/lib64 -laprutil-1 -L/usr/local/lib -lpcre
-lxml2 -lz -lm -llua -lm -ldl /root/pcre-8.33/.libs/libpcre.a
/root/openssl-1.0.1e/.openssl/lib/libssl.a
/root/openssl-1.0.1e/.openssl/lib/libcrypto.a -ldl -lz
/root/modsecurity-apache_2.7.5/nginx/modsecurity/../../standalone/.libs/standalone.a(standalone_la-modsecurity.o):
In function `modsecurity_init':
/root/modsecurity-apache_2.7.5/standalone/../apache2/modsecurity.c:131:
undefined reference to `ap_unixd_set_global_mutex_perms'
/root/modsecurity-apache_2.7.5/standalone/../apache2/modsecurity.c:149:
undefined reference to `ap_unixd_set_global_mutex_perms'
collect2: ld returned 1 exit status
make[1]: *** [objs/nginx] Error 1
make[1]: Leaving directory `/root/nginx-1.5.2'
make: *** [build] Error 2

I've confirmed that 2.7.4 still builds fine on this machine, so the
libraries and dependencies are all present.

Thanks,
Ian

------------------------------------------------------------------------------
See everything from the browser to the database with AppDynamics
Get end-to-end visibility with application monitoring from AppDynamics
Isolate bottlenecks and diagnose root cause in seconds.
Start your free trial of AppDynamics Pro today!
http://pubads.g.doubleclick.net/gampad/clk?id=48808831&iu=/4140/ostg.clktrk
_______________________________________________
mod-security-developers mailing list
mod-security-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/mod-security-developers
ModSecurity Services from Trustwave's SpiderLabs:
https://www.trustwave.com/spiderLabs.php