Will fix this



On Tue, Jun 11, 2013 at 7:26 AM, <bdolljr@bigskytech.com> wrote:
Hi All,

I'm trying to compile mod_security on Centos 6.4 using nginx 1.4.1 as the server.  I am getting the following error which after looking at the code I think is a bug.  I'm getting:

../mod_security/nginx/modsecurity/ngx_http_modsecurity.c:1362: error: array subscript is above array bounds

When reviewing the code I see that salt[] is being NULL terminated at offset salt[25].  The salt array is defined in size to be 25.  I'm not sure if the correct action is to modify the code to make the salt[] array one larger or having the prior loop fall out one sooner.

Any help would be appreciated.  I'm not very proficient in coding so I don't feel comfortable trying to get the current sources and submitting a patch.  Especially when I don't really understand what that code is doing.

Thanks for your help!


This SF.net email is sponsored by Windows:

Build for Windows Store.

mod-security-developers mailing list
ModSecurity Services from Trustwave's SpiderLabs: