Hello Ross,

Yes. This is a strange situation. The error happened in apache24 but not in apache22.
Anyway, i did some changes in the "breakline" chars and it is working now:

SecRule MULTIPART_STRICT_ERROR "!@eq 0" \
"id:'200002',phase:2,t:none,log,deny,status:44, \
msg:'Multipart request body failed strict validation: \
PE %{REQBODY_PROCESSOR_ERROR}, \
BQ %{MULTIPART_BOUNDARY_QUOTED}, \
BW %{MULTIPART_BOUNDARY_WHITESPACE}, \
DB %{MULTIPART_DATA_BEFORE}, \
DA %{MULTIPART_DATA_AFTER}, \
HF %{MULTIPART_HEADER_FOLDING}, \
LF %{MULTIPART_LF_LINE}, \
SM %{MULTIPART_MISSING_SEMICOLON}, \
IQ %{MULTIPART_INVALID_QUOTING}, \
IP %{MULTIPART_INVALID_PART}, \
IH %{MULTIPART_INVALID_HEADER_FOLDING}, \
FL %{MULTIPART_FILE_LIMIT_EXCEEDED}'"


Can you confirm ?

Thanks

Breno

On Thu, Oct 18, 2012 at 3:53 PM, Ross Lawrie <ross@sentrypayments.com> wrote:
Hi,

Testing an upgrade to 2.7.0 from 2.6.8 and am running into a problem I
haven't been able to figure out, or successfully Google.

On an attempt to start (or even test) Apache, I get the following error:

$ /usr/local/apache/bin/apachectl configtest
AH00526: Syntax error on line 65 of /usr/local/apache/conf/modsecurity.conf:
Error parsing actions: Invalid quoted pair at position 164:
id:'200002',phase:2,t:none,log,deny,status:44,msg:'Multipart request
body failed strict validation: PE %{REQBODY_PROCESSOR_ERROR}, BQ
%{MULTIPART_BOUNDARY_QUOTED}, \\

I've done this with just the default modsecurity.conf-recommended,
included in the source package, build options are:

./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--with-apr=/usr/local/apache/bin/apr-1-config \
--with-apu=/usr/local/apache/bin/apu-1-config \
--with-lua \
--with-pcre=/usr/bin/pcre-config

Apache 2.4.3 from source. OS is Debian 6.0.6. I'm sure there's something
obvious I'm missing or haven't read, but I can't seem to find it and am
hoping someone can point me in the right direction.

Thanks,

Ross.

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_sfd2d_oct
_______________________________________________
mod-security-users mailing list
mod-security-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/mod-security-users
Commercial ModSecurity Rules and Support from Trustwave's SpiderLabs:
http://www.modsecurity.org/projects/commercial/rules/
http://www.modsecurity.org/projects/commercial/support/