We have a problem building modsecurity with lua. It is fixed in the next 2.6.1 version. If you want i can send you a tarball.



2011/6/29 Сергей Кузнецов <q4x2@mail.ru>
Hi all!
I meet a problem here when configuring new mod_sec 2.6.0 with lua scripting lang support on my freebsd 7.3 where lua installed from ports and mod_sec try to install from sources.
I try some diff configure script options:
./configure --with-lua=/usr/local
./configure --with-lua=/usr/local/lib
but with no effect, configure script always says:

checking for liblua config script... no
checking for lua install... no
configure: optional lua library not found

LUA installed from port tree, libs are here:
/usr/local/lib/liblua-5.1.so -> liblua-5.1.so.1
/usr/local/lib/liblua-5.1.so.1 -> lua51/liblua-5.1.so.1
/usr/local/lib/liblua.a -> /usr/local/lib/lua51/liblua.a
/usr/local/lib/liblua.so -> /usr/local/lib/lua51/liblua.so

THX for any help!

All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security
threats, fraudulent activity, and more. Splunk takes this data and makes
sense of it. IT sense. And common sense.
mod-security-users mailing list
ModSecurity Services from Trustwave's SpiderLabs: