I tried following the blog/post http://blog.spiderlabs.com/2012/09/announcing-the-availability-of-modsecurity-extension-for-nginx.html
on my CentOS 6.2 host, and got stuck immediately.

Configure spits out the following:
configure: looking for Apache module support via DSO through APXS
configure: error: couldn't find APXS

Not sure what the dependency is that ModSec is looking for to build the standalone (first step in the post).  I hope it's not an apache binary, because the whole purpose of building for nginx would be that I don't have (or want) Apache on my host.

If there's some apache-support-lib that's small and easy to d/l and install, I don't mind.  But just like I wouldn't expect the configure/build/install to be looking for Microsoft IIS binaries on my CentOS box, I don't think it should be asking for binaries or libraries that are strictly for a different web server to build for nginx.

Can anyone point me in the right direction about dependencies and/or a workaround?

Thanks,
AJ