Problem with Mod Security installed in Joomla and Wordpress websites

Rules
Ganesh
2013-08-10
2013-09-10
  • Ganesh
    Ganesh
    2013-08-10

    Hi,
    I have installed Mod_Security in some of my websites. It works fine. Since those websites are CMS such as Joomla and WordPress, while login to the admin, it throws 403 Error. And I can't login. After I disable Mod_Security and login, its works fine. So the problem exist only with Mod Security. Can I have the solution for that ?? Anyone is appreciated to give me a solution.

     
    Last edit: Ganesh 2013-08-10
    • Ryan Barnett
      Ryan Barnett
      2013-08-10

      What do the logs say?

      --
      Ryan Barnett
      Lead Security Researcher
      Trustwave - SpiderLabs

      On Aug 10, 2013, at 11:14 AM, "Ganesh" gane-kumar@users.sf.net wrote:

      Hi,
      I have installed Mod_Security in some of my websites. It works fine. Since those websites are CMS such as Joomla and WordPress, while login to the admin, it throws 403 Error. And I can't login. Can I have the solution for that ??

      Problem with Mod Security installed in Joomla and Wordpress websites

      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/mod-security/discussion/1298046/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       
      • Ganesh
        Ganesh
        2013-08-12

        Hi Ryan,
        While login at admin, the page keeps on loading and throws 500 - Internal server error.

        When I view server log. I have got the below log captured.

        2013-08-12 06:44:32 IP-addr 50727 IP-addr 80 HTTP/1.1 POST /administrator/index.php - 8 Connection_Abandoned_By_ReqQueue.

        Do I need to edit or remove any of the Mod_Security rule to work so ?

        Please Help ?

         
        Last edit: Ganesh 2013-08-12
  • Ryan Barnett
    Ryan Barnett
    2013-09-10

    Ganesh,
    What do the ModSecurity audit log or Apache error log show?