mod_qos install - apache version

  • Andrew


    What's minimum Apache version for each mod_qoc version?

    I'm trying to install the latest one (10.16) on Apache 2.0 and it doesn't seem to work..

    (wasadmin)>/opt/IBM/HTTPServer/bin $ httpd -v
    Server version: IBM_HTTP_Server/ Apache/2.0.47
    Server built:   Jan  5 2011 16:40:54
    (wasadmin)>/opt/IBM/HTTPServer/build $ libtool --version (GNU libtool) 1.4.2 (1.922.2.53 2001/09/11 03:18:52)
    (wasadmin)>/opt/IBM/HTTPServer/bin $ apxs -c /opt/IBM/HTTPServer/qos/mod_qos.c
    /opt/IBM/HTTPServer/build/libtool --silent --mode=compile cc -xarch=amd64 -prefer-pic -xO3  -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT  -I/opt/IBM/HTTPServer/include  -I/opt/IBM/HTTPServer/include   -I/opt/IBM/HTTPServer/include   -c -o /opt/IBM/HTTPServer/qos/mod_qos.lo /opt/IBM/HTTPServer/qos/mod_qos.c && touch /opt/IBM/HTTPServer/qos/mod_qos.slo
    /opt/IBM/HTTPServer/build/libtool: line 848: cc: command not found
    apxs:Error: Command failed with rc=65536

    Also, is there a document somewhere that lists available mod_qoc features in each version?

    Thanks a lot,

  • mod_qos is designed for and tested with Apache version 2.2. However, it compiles with Apache 2.0 too and should work without restrictions.
    Apache 2.4 is currently supported by limited functionality only.

    All changes are listed within the CHANGES.txt file (included within the tar archive).

    However, the error message above shows that the libtool it not able to locate your C compiler.