Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Announce: lirc_mod_mce_0.4.0

Help
jon
2011-01-17
2013-04-15
  • jon
    jon
    2011-01-17

    I've just put lirc-mod-mce 0.4.0 on sourceforge.  You'll need it unless you're working Ubuntu.

    For Ubuntu 10.04 (Lucid) and now 10.10 (Maverick) users, use my ppa instead:

    $ sudo apt-add-repository ppa:jon-hedgerows/lirc-mod-mce
    $ sudo apt-get update
    $ sudo apt-get install lirc lirc-modules-source

    If you're paranoid and an Ubuntu user, then you can also get the source from the same ppa.

    Enjoy!

    Jon

     
  • Crasher
    Crasher
    2011-02-06

    Hi,

    how am i supposed to configure the Keyboard. Trying irw I get output for the remote control Buttons, but not for my Keyboard Keys (like characters). Trying to learn new codes with "irrecord -n -d /dev/lirc0 /usr/share/lirc/remotes/mceusb/lircd.conf" it justs shows up "something went wrong" when hitting characters. Trying to learn a new remote with irrecord i get  "No toggle bit mask found". Do I have to blacklist any modules? I'm using Ubuntu 10.10.

    Thanks for your help,
    reagards crasher2k

     
  • Leon
    Leon
    2011-02-17

    Hallo Jon,

    exactly the same problem here using Gentoo. The remote control itself as well as the media keys on the keyboard are working fine, but unfortunately no response from any of the keyboard keys (like characters).

    Kernel: 2.6.36-gentoo-r7
    lirc version: 0.8.7

    Turning on the debug mode of module lirc_mceusb didn't bring anything useful.
    Any idea how to proceed?

    Regards,

    Leon

     
  • jon
    jon
    2011-11-22

    (sorry, I don't lurk around here, and don't necessarily follow every discussion…)

    @crasher2k:  the support for the keyboard and mouse part of the device is baked into the driver.  You don't need to dio anything to "learn" the keys.  It just works.

    @leon:  in ubuntu the newer version of the driver is picked automatically by the kernel.  I don't know how gentoo behaves - you may want to remove any old versions of the module.