lirc_mod_mce install in mythbuntu?

Help
2008-04-03
2013-04-15
1 2 > >> (Page 1 of 2)
  • richard joss
    richard joss
    2008-04-03

    Florian (or anyone)
    Can you help me get my mce keyboard working with mythbuntu 8.04 beta?  I am using kernel 2.6.24.14 and mythtv 0.21.  The mce remote works reasonably ok and the media keys on the keyboard all work.  It is the rest of the keys and the mouse I want to work.  I have followed various guides and this is where I have got to.

    1. I downloaded and untarred lirc_mod_mce0.1.4.tar.bz2

    2.  I downloaded and installed linux-headers-2.6.24.14-generic, linux-source-2.6.24, and lirc-modules-source, which installs as lirc-0.8.3~pre1.

    3. I then copied lirc.dev.h from /usr/src/lirc-0.8.3~pre/lirc_dev/ to the downloaded lirc_mod_mce folder.

    4.  I changed to this folder and ran "make".  I get this output:

    richard@tranquil:~/downloads/lirc_mod_mce$ make
    make -C /lib/modules/2.6.24-14-generic/build SUBDIRS=/home/richard/downloads/lirc_mod_mce modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.24-14-generic'
      Building modules, stage 2.
      MODPOST 1 modules
    WARNING: "lirc_register_plugin" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
    WARNING: "lirc_get_pdata" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
    WARNING: "lirc_unregister_plugin" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
      CC      /home/richard/downloads/lirc_mod_mce/lirc_mod_mce.mod.o
      LD [M]  /home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-14-generic'
    richard@tranquil:~/downloads/lirc_mod_mce$

    Any ideas about what I should try next?

    BTW - if I have to use a patch could you explain how I do that as I have not come across this before!

    Many thanks

    Richard

     
    • richard joss
      richard joss
      2008-04-03

      Sorry - forgot to mention that I also got the LONG errors mentioned in a recent post.  I added

      #ifndef LONG
      #define LONG(x) ((x)/BITS_PER_LONG)
      #endif

      right at the front of the lirc_mod_mce.c file.  Not sure if that is the correct place but it got rid of the first of the error messages on "make" - but still got the ones above.

       
    • Florian Demski
      Florian Demski
      2008-04-03

      Richard,

      the next step would be loading the module.

      At first be sure that the old module gets unloaded:

      As root execute 'lsmod' and check for lirc_mceusb2 (I think that was the name of that module). If it is loaded, unload it with 'rmmod lirc_mceusb2' (or the right name). Next, try to insert the module: 'insmod lirc_mod_mce.ko'. Now, the keyboard should work. I'm a bit in a hurry right now, but I'm pretty sure that there is some tutorial on using kernel modules with your distribution (keywords: /lib/modules, modprobe, modules autoload).

      Florian

       
    • richard joss
      richard joss
      2008-04-03

      Florian - wow what a quick response.  I won't bother you now - perhaps you might check this thread when you have time.

      Just to let you know:  I unloaded the lirc_mceusb2 module ok.  But when I try the insmod statement, it reports "no file or directory".  The lirc_mod_ce.ko file DOES exist (in /lib/modules/2.6.24-14-generic/ubuntu/misc/) which is the nearest directory I could find to put it (The guide I looked at said in the /lib/modules/YOURKERNEL/misc directory - which does not exist).

      I will try by creating this directory and then adding the file.

      Many thanks for your help

      Richard

       
    • richard joss
      richard joss
      2008-04-03

      OK - insmod could still not find the file.  So I tried giving it the actual full location:

      richard@tranquil:~$ sudo insmod /lib/modules/2.6.24-14-generic/misc/lirc_mod_mce.ko
      richard@tranquil:~$

      and it appears to have installed ok:

      richard@tranquil:~$ lsmod | grep lirc
      lirc_mod_mce           17796  0
      lirc_dev               15732  1 lirc_mod_mce
      usbcore               146028  8 lirc_mod_mce,acx,usbhid,usb_storage,libusual,ehci_hcd,uhci_hcd
      richard@tranquil:~$

      I then did:

      richard@tranquil:~$ sudo depmod -a
      richard@tranquil:~$

      and unplugged and replugged the usb connection for the keyboard's beanbag.

      Now the main part of the keyboard is WORKING!  BRILLIANT1

      The only problem now is that the mousepointer and the click keys are still not working.
      Perhaps you can help with that?

      Richard

       
      • Florian Demski
        Florian Demski
        2008-04-03

        Congrats so far.

        When your mouse pointer does not move, unfortunately many possible problems could exist. For a first quick shot, please post the contents of /etc/X11/xorg.cnf.

        Florian

         
    • Florian Demski
      Florian Demski
      2008-04-03

      oops. xorg.conf is the filename --- the o got lost.

       
    • richard joss
      richard joss
      2008-04-03

      Thanks for replying.  Unfortunately the new "automated" construction of xorg.conf gives no details of the actual content of the file.  It is worse than MS Windows and that is saying something.  Have a look at this:

      # xorg.conf (X.Org X Window System server configuration file)
      #
      # This file was generated by dexconf, the Debian X Configuration tool, using
      # values from the debconf database.
      #
      # Edit this file with caution, and see the xorg.conf manual page.
      # (Type "man xorg.conf" at the shell prompt.)
      #
      # This file is automatically updated on xserver-xorg package upgrades *only*
      # if it has not been modified since the last upgrade of the xserver-xorg
      # package.
      #
      # If you have edited this file but would like it to be automatically updated
      # again, run the following command:
      #   sudo dpkg-reconfigure -phigh xserver-xorg

      Section "InputDevice"
          Identifier    "Generic Keyboard"
          Driver        "kbd"
          Option        "XkbRules"    "xorg"
          Option        "XkbModel"    "pc105"
          Option        "XkbLayout"    "gb"
      EndSection

      Section "InputDevice"
          Identifier    "Configured Mouse"
          Driver        "vmmouse"
      EndSection

      Section "Device"
          Identifier    "Configured Video Device"
      EndSection

      Section "Monitor"
          Identifier    "Configured Monitor"
      EndSection

      Section "Screen"
          Identifier    "Default Screen"
          Monitor        "Configured Monitor"
          Device        "Configured Video Device"
      EndSection

      Section "ServerLayout"
          Identifier    "Default Layout"
          Screen        "Default Screen"
      EndSection

      I am going to post on the Ubuntu forum about how to get the actual details.  Perhaps you have some idea of a command line command I could use to get you the info you want?

      Cheers

      Richard

      BTW - this is the output from the relevant section of Xorg.0.log

      (**) Option "XkbModel" "pc105"
      (**) Generic Keyboard: XkbModel: "pc105"
      (**) Option "XkbLayout" "gb"
      (**) Generic Keyboard: XkbLayout: "gb"
      (**) Option "CustomKeycodes" "off"
      (**) Generic Keyboard: CustomKeycodes disabled
      (II) evaluating device (Generic Keyboard)
      (II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
      (II) evaluating device (<default pointer>)
      (II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
      (--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
      (II) <default pointer>: ps2EnableDataReporting: succeeded
      SetClientVersion: 0 9
      SetKbdSettings - type: -1081087188 rate: 30 delay: 500 snumlk: 124

      Not much I' afraid

       
    • richard joss
      richard joss
      2008-04-04

      Florian

      Not sure if you have had time to look at this thread.  I have tried a couple of other things without success.  I have tried different settings for the mouse in xorg.conf:

      In the InputDevice Section I tried:

      Section "InputDevice"
      # generated from default
      Identifier "Mouse0"
      Driver "mouse"
      # Option "Protocol" "auto"
      Option "Device" "/dev/input/mice"
      Option "Emulate3Buttons" "no"
      Option "ZAxisMapping" "4 5"
      EndSection

        Then tried Option "Device" "/dev/psaux" and Option "Device" "/dev/ttyS0"

      Which I have seen before in different xorg.conf files.

      Am I on the right track?  I have posted for help re the xorg.conf file in the UbuntuMythbuntu forums but nothing yet.  Anyway you are much more likely to know what I should be doing.  I haven't found ONE person yet who has successfully got the MCE keyboard working with Ubuntu.  A couple of people have said they have but no one has posted how they did t!

      Cheers

       
    • richard joss
      richard joss
      2008-04-08

      Hi Florian - still no reply from you so i guess you are still very busy.  Just to update you.  I still have a lot of problems with both the lirc_mod_mce driver and the mod_mce driver.  First, if I unload lirc_mceusb2 it means I lose the media keys, and my mce rc6 remote won't work.  If I leave the mceusb2 installed, then the main keyboard does not work, but the meadia keys are OK.  It looks like the two parts cannot work at the same time.  This happens with both drivers.

      Also the mouse/click keys do not work (as I said earlier in this thread).  I now have a full xorg.conf for you to look at:

      Section "ServerLayout"
        Identifier "XFree86 Configured"
        Screen 0 "Screen0" 0 0
      #  InputDevice "Keyboard0" "CoreKeyboard"
        InputDevice "PS/2 Mouse" "CorePointer"
      # InputDevice "USB Mouse" "CorePointer"
      # InputDevice "Serial Mouse" "CorePointer"
      EndSection

      Section "ServerFlags"
        Option "AllowMouseOpenFail" "true"
      EndSection

      Section "Files"
      # Xorg 7.0 font paths

      FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
      FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
      FontPath "/usr/share/fonts/X11/misc:unscaled"
      FontPath "/usr/share/fonts/X11/misc"
      FontPath "/usr/share/fonts/X11/Type1"
      FontPath "/usr/share/fonts/X11/100dpi"
      FontPath "/usr/share/fonts/X11/75dpi"
      EndSection

      Section "Module"

      EndSection

      Section "InputDevice"
        Identifier "Keyboard0"
        Driver "keyboard"
        Option "CoreKeyboard"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "gb"
      #  Option "XKbOptions" ""
      EndSection

      Section "InputDevice"
        Identifier "Serial Mouse"
        Driver "mouse"
        Option  "Protocol" "Microsoft"
        Option  "Device" "/dev/ttyS0"
        Option  "Emulate3Buttons" "false"
        Option  "Emulate3Timeout" "70"
      EndSection

      Section "InputDevice"
        Identifier "PS/2 Mouse"
        Driver "mouse"
        Option "Protocol" "auto"
        Option "Device" "/dev/psaux"
        Option "Emulate3Buttons" "false"
        Option "Emulate3Timeout" "70"
        Option "ZAxisMapping" "4 5"
        Option "Buttons" "5"
      EndSection

      Section "InputDevice"
        Identifier "USB Mouse"
        Driver "mouse"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ExplorerPS/2"
        Option "ZAxisMapping" "4 5"
        Option "Buttons" "5"
      EndSection

      Section "Monitor"
        Identifier "Monitor0"
        VendorName "unknown"
        ModelName "unknown"
        Option "DPMS" "true"
        HorizSync    67.5
        VertRefresh  60

      EndSection

      Section "Device"
        Identifier  "Card0"
        Driver "intel"
        BoardName "unknown"
        Screen 0
      EndSection

      Section "Screen"
        Identifier "Screen0"
        Device "Card0"
        Monitor "Monitor0"
        DefaultColorDepth 24
       
        SubSection "Display"
        Depth 8
        Modes "1920x1080" "1280x1024" "1024x760""800x600"
        EndSubSection
        SubSection "Display"
        Depth 15
        Modes "1920x1080""1280x1024" "1024x760""800x600"
        EndSubSection
        SubSection "Display"
        Depth 16
        Modes "1920x1080""1280x1024" "1024x760" "800x600"
        EndSubSection
        SubSection "Display"
        Depth 24
        Modes "1920x1080""1280x1024" "1024x760" "800x600"
        EndSubSection
        SubSection "Display"
        Depth 32
        Modes "1920x1080""1280x1024" "1024x760""800x600"
        EndSubSection

      EndSection

      Section "Extensions"
        Option "Composite" "Enable"
      EndSection

      You can see that I have tried three different mouse settings but none of them work with the pointer on the mce keyboard.

      By the way - maybe some of the problem is in the lirc_mod_mce "make" compile when I get this output:

      root@tranquil:~/downloads/lirc_mod_mce# make
      make -C /lib/modules/2.6.24-14-generic/build SUBDIRS=/home/richard/downloads/lirc_mod_mce modules
      make[1]: Entering directory `/usr/src/linux-headers-2.6.24-14-generic'
        Building modules, stage 2.
        MODPOST 1 modules
      WARNING: "lirc_register_plugin" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
      WARNING: "lirc_get_pdata" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
      WARNING: "lirc_unregister_plugin" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
      make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-14-generic'

      Not sure why it says "undefined" everywhere.  I do not get this problem when compiling the mod_mce module.

       
    • richard joss
      richard joss
      2008-04-08

      OK Florian got BOTH media keys AND keyboard keys to work at the same time.

      For the rest of the ubuntu/mythbuntu users who might have the same problem - the lirc_mod_mce.ko file needs to be copied to /lib/modules/YOURKERNEL/ubuntu/misc.  Then do "depmod -A".  Then edit /etc/lirc/hardware.conf and under modules, replace whatever is there with "lirc_dev lirc_mod_mce".  Finally make sure that LOAD MODULES is still "true".  Then log out and back in again.

      Florian - however, the mouse and click keys are still not working.  Can you help??

      If anyone is still looking at this thread - could they post the mouse section of their xorg.conf

      Thanks folks.

       
      • Florian Demski
        Florian Demski
        2008-04-08

        Sorry for answering that late.

        I have to take a look at my media center computer where the mouse works fine. Unfortunately, I won't be home until the weekend, so I cannot post my X config until then. I'm not sure if I tried the mouse thing with my laptop, so my laptop's X config is quite useless.

        Florian

         
        • richard joss
          richard joss
          2008-04-08

          Thanks for the reply - I just appreciate your commitment when I know you must have so much else going on.  I'll wait to hear what your xorg.conf file is.

          If we can get this working on mythbuntu, I know there are quite a few people who have tried and given up that we could help.

          RJ

           
    • Florian Demski
      Florian Demski
      2008-04-12

      I checked using mythbuntu and there are a few things that are problematic:

      >Section "InputDevice"
      >Identifier "Configured Mouse"
      >Driver "vmmouse"
      >EndSection

      Is it possible that you are running mythbuntu inside VMware? The vmmouse driver is the driver installed with vmware-modules.

      If so, the host's mouse is used and we don't need to discuss any further.

      I installed mythbuntu also under VMware and had no luck getting even the keyboard properly working. Either my VMware screws up the USB packets or maybe the batteries of my keyboard are dying. I don't know and unfortunately I don't have the time to find out.

      At least I hacked the driver to generate random mouse events upon reception of a packet and it worked.

      For diagnosing the problem and necessary steps, take a look at /proc/bus/input/devices:

      ...
      N: Name="Philips eHome Infrared Transceiver"
      ...
      H: Handlers=kbd mouse1 event3
      ...

      and /proc/bus/input/handlers:
      ...
      N: Number=1 Name=mousedev Minor=32
      ...

      /dev/input
      ...
      crw-r--r--  13, 63   mice
      crw-r--r--  13, 32   mouse0
      crw-r--r--  13, 33   mouse1
      ...

      The USB mouse section of your X config is right for this purpose; though the protocol should be set to automatic.

       
      • richard joss
        richard joss
        2008-04-12

        Florian - Thanks for the clues about diagnosis. OK might be getting somewhere now.  Here is the data:

        1. First - not sure why the mouse driver came up as vmmouse.  I don't have vmware installed.  Anyway - I changed the driver to "mouse" in xorg.conf and it all works fine but no response from the mce keyboard

        2. lsmod | grep lirc shows lirc_mod_mce as being present:

        root@tranquil:~/downloads/lirc_mod_mce# lsmod | grep lirc
        lirc_mod_mce           17796  0
        lirc_dev               15732  1 lirc_mod_mce
        usbcore               146028  8 lirc_mod_mce,acx,usbhid,usb_storage,libusual,ehci_hcd,uhci_hcd
        root@tranquil:~/downloads/lirc_mod_mce#

        3.  The normal lirc_mceusb2 is not installed by virtue of me replacing it in /etc/lirc/hardware.conf with your driver:

        # /etc/lirc/hardware.conf
        #
        #Chosen Remote Control
        REMOTE=
        REMOTE_MODULES="lirc_dev lirc_mod_mce"
        REMOTE_DRIVER=""
        REMOTE_DEVICE="/dev/lirc0"
        REMOTE_LIRCD_CONF="mceusb/lircd.conf.mceusb"
        REMOTE_LIRCD_ARGS=""

        #Chosen IR Transmitter
        TRANSMITTER="None"
        TRANSMITTER_MODULES=""
        TRANSMITTER_DRIVER=""
        TRANSMITTER_DEVICE=""
        TRANSMITTER_LIRCD_CONF=""
        TRANSMITTER_LIRCD_ARGS=""

        #Enable lircd
        START_LIRCD="true"

        #Don't start lircmd even if there seems to be a good config file
        #START_LIRCMD="false"

        #Try to load appropriate kernel modules
        LOAD_MODULES="false"

        # Default configuration files for your hardware if any
        LIRCMD_CONF=""

        #Forcing noninteractive reconfiguration
        #If lirc is to be reconfigured by an external application
        #that doesn't have a debconf frontend available, the noninteractive
        #frontend can be invoked and set to parse REMOTE and TRANSMITTER
        #It will then populate all other variables without any user input
        #If you would like to configure lirc via standard methods, be sure
        #to leave this set to "false"
        FORCE_NONINTERACTIVE_RECONFIGURATION="false"
        START_LIRCMD=""

        Does that look OK to you?  I left the line REMOTE_LIRCD_CONF="mceusb/lircd.conf.mceusb" as per the original file - is that OK?

        4.  cat /proc/bus/input/devices does NOT show anything about the "Philips eHome Infrared Transceiver" :

        root@tranquil:~# sudo cat /proc/bus/input/devices
        I: Bus=0017 Vendor=0001 Product=0001 Version=0100
        N: Name="Macintosh mouse button emulation"
        P: Phys=
        S: Sysfs=/devices/virtual/input/input0
        U: Uniq=
        H: Handlers=mouse0 event0
        B: EV=7
        B: KEY=70000 0 0 0 0 0 0 0 0
        B: REL=3

        I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
        N: Name="AT Translated Set 2 keyboard"
        P: Phys=isa0060/serio0/input0
        S: Sysfs=/devices/platform/i8042/serio0/input/input1
        U: Uniq=
        H: Handlers=kbd event1
        B: EV=120013
        B: KEY=4 2000000 3803078 f800d001 feffffdf ffefffff ffffffff fffffffe
        B: MSC=10
        B: LED=7

        I: Bus=0010 Vendor=001f Product=0001 Version=0100
        N: Name="PC Speaker"
        P: Phys=isa0061/input0
        S: Sysfs=/devices/platform/pcspkr/input/input2
        U: Uniq=
        H: Handlers=kbd event2
        B: EV=40001
        B: SND=6

        I: Bus=0011 Vendor=0002 Product=0001 Version=0000
        N: Name="PS/2 Generic Mouse"
        P: Phys=isa0060/serio1/input0
        S: Sysfs=/devices/platform/i8042/serio1/input/input3
        U: Uniq=
        H: Handlers=mouse1 event3
        B: EV=7
        B: KEY=70000 0 0 0 0 0 0 0 0
        B: REL=3

        I: Bus=0019 Vendor=0000 Product=0002 Version=0000
        N: Name="Power Button (FF)"
        P: Phys=LNXPWRBN/button/input0
        S: Sysfs=/devices/virtual/input/input4
        U: Uniq=
        H: Handlers=kbd event4
        B: EV=3
        B: KEY=100000 0 0 0

        I: Bus=0019 Vendor=0000 Product=0001 Version=0000
        N: Name="Power Button (CM)"
        P: Phys=PNP0C0C/button/input0
        S: Sysfs=/devices/virtual/input/input5
        U: Uniq=
        H: Handlers=kbd event5
        B: EV=3
        B: KEY=100000 0 0 0
        root@tranquil:~#

        I also have an ordinary PS2 mouse and keyboard plugged in as the mce keyboard doesn't work - would that make any difference?

        5. cat /proc/bus/input/handlers gives this output:

        root@tranquil:~/downloads/lirc_mod_mce# sudo cat /proc/bus/input/handlers
        N: Number=0 Name=kbd
        N: Number=1 Name=mousedev Minor=32
        N: Number=2 Name=evdev Minor=64
        root@tranquil:~/downloads/lirc_mod_mce#

        6. Not sure you what you want from "/dev/input" in your post.  Did you mean cat/proc/dev/input?  That just shows:

        root@tranquil:~/downloads/lirc_mod_mce# cat /proc/dev/input
        cat: /proc/dev/input: No such file or directory
        Of course there is a /dev/input directory.  Listing the contents gives:

        root@tranquil:~/downloads/lirc_mod_mce# ls /dev/input
        by-path  event0  event1  event2  event3  event4  event5  mice  mouse0  mouse1
        root@tranquil:~/downloads/lirc_mod_mce#

        7.  As I said to you before - when I did "make" it threw up some error messages.  Is it possible that the compile did not go OK? This is the output::

        root@tranquil:~/downloads/lirc_mod_mce# make
        make -C /lib/modules/2.6.24-15-generic/build SUBDIRS=/home/richard/downloads/lirc_mod_mce modules
        make[1]: Entering directory `/usr/src/linux-headers-2.6.24-15-generic'
          Building modules, stage 2.
          MODPOST 1 modules
        WARNING: "lirc_register_plugin" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
        WARNING: "lirc_get_pdata" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
        WARNING: "lirc_unregister_plugin" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
        make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-15-generic'
        root@tranquil:~/downloads/lirc_mod_mce#

        Hope this helps and that you can advise me of what to do next.

        Thanks again

         
        • Florian Demski
          Florian Demski
          2008-04-12

          > 2. lsmod | grep lirc shows lirc_mod_mce as being present:

          OK

          > 3. The normal lirc_mceusb2 is not installed by virtue of me replacing it in /etc/lirc/hardware.conf with your driver:
          > Does that look OK to you? I left the line REMOTE_LIRCD_CONF="mceusb/lircd.conf.mceusb" as per the original file - is that OK?

          I am not sure as I never used lirc_mod_mce by myself --- I only assembled it because there was some kind of popular demand for it.

           
          > 4. cat /proc/bus/input/devices does NOT show anything about the "Philips eHome Infrared Transceiver" : 

          That's not good.

          Please check the output in /var/log/messages after loading / unloading lirc_mod_mce. It seems as if it's not being registered as an input driver - maybe it couldn't access the hardware or other bad things happened.

          > I also have an ordinary PS2 mouse and keyboard plugged in as the mce keyboard doesn't work - would that make any difference?

          no.

          > 5. cat /proc/bus/input/handlers gives this output:
          > 6. Not sure you what you want from "/dev/input" in your post. Did you mean cat/proc/dev/input? That just shows:
          > by-path event0 event1 event2 event3 event4 event5 mice mouse0 mouse1

          that's only relevant if the driver has been loaded properly. 6 would have been "ls -la /dev/input"

          > 7. As I said to you before - when I did "make" it threw up some error messages. Is it possible that the compile did not go OK? This > is the output::
          > WARNING: "lirc_register_plugin" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
          > WARNING: "lirc_get_pdata" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!
          > WARNING: "lirc_unregister_plugin" [/home/richard/downloads/lirc_mod_mce/lirc_mod_mce.ko] undefined!

          Yes, that's ok. These are warnings and not error messages. This mainly indicates that lirc_mod_mce accesses functions from other modules (in this case some of lirc's modules).

           
          • richard joss
            richard joss
            2008-04-13

            Florian.  I got a better result after shutting down the PC and rebooting.  The Ehome is still not shown in /input/devices but here is a bit more output.

            var/log/messages shows this when i load and unload your driver:

            Apr 13 19:34:03 tranquil kernel: [ 1377.938144] usbcore: deregistering interface driver lirc_mod_mce
            Apr 13 19:36:06 tranquil kernel: [ 1501.415149]
            Apr 13 19:36:06 tranquil kernel: [ 1501.415153] lirc_mod_mce: Input driver for Microsoft MCE 2005 keyboard v0.1.3
            Apr 13 19:36:06 tranquil kernel: [ 1501.415161] lirc_mod_mce: Florian Demski
            Apr 13 19:36:06 tranquil kernel: [ 1501.421858] usbcore: registered new interface driver lirc_mod_mce

            So presumably that is good.

            /dev/input shows this:

            richard@tranquil:~$ ls -la /dev/input
            total 0
            drwxr-xr-x  3 root root    240 2008-04-13 19:13 .
            drwxr-xr-x 13 root root  14400 2008-04-13 19:13 ..
            drwxr-xr-x  2 root root    120 2008-04-13 19:13 by-path
            crw-rw----  1 root root 13, 64 2008-04-13 19:13 event0
            crw-rw----  1 root root 13, 65 2008-04-13 19:13 event1
            crw-rw----  1 root root 13, 66 2008-04-13 19:13 event2
            crw-rw----  1 root root 13, 67 2008-04-13 19:13 event3
            crw-rw----  1 root root 13, 68 2008-04-13 19:13 event4
            crw-rw----  1 root root 13, 69 2008-04-13 19:13 event5
            crw-rw----  1 root root 13, 63 2008-04-13 19:13 mice
            crw-rw----  1 root root 13, 32 2008-04-13 19:13 mouse0
            crw-rw----  1 root root 13, 33 2008-04-13 19:13 mouse1
            richard@tranquil:~$

            Not sure if that is good or bad.

            Then I found that lirc_mceusb2 was still loaded.  So I unloaded that and then unloaded/reloaded your driver. Still no keyboard but this is what /messages showed:

            Apr 13 19:42:11 tranquil kernel: [ 1879.409176] usbcore: deregistering interface driver lirc_mceusb2
            Apr 13 19:42:11 tranquil kernel: [ 1879.415779] lirc_mceusb2[4]: usb remote disconnected
            Apr 13 19:42:40 tranquil kernel: [ 1909.041944] usbcore: deregistering interface driver lirc_mod_mce
            Apr 13 19:42:55 tranquil kernel: [ 1924.931331]
            Apr 13 19:42:55 tranquil kernel: [ 1924.931335] lirc_mod_mce: Input driver for Microsoft MCE 2005 keyboard v0.1.3
            Apr 13 19:42:55 tranquil kernel: [ 1924.931343] lirc_mod_mce: Florian Demski
            Apr 13 19:42:56 tranquil kernel: [  887.590225] usb 4-1.2: reset full speed USB device using ehci_hcd and address 4
            Apr 13 19:42:56 tranquil kernel: [ 1925.310924] lirc_dev: lirc_register_plugin: sample_rate: 0
            Apr 13 19:42:56 tranquil kernel: [ 1925.310932] lirc_dev: lirc_register_plugin: no module owner registered
            Apr 13 19:42:56 tranquil kernel: [ 1925.310943] lirc_mod_mce[4]: out of memory (code=9)
            Apr 13 19:42:56 tranquil kernel: [ 1925.310966] lirc_mod_mce: probe of 4-1.2:1.0 failed with error -12
            Apr 13 19:42:56 tranquil kernel: [ 1925.311000] usbcore: registered new interface driver lirc_mod_mce

            Are these error messages significant?

            Thanks for sticking with me.  I think it is amazing that you wrote the driver but have never used it!!

             
            • Florian Demski
              Florian Demski
              2008-04-13

              > Apr 13 19:42:56 tranquil kernel: [ 1925.310932] lirc_dev: lirc_register_plugin: no module owner registered

              I ran into the same issue with my experiments with mythbuntu. Copy over the original lirc.h and lirc_dev.h from /usr/src/modules/lirc/ and /usr/src/modules/lirc/lirc_dev.h to the source directory of lirc_mod_mce and recompile the module.

              I wrote down the paths from memory so they might be incorrect. At least you should get an impression about what to do.

              Florian

               
              • richard joss
                richard joss
                2008-04-14

                You wrote:
                I ran into the same issue with my experiments with mythbuntu. Copy over the original lirc.h and lirc_dev.h from /usr/src/modules/lirc/ and /usr/src/modules/lirc/lirc_dev.h to the source directory of lirc_mod_mce and recompile the module.

                Ooooops -the only copies of lirc.h and lirc_dev.h are already in the download directory for your driver - which I got by untarring lirc_mocd_mce.bz2

                I have searched the whole hard drive.

                Any ideas?

                 
                • Florian Demski
                  Florian Demski
                  2008-04-14

                  Either get the package lirc-modules-source (with apt-get) or on http://www.lirc.org.

                  Florian

                   
                  • richard joss
                    richard joss
                    2008-04-14

                    Sorry mate - I had reinstalled mythbuntu as a fresh install to try all this again and forgot that step.  I have downloaded and installed lirc-modules, copied over the files as you said and recompiled.  Now I have the mce keyboard working but still no mouse or click keys.

                    However I DO now have something better in the cat /proc/bus/input/devices:

                    I: Bus=0003 Vendor=0609 Product=031d Version=0000
                    N: Name="SMK eHome Infrared Transceiver"
                    P: Phys=/input0
                    S: Sysfs=/devices/pci0000:00/0000:00:1d.7/usb4/4-1/4-1.2/input/input6
                    U: Uniq=
                    H: Handlers=kbd event6
                    B: EV=7
                    B: KEY=7 ff87207a c14057ff febeffdf ffefffff ffffffff fffffffe
                    B: REL=3

                    But I see from the example you sent me that the Handlers statement does not include mouse1 or what ever was in yours.

                    I presume this is significant.

                     
                    • Florian Demski
                      Florian Demski
                      2008-04-14

                      > But I see from the example you sent me that the Handlers statement does not include mouse1 or what ever was in yours.
                      > I presume this is significant.

                      Yes, it is. Are you 100% positive that the right driver is loaded right now? Check /proc/bus/usb/devices (there are some entries "Driver="). What information does /var/log/messages show? What kernel version are you using? (uname -a)

                       
                      • richard joss
                        richard joss
                        2008-04-14

                        Hi Florian - sorry about the late reply.

                        uname -r shows:

                        richard@tranquil:~$ uname -r
                        2.6.24-15-generic
                        richard@tranquil:~$

                        The driver is definitely loaded but with an error message?  var/log/message shows:

                        Apr 14 23:50:33 tranquil kernel: [11014.107808] lirc_mod_mce: Input driver for Microsoft MCE 2005 keyboard v0.1.3
                        Apr 14 23:50:33 tranquil kernel: [11014.107816] lirc_mod_mce: Florian Demski
                        Apr 14 23:50:33 tranquil kernel: [11014.380720] usb 4-1.2: reset full speed USB device using ehci_hcd and address 4
                        Apr 14 23:50:33 tranquil kernel: [11014.473489] lirc_dev: lirc_register_plugin: sample_rate: 0
                        Apr 14 23:50:33 tranquil kernel: [11014.473508] lirc_mod_mce[4]: out of memory (code=9)
                        Apr 14 23:50:33 tranquil kernel: [11014.473524] lirc_mod_mce: probe of 4-1.2:1.0 failed with error -12
                        Apr 14 23:50:33 tranquil kernel: [11014.473554] usbcore: registered new interface driver lirc_mod_mce
                        Apr 14 23:53:41 tranquil kernel: [11214.752016] usb 4-1.1: reset high speed USB device using ehci_hcd and address 3

                        Strange - cat /proc/bus/usb/devices shows:

                        richard@tranquil:~$ cat /proc/bus/usb/devices
                        cat: /proc/bus/usb/devices: No such file or directory
                        richard@tranquil:~$

                        and using file manager to look at the directory /proc/bus/usb shows an empty directory??

                        Richard

                         
                        • richard joss
                          richard joss
                          2008-04-15

                          Florian - /proc/bus/usb was empty because usbfs was not being mounted.  When I mount it, I get the info you want. cat /proc/bususb/devices shows:

                          T:  Bus=04 Lev=02 Prnt=02 Port=01 Cnt=02 Dev#=  4 Spd=12  MxCh= 0
                          D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs=  1
                          P:  Vendor=0609 ProdID=031d Rev= 0.00
                          S:  Manufacturer=SMK
                          S:  Product=eHome Infrared Transceiver
                          S:  SerialNumber=SM002VoS
                          C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
                          I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=lirc_mod_mce
                          E:  Ad=01(O) Atr=03(Int.) MxPS=  16 Ivl=1ms
                          E:  Ad=81(I) Atr=03(Int.) MxPS=  16 Ivl=1ms

                          so there is your driver.

                          I will play about with things now usbfs is mounted and see if that has helped any.  If there is no further post here, then I have made no more progress and will wait to hear if you have any more ideas

                          Thanks

                          Richard

                           
                          • richard joss
                            richard joss
                            2008-04-17

                            Florian- just to let you know that I played about some more yesterday (being retired can be nice!) but got no further.  Booting with usbfs makes no difference.  Here is where I am:

                            1.  If I load lirc_mod_mce on its own, the mce keyboard works fine but no media keys.

                            2.  If I load lirc_mceusb2 on its own I get media keys but no keyboard keys.

                            3.  If I load both together I usually just get the media keys.

                            4.  I can't get the mouse cursor or keys to work at all.

                            4.  I have also tried mod_mce but get the same results.

                            I saw the posts from the guy with the Pinnacle question.  As we have both found - there is no keyboard statement in the handler section in cat /proc/bus/input devices.  I am using the latest kernel

                            I have to leave it up to you as the expert.

                             
1 2 > >> (Page 1 of 2)