Karmic and 0.1.5

  • sabbato753

    Since there seems to be no solution for 0.2.1 until the creator gets back, I wanted to post a solution for all those running Karmic who are looking to get this working.  You can use at least the 0.1.5 driver, which is repaired by the following:

    1) Replace all instances of _plugin with _driver (use vi search/replace)
    2) COMMENT OUT (//) line 1056:   plugin->ioctl = lirc_ioctl;
    3) Line 1111 - REPLACE  input_dev->cdev.dev = &dev->dev;    WITH   input_dev->dev.parent = &dev->dev;

    Copy your own /usr/src/lirc_XXX/drivers/lirc_dev/lirc_dev.h to the compiling directory, type "make" and resume your normal install. 

    Hope this helps some people.  I stumbled on this in parts from random posts on Ubuntu's forum, so thanks to whoever it was that I'm condensing this from to get it working again.