Announce: ir-mce-kbd-decoder-dkms for Ubuntu

Help
jon
2011-11-22
2013-04-15
  • jon
    jon
    2011-11-22

    thanks to Ryan R I have a backported version of the mce keyboard driver from ir-core in Linux 3.1.  I've packaged this for Ubuntu Natty and Oneiric here:

    https://launchpad.net/~jon-hedgerows/+archive/lirc-mod-mce

    add this repository (ppa:jon-hedgerows/lirc-mod-mce) and then install ir-mce-kbd-decoder-dkms

    The keyboard should then work out of the box.  If you have lirc installed, you may need to check that lirc hasn't switched of in-kernel decoding of rc-5 and rc-6 protocols.

    Linux 3.1 (which should be in Ubuntu Precise in April 2012) includes native support the the mce keyboard, so mod-mce has reached the end of the line, and no future versions of Ubuntu should need backports to support the keyboard.

    Jon