MAX user interface performance

Help
Fufutos
2005-02-22
2013-03-27
  • Fufutos
    Fufutos
    2005-02-22

    Hi,

    I am using MAX for a class project.
    The problem is that (compared to magic)
    MAX flickers when I move/zoom the layout
    and becomes kind of unresponsive with the wiring tool.

    Are there any tricks to improve
    the user interface performance ?

    Thanx in advance.

    for reference:
    I am an experienced linux user and my machine has
    Pentium II 350MHz
    Trident Blade3D w/ 8MB

     
    • Lee Tavrow
      Lee Tavrow
      2005-02-28

      Without seeing the flickering or unresposiveness, it is hard for me to diagnose your problem.  Clearly you have an old and slower machine which may simply be the problem.  One thing you can do is edit /etc/X11/XF86config or /etc/X11/XF86config4 files to use 8-bit colormap instead of truecolor (you might already be doing this if you run magic) which might help. 

      There are indeed some hidden variables in MAX to control redisplay performance.  You can try this,

      set LAY_CACHE_STIPPLE_METHOD 0

      Sadly this will crash MAX on some versions of xfree but might work for you.

      Let me know if this helps.

      lee

       
    • Fufutos
      Fufutos
      2005-03-08

      8-bit @ 1024x768 and 16-bit @ 800x600 worked just fine.
      Higher bpp's or resolutions caused slow downs,
      setting LAY_CACHE_STIPPLE_METHOD did not cause
      any perceived improvement in these cases.

      Thanks for the help and for making the tools public domain.
      Needless to say, they are great.