I need some help please

  • Hi,
    i've managed to get mlterm running and i installed the fonts for arabic viewing, but when i try to view arabic in lynx i only get boxes. The command i used to start mlterm was
    `mlterm -E utf8 -w 20 &'
    The command i used for lynx was
    `lynx -display_charset=UTF-8'
    but all i got was boxes.
    I appreciate your help thank you.

    • Hi,

      Would you show me your mlterm/font (or mlterm/aafont if you are using anti-alias)?

      FYI, that's worked at least for me, I have used

      ISO10646_UCS2_1 = 17,-mutt-clearlyu-medium-r-normal--17-12

      for my ~/.mlterm/font and executed lynx as

      LANG=en_US.UTF-8 lynx --display_charset=utf-8 http://www.columbia.edu/kermit/utf8.html

    • actually i don't have a ~/.mlterm/font but i have found a font  file in /usr/local/etc/mlterm/ and all the lines have a # in the beginning. I've tried to use the line u did but it still doesn't work all i get is boxes,
      i'm not sure if the problem is the font but i also tried downloading http://www.arabeyes.org/download/external/vim/10x21.pcf.Z and it wouldn't let me.

    • i think i got it to work,
      i guess the main reason was i didn't convert the 10x20.bdf to 10x20.pcf.gz
      i found that information at http://www.farsiweb.info/howto/xterm/
      i managed to get it to work! however i still do have a question, is there a way to arrange it so that i wouldn't have to type the long command at the command line? by editing a configuration file maybe? that would be very appreciated thank you very much

      • Add

        ISO10646_UCS2_1 = 20,-Misc-Fixed-Medium-R-Normal--20-200-75-75-C-100-ISO10646-1

        to your ~/.mlterm/font and


        to your ~/.mlterm/main.

        That will make mlterm use 20 pixel font by default and use the unicode font you have added to yur system to display whan fontsize = 20.