A question about background

Jacky Jou
  • Jacky Jou
    Jacky Jou

    is the gackground picture function enabled in version 2.6.2?
    I can't change it, and can't set brightness or gammar value when transparent.

    • Jacky Jou
      Jacky Jou

      thanx for reply, but I can't fix it still, I am a newbie, don't know whether do I do right things.
      I just modify the code describes in CVS, change line 903 in x_window.c  as CVS file says, remove the mlterm I compiled earlier, type make clean in sorce code directory, then type ./configure, make, make install. it still has the same problem. What should I do ?

      • Did you supplied --imagelib=[...] option to configure?
        If so, which one did you choosed?

        • Sorry,Use  "--with-imagelib" insted of  "--imagelib".

    • Jacky Jou
      Jacky Jou

      and I lost AntiAlias function now. it works well before I recomplied it. and I can't fix it back .... I remove all stuff and redownload , recompile , reinstall, but no works .... ? how stranger ....

      • Wich did  you mean  your mlterm binary won't run with -A option or anti-aliased texts are not displaied?

    • Jacky Jou
      Jacky Jou

      Thanx for help. Tha aa problem causes of that I forgot to add parameter when configure.
      After some try, if I configure with
      --with-imagelib=imlib --enable-anti-alias
      The picture function still doesn't work, brightness neither.
      --with-imagelib=dgk-pixbuf2 --enable-anti-alias
      picture function looks like it works, but always not found file. brightness value can be modified but no effect.
      Aa function just works fine.
      I read man page, it says wall paper function need imlib right? my imlib version is 1.9.14-5mdk. Is it matter?
      Sincerely thanx.

      • In the case of --with-imagelib=imlib,  didn't configure produce some error messages?

        WIth gdk-pixbuf2, how have you specified picuture file?
        It must be a absolute path or relative to mlterm's working directory (or you can use mlconfig to choose a file using GUI).

        If neither wallpaper nor transparency is used, background color do not be affected by the "brightness" setting.

        The description of man page is wrong and I'll fix it.
        Thanks for reporting.

    • Jacky Jou
      Jacky Jou

      sorry for bothering again.
      I reconfigured my mlterm with --with-imagelib=gdk-pixbuf2 --enable-anti-alias
      then re make and make install
      no error message found. at least not at the end lines of configure and make and make install. (don't know whethere there r some in those flush messages, but if there is error, it should stopped the configure or make action right?)
      here is a screenshot about my problem:
      you can see my configure file main's content.
      when I execute a mlterm. the blackground is black.
      I execute another mlterm from the first terminal. there is a line says file not found in the first terminal.
      then I open the second terminal's mlconfig window. There is nothing in picture option. then I choose from GUI. press apply, the first terminal shows file not found again.
      another problem is about transparent. it works, but if I put brightness parameter in configure file main. the background become color mode. if I change it in mlconfig window. it is no effect, the background is still so bright and become a fixed picture in mlterm. not follows when I move mlterm's window as it did before I modified the brightness option in mlconfig.
      any idea?

    • The message " wall picture file xxx is not found" only means loading of the file has failed somehow.

      When the file is broken(or at least not readable by gdk-pixbuf), this message will also be generated.

      Do other applicaitions that use gdk-pixbuf (like gimp) can open the image file?

      About transparency, I couldn't reproduce your problem.
      Would you checkout latest CVS and try it?

    • Jacky Jou
      Jacky Jou

      Thanx for help. I can see the picture in gimp. and I learned CVS update at the moment ^^. But the problem is still the same. Maybe some problems of my system .... Thanx any way. mlterm is a very nice software ! I'll keeping update my mlterm. maybe my problem will solve in next version ^^
      Thanx again.

    • Jacky Jou
      Jacky Jou

      after install a lot of gtk gdk balabalabala and recompile mlterm. I got a perfact terminal !!!
      now I am so happy with my desktop environment.
      Sorry for so much bother. Thanx for ur patience and thanx mlterm ^^.