#1 MATLAB versions >=7.10 are handled incorrectly

open
nobody
None
5
2012-01-07
2012-01-07
Tomas Kazmar
No

The setup.py script handles MATLAB versions above 7.10 as being lower than 7.3 which results in compilation errors, related to mwSize definition.

There is a patch available in the mailing list using LooseVersion for representing the version number. It would be great if it gets actually applied and a new mlabwrap version released. IMHO, majority of MATLAB installations are over 7.10 and this problem makes the impression that mlabwrap does not work at all.

Discussion