symbol lookup error

saito_kazz
2012-10-01
2013-05-30
  • saito_kazz
    saito_kazz
    2012-10-01

    Hello, everyone
    In the following environments, I have compiled the mjpg-streamer.
    Hard: ARM Cortex-A8
    OS: Ubuntu 12.04

    However, it stops with the following error.
    MJPG Streamer Version: svn rev:
      i: Using V4L2 device:. / dev/video0
      i: Desired Resolution: 640 x 480
      i: Frames Per Second:. 5
      i: Format …………: YUV
      i: JPEG Quality ……: 80
    Adding control for Pan (relative)
    UVCIOC_CTRL_ADD - Error: Invalid argument
    Adding control for Tilt (relative)
    UVCIOC_CTRL_ADD - Error: Invalid argument
    Adding control for Pan Reset
    UVCIOC_CTRL_ADD - Error: Invalid argument
    Adding control for Tilt Reset
    UVCIOC_CTRL_ADD - Error: Invalid argument
    Adding control for Pan / tilt Reset
    UVCIOC_CTRL_ADD - Error: Invalid argument
    Adding control for Focus (absolute)
    UVCIOC_CTRL_ADD - Error: Invalid argument
    mapping control for Pan (relative)
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for Tilt (relative)
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for Pan Reset
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for Tilt Reset
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for Pan / tilt Reset
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for Focus (absolute)
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for LED1 Mode
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for LED1 Frequency
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for Disable video processing
    UVCIOC_CTRL_MAP - Error: Invalid argument
    mapping control for Raw bits per pixel
    UVCIOC_CTRL_MAP - Error: Invalid argument
      o: www-folder-path …: / home / www-data /
      o: HTTP TCP port …..: 8080
      o: username: password:. hoge: hoge
      o: commands ……….: enabled
    mjpg-streamer/mjpg-streamer/mjpg_streamer: symbol lookup error: / usr / lib / input_uvc.so: undefined symbol: jpeg_std_error

    so all of the input output is copied to the / usr / lib /.

    Please give me advice.

     
  • Hello,

    I have faced with the similar problem after upgrading to 12.04.  The solution was moving the -ljpeg to the last compilation argument.

    It was fixed in the experimental baranch, soI guess you have compiled the stable branch.
    Now I have update it also, let me know the results.

    Regards,
    Miklós

     
  • saito_kazz
    saito_kazz
    2012-10-03

    Hello martonmiklos
    thank you for reply.

    On line 29 of the Makefile, I added -ljpeg.
    Is this correct?

    However, the results do not change.

     
  • saito_kazz
    saito_kazz
    2012-10-04

    Thank you for politely explaining
    I did as you say, I was able to run.
    However, the following error is still remained.

    Adding control for Pan (relative)
    UVCIOC_CTRL_ADD - Error: Invalid argument
               .
               .

    In this regard, do you know?