#42 core dump reading a non-existent message

2.9.0 branch
closed-fixed
Colin Tuckley
Client (9)
3
2006-06-26
2003-03-14
Anonymous
No

sometimes, reading and removing the mail from the file
that contains messages encrypted for my nym, appears a
new empty message with no subject that if i try to
delete, mixmaster do a core dump:

buffers.c:385: buf_get: Assertion `n > 0' failed.

i'm using 2.9b40 but i think that this bug is present
in any new release.

Discussion

  • Trek Star
    Trek Star
    2003-03-14

    Logged In: YES
    user_id=365839

    for more information contact me :-)

     
    • priority: 5 --> 3
     
  • Colin Tuckley
    Colin Tuckley
    2006-06-26

    Logged In: YES
    user_id=618735

    This was caused by debug mode being partially enabled. This
    has been fixed in svn in the branch that will become 3.1

     
  • Colin Tuckley
    Colin Tuckley
    2006-06-26

    • status: open --> closed
     
  • Colin Tuckley
    Colin Tuckley
    2006-06-26

    • status: closed --> closed-fixed
     
  • Colin Tuckley
    Colin Tuckley
    2006-06-26

    • assigned_to: nobody --> colintu