There are some odd things with the syncing. Every time I try to sync, it says that the ALDB is old for devices. I scan them, then sync, something else is (sometimes also) stale.

I've also seen this... where the PLM modules thinks the PL is getting reset during lots of activity:


11/27/13 11:01:22 PM [Insteon::BaseController]  Adding controller record to $s_kit_fanhi for $fl_kitchen_fan
cmd = add; data3 = 14; group = 14; is_controller = 1;
11/27/13 11:01:22 PM [Insteon::BaseController]  Adding controller record to $s_kit_fanhi for $kpl_kit1_d
cmd = add; data3 = 14; group = 14; is_controller = 1;
11/27/13 11:01:22 PM [Insteon::BaseController]  Adding controller record to $s_kit_fanhi for $kpl_kit1_a
cmd = add; data3 = 14; group = 14; is_controller = 1;
11/27/13 11:01:22 PM [Insteon_PLM] WARN: PLM unable to complete requested PLM link table update (update/add controller record) for group: 14 and deviceid: 229257
11/27/13 11:01:22 PM [Insteon::ALDB_PLM] WARN: attempt to add link to PLM that already exists! deviceid=229257, group=14, is_controller=1, subaddress=14
11/27/13 11:01:22 PM [Insteon_PLM] WARN: PLM unable to complete requested PLM link table update (update/add controller record) for group: 14 and deviceid: 21cc1e
11/27/13 11:01:22 PM [Insteon::ALDB_PLM] WARN: attempt to add link to PLM that already exists! deviceid=229257, group=14, is_controller=1, subaddress=14
11/27/13 11:01:22 PM [Insteon::ALDB_PLM] WARN: attempt to add link to PLM that already exists! deviceid=229257, group=14, is_controller=1, subaddress=14
11/27/13 11:01:22 PM [Sync all links] Now syncing: $s_back_spot1 (33 of 187)
11/27/13 11:01:22 PM [Sync all links] Now syncing: $s_hall_light (34 of 187)
11/27/13 11:01:22 PM [Insteon::BaseController]  Adding responder record to $sl_foyer1 from $s_hall_light
on_level = 100; cmd = add; data3 = 01; group = 16; is_controller = 0; ramp_rate = 0;
11/27/13 11:01:23 PM [Insteon::BaseObject] The link table for $sl_foyer1 is in sync.
11/27/13 11:01:23 PM [Insteon::ALDB_i2] $sl_foyer1 writing address: 0fcf for device: 223ea7 and group: 16
11/27/13 11:01:23 PM $sl_foyer1 is 100%
11/27/13 11:01:23 PM First Floor: a 1st floor light is now 100%
11/27/13 11:01:23 PM [Insteon_PLM] Detected PLM user reset to factory defaults
11/27/13 11:01:23 PM [Insteon_PLM] Detected PLM user reset to factory defaults
11/27/13 11:01:26 PM [Insteon_PLM] Detected PLM user reset to factory defaults
11/27/13 11:01:26 PM [Insteon_PLM] Detected PLM user reset to factory defaults
11/27/13 11:01:29 PM [Insteon_PLM] Detected PLM user reset to factory defaults
11/27/13 11:01:29 PM [Insteon_PLM] Detected PLM user reset to factory defaults
11/27/13 11:01:31 PM [Insteon_PLM] Detected PLM user reset to factory defaults
11/27/13 11:01:31 PM [Insteon_PLM] Detected PLM user reset to factory defaults
11/27/13 11:01:34 PM Motion sensed in Kitchen.
11/27/13 11:01:34 PM [Insteon::BaseObject] The Link Table Version for $sl_foyer1 has been updated to version number 06
11/27/13 11:01:34 PM [Sync all links] Now syncing: $kpl_uphalln_main (35 of 187)
11/27/13 11:01:34 PM [Sync all links] Now syncing: $kpl_uphalln_a (36 of 187)
11/27/13 11:01:34 PM [Sync all links] Now syncing: $kpl_uphalln_b (37 of 187)
11/27/13 11:01:34 PM [Sync all links] Now syncing: $kpl_uphalln_c (38 of 187)
11/27/13 11:01:34 PM [Sync all links] Now syncing: $kpl_uphalln_d (39 of 187)
11/27/13 11:01:34 PM [Sync all links] Now syncing: $kpl_foyer1_main (40 of 187)
11/27/13 11:01:34 PM [Insteon::BaseController]  Adding controller record to $kpl_foyer1_main for $kpl_uphalln_a
cmd = add; data3 = 01; group = 01; is_controller = 1;
11/27/13 11:01:34 PM [Insteon::BaseController]  Adding controller record to $kpl_foyer1_main for $kpl_mk1_d
cmd = add; data3 = 01; group = 01; is_controller = 1;
11/27/13 11:01:34 PM $sl_foyer1 is 100%
11/27/13 11:01:34 PM First Floor: a 1st floor light is now 100%
11/27/13 11:01:35 PM [Insteon::BaseObject] The link table for $kpl_foyer1_main is in sync.
11/27/13 11:01:35 PM [Insteon::ALDB_i2] $kpl_foyer1_main writing address: 0edf for device: 1cdf19 and group: 01
11/27/13 11:01:35 PM $kpl_foyer1_main is on
11/27/13 11:01:37 PM Motion sensed in Family.
I also haven't changed anything since the last 4-5 syncs... it always finds something to sync. I don't get it.

Perhaps I need to turn on debug and do some real staged tests where I really pay attention to what steps I'm taking.

Lastly, Happy Thanksgiving to all. I don't expect anything to be done right now, but I thought I'd better get the message out anyway. Take care!!

Steve