It looks like you have entered a mismatched pair of { and missing } as part of some "if" statement - perhaps in the code you wrote?
you can move the module out of your code directory and then try a restart.
 
Or maybe you used a brace in your trigger statement? At any rate the answer to your question is the triggers are in triggers.current in your local data directory eg ~/mymisterhousedirectory/data/triggers.current
 
 -----Original Message-----
From: Jens Torell [mailto:jenstorell@yahoo.com]
Sent: November 29, 2008 8:35 PM
To: MisterHouse
Subject: [mh] Messed up trigger crashing MH

I had some time this weekend to play with some more Insteon hardware that I purchased a while back.  Everything installed easily and is working.  Today I strung Christmas lights and plugged them all into an Insteon outlet so I could just turn them on and off automatically everyday.  I have used the web interface to add triggers for my hardware in the past and so I thought I'd do that for this application as well.  It didn't work out this time.  Perhaps I mis-typed something, but now MH won't load.  The errors it spits out are pasted in the message below.

Where are the triggers stored when you add them via the web-interface?  I'm happy with just going in and deleting what I tried to add today because I created an entry in insteon.pl that should take care of what I'm trying to accomplish.

Thanks for your help and Happy Thanksgiving.

Jens Torell



11/29/08 07:17:59 PM Oops1: Scalar found where operator expected at (eval 448) line 3061, near "''$Time_Sunset"
11/29/08 07:17:59 PM Oops1:     (Missing operator before $Time_Sunset?)
11/29/08 07:17:59 PM Oops1: String found where operator expected at (eval 448) line 3061, near "$Time_Sunset''"
11/29/08 07:17:59 PM Oops1:     (Missing operator before ''?)
Error in user code file ./../data/mh_temp.user_code
11/29/08 07:17:59 PM:
11/29/08 07:17:59 PM Oops1:     (Missing operator before ''?)
Global symbol "$benchmark_tickcount" requires explicit package name at (eval 448) line 3101.
Global symbol "$benchmark_tickcount" requires explicit package name at (eval 448) line 3101.
syntax error at (eval 448) line 3103, near ";

}"
Line 3096:  # name=scan insteon link tables type=NoExpire
Line 3097:  if ((time_cron '00 02 * * *') and &trigger_active('scan insteon link tables')) {
Line 3098:      # FYI trigger code: &_get_next_linkscan();
Line 3099:      &trigger_run('scan insteon link tables',1);
Line 3100:  }
Line 3101:     $Benchmark_Members{'triggers_table'} += &get_tickcount - $benchmark_tickcount if $benchmark_tickcount and $Benchmark_Members{on_off_flag};
Line 3102: 
Line 3103:  } # End of triggers_table#-----------------------------------
Line 3104: 
Line 3105:  sub loop_code {
Line 3106: