cross-compiled 1.1.3 not working. what did I miss?

Help
Wyrm
2014-06-22
2014-06-22
  • Wyrm
    Wyrm
    2014-06-22

    Hello,

    I tried cross compiling new 1.1.3 myself and failed. Below is how I did it.
    Please see that I did wrong.

    My target device is a NAS, WD my cloud, equiped with Mindspeed Comcerto
    2000 (M86261G-12) dual-core ARM Cortex-A9 Communication Processor according to this review.

    http://www.smallnetbuilder.com/nas/nas-reviews/32244-wd-my-cloud-reviewed?start=1

    I first got debian wheezy for amd64 and installed it on oracle vm
    virtualbox, and built cross compiling environment by following this,

    https://wiki.debian.org/EmdebianToolchain

    $ apt-get install emdebian-archive-keyring
    $ echo "deb http://ftp.us.debian.org/debian/ squeeze main" >> /etc/apt/sources.list.d/emdebian.list
    $ apt-get install xapt

    Then got dependencies installed,

    $ xapt -a armhf -m libavformat-dev libavutil-dev libavcodec-dev libflac-dev libvorbis-dev libid3tag0-dev libexif-dev libjpeg-dev libsqlite3-dev libogg-dev

    cross-compiler came from here,

    http://gsoc.sitedethib.com/posts/apt-get_install_gcc-4.7-arm-linux-gnueabihf/

    $ dpkg --add-architecture armhf
    $ apt-get update
    $ echo "deb http://emdebian.org/~thibg/repo/ sid main" >> /etc/apt/sources.list
    $ apt-get update
    $ apt-get --no-install-recommends install gcc-4.7-arm-linux-gnueabihf

    next was compiling. I downloaded 1.1.3 source and did,

    $ apt-get install automake autoconf autopoint gettext checkinstall
    $ ./configure --prefix=$HOME/armhf/usr/local --host=arm-unknown-linux-gnueabihf CC=arm-linux-gnueabihf-gcc-4.7
    $ make
    $ checkinstall --no-install

    then I changed architecture to armhf and built a package, moved it to NAS, and,

    $ dpkg -i minidlna_1.1.3-1_armhf.deb

    All the processes went smoothly and I never got stumbled on an error
    message. But when I tried to start minidlna I got nothing, no message
    or anything, just came back to prompt. It won't start.

    So this is the result of struggles of a week. Hope if someone can see
    what went wrong.

    Thanks.

     
    Last edit: Wyrm 2014-06-30