Xbox360 not seeing Server

vmummer
2009-05-08
2013-05-29
  • vmummer
    vmummer
    2009-05-08

    From the debugs below, I can see that the Xbox360 is asking for M-SEARCH, we send a response, then nothing.

    Any suggestions?

    V.

    [2009/05/06 13:25:52] minissdp.c:375: info: SSDP M-SEARCH from 192.168.101.102:7802 ST: urn:schemas-microsoft-com:service:MSContentDirectory:1
    [2009/05/06 13:25:52] minissdp.c:375: info: SSDP M-SEARCH from 192.168.101.102:2566 ST: urn:schemas-upnp-org:service:ContentDirectory:1
    [2009/05/06 13:25:52] minidlna.c:868: debug: HTTP connection from 192.168.101.102:55248
    [2009/05/06 13:25:52] upnphttp.c:527: debug: HTTP REQUEST: GET /rootDesc.xml HTTP/1.1
    User-Agent: Xbox/2.0.7363.0 UPnP/1.0 Xbox/2.0.7363.0
    Connection: Keep-alive
    Host:192.168.101.170

    [2009/05/06 13:25:52] upnphttp.c:848: debug: HTTP RESPONSE: HTTP/1.1 200 OK
    Content-Type: text/xml; charset="utf-8"
    Connection: close
    Content-Length: 2229

    <?xml version="1.0"?>
    <root xmlns="urn:schemas-upnp-org:device-1-0"><specVersion><major>1</major><minor>0</minor></specVersion><device><deviceType>urn:schemas-upnp-org:device:MediaServer:1</deviceType><friendlyName>iDemandTV</friendlyName><manufacturer>Justin Maggard</manufacturer><manufacturerURL>http://www.kernel.org/</manufacturerURL><modelDescription>Fedora *ReadyNAS dev DLNA</modelDescription><modelName>Windows Media Connect compatible (minidlna)</modelName><modelNumber>zp1000</modelNumber><modelURL>http://www.kernel.org/</modelURL><serialNumber>x20090301</serialNumber><UDN>uuid:4d696e69-444c-164e-9d41-000c29dba183</UDN><dlna:X_DLNADOC xmlns:dlna="urn:schemas-dlna-org:device-1-0">DMS-1.50</dlna:X_DLNADOC><presentationURL>http://192.168.101.170/</presentationURL><iconList><icon><mimetype>image/png</mimetype><width>48</width><height>48</height><depth>32</depth><url>/icons/sm.png</url></icon><icon><mimetype>image/png</mimetype><width>120</width><height>120</height><depth>32</depth><url>/icons/lrg.png</url></icon><icon><mimetype>image/jpeg</mimetype><width>48</width><height>48</height><depth>32</depth><url>/icons/sm.jpg</url></icon><icon><mimetype>image/jpeg</mimetype><width>120</width><height>120</height><depth>32</depth><url>/icons/lrg.jpg</url></icon></iconList><serviceList><service><serviceType>urn:schemas-upnp-org:service:ContentDirectory:1</serviceType><serviceId>urn:upnp-org:serviceId:ContentDirectory</serviceId><controlURL>/ctl/ContentDir</controlURL><eventSubURL>/evt/ContentDir</eventSubURL><SCPDURL>/ContentDir.xml</SCPDURL></service><service><serviceType>urn:schemas-upnp-org:service:ConnectionManager:1</serviceType><serviceId>urn:upnp-org:serviceId:ConnectionManager</serviceId><controlURL>/ctl/ConnectionMgr</controlURL><eventSubURL>/evt/ConnectionMgr</eventSubURL><SCPDURL>/ConnectionMgr.xml</SCPDURL></service><service><serviceType>urn:microsoft.com:service:X_MS_MediaReceiverRegistrar:1</serviceType><serviceId>urn:microsoft.com:serviceId:X_MS_MediaReceiverRegistrar</serviceId><controlURL>/ctl/X_MS_MediaReceiverRegistrar</controlURL><eventSubURL>/evt/X_MS_MediaReceiverRegistrar</eventSubURL><SCPDURL>/X_MS_MediaReceiverRegistrar.xml</SCPDURL></service></serviceList></device></root>
    [2009/05/06 13:25:53] minissdp.c:375: info: SSDP M-SEARCH from 192.168.101.102:7802 ST: urn:schemas-microsoft-com:service:MSContentDirectory:1
    [2009/05/06 13:25:53] minissdp.c:375: info: SSDP M-SEARCH from 192.168.101.102:2566 ST: urn:schemas-upnp-org:service:ContentDirectory:1
    [2009/05/06 13:25:53] minissdp.c:375: info: SSDP M-SEARCH from 192.168.101.102:7802 ST: urn:schemas-microsoft-com:service:MSContentDirectory:1
    [2009/05/06 13:25:53] minissdp.c:375: info: SSDP M-SEARCH from 192.168.101.102:2566 ST: urn:schemas-upnp-org:service:ContentDirectory:1

     
    • vmummer
      vmummer
      2009-05-08

      looks like sync up to 1.0.8 fixed it.

      thx

       
    • vmummer
      vmummer
      2009-05-08

      ok so what really fixed was this:

      FriendlyName to be something like 'YourName : 1' ... or the 360 wont recognize it.