Minidlna not working whens start at boot

tuyen
2013-02-26
2013-05-29
  • tuyen
    tuyen
    2013-02-26

    Hello, I've set up minidlna, got it working, and set up to start at boot with the command
    sudo update-rc.d minidlna defaults

    But minidlna would seem to unable to start at boot successfully.  Looking at the log, these are what in it:

    minidlna.c:155: warn: received signal 15, good-bye
    minidlna.c:907: warn: Starting MiniDLNA version 1.0.21 .
    minidlna.c:1002: warn: HTTP listening on port 8200
    minidlna.c:155: warn: received signal 15, good-bye
    minidlna.c:907: warn: Starting MiniDLNA version 1.0.21 .
    minidlna.c:1002: warn: HTTP listening on port 8200
    minidlna.c:155: warn: received signal 15, good-bye

    What is the warning error 155?  And what might be the problem?  Thanks.

     
  • Cecil Coupe
    Cecil Coupe
    2013-02-26

    I had this problem with Ubuntu which doesn't care for the old rc.d setup.  Sig 15 means something else is telling minidlna. If your Linux is using upstart or something similar you need update the minidlna.init to what is required. PITA to debug.

     
  • tuyen
    tuyen
    2013-02-26

    Alright.  I think Sig 15 is the shut down signal to minidlna.  So both my rc.d setup and I also have tried Startup Applications Preferences did not work.  Does anyone know how to check in what log to see why minidlna did not automatic start at boot?

     
  • Genix
    Genix
    2013-03-09

    The same problem for me.
    I can run service minidlna restart manually after every reboot and it works. But doesn't run automatically.

     
  • George
    George
    2013-03-09

    Try moving it as far back in the start up scripts as you can.  As an example my system has a script to start telnet.  I would put the minidlna start after the start of telnet.