Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

annoyance when browsing from my TV

2014-03-06
2014-12-10
  • superfake123
    superfake123
    2014-03-06

    ok so I have in my config

    media_dir=V,/mnt/media/Video/

    and in this directory are a 'Movies' and 'TV' directory... now when I access the server from my TV, the first thing I see is "All videos" and "Folders" and I do not want that. I want the first thing I see to be the Movies and TV directories.. Can this be done somehow?

     
  • Justin Maggard
    Justin Maggard
    2014-03-06

    Try setting:

    root_container=B
    

    in your /etc/minidlna.conf file.

     
  • superfake123
    superfake123
    2014-03-07

    I've tried that. actually I've tried all of those different settings for root_container and it doesn't seem to change anything for me :\

     
  • Justin Maggard
    Justin Maggard
    2014-03-07

    Then your TV must be caching the old results. Make sure you restart minidlna and the TV after changing the setting. If it's still not working, run minidlna in debug mode and look at communications with the TV to see if we can get any clues.

     
  • superfake123
    superfake123
    2014-03-07

    and here is my /etc/minidlna.conf

    port=8200
    media_dir=/mnt/media/Video/
    friendly_name=Media
    db_dir=/var/cache/minidlna
    log_dir=/var/log
    album_art_names=Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg
    inotify=yes
    enable_tivo=no
    strict_dlna=no
    notify_interval=900
    serial=12345678
    model_number=1
    root_container=B

    and not sure if it makes a difference but this is what I'm running

    [root@viral morgan]# uname -a
    Linux viral 3.13.5-1-ARCH #1 SMP PREEMPT Sun Feb 23 00:25:24 CET 2014 x86_64 GNU/Linux

     
  • Justin Maggard
    Justin Maggard
    2014-03-07

    Oh, I see what the problem is. I just checked in a fix into git.

     
  • superfake123
    superfake123
    2014-03-08

    that fixed it. many thanks!!

     
  • fberndt
    fberndt
    2014-04-09

    Hi,

    I would also get rid of "All videos" and "Folders" menu on my samsung TV. However, when I set root_container=B my TV says that there are no video files after rescan. I have compiled the current git-version statically for my pogoplug device.

    Here is the message I got from the debug mode:

    [2014/04/09 13:04:29] minidlna.c:1253: debug: HTTP connection from 192.168.2.103:37319
    [2014/04/09 13:04:29] clients.c:256: debug: Client found in cache. [Samsung Series [CDE]/entry 0]
    [2014/04/09 13:04:29] upnphttp.c:875: debug: HTTP REQUEST: POST /ctl/ContentDir HTTP/1.0
    HOST: 192.168.2.101:8200
    CONTENT-LENGTH: 255
    CONTENT-TYPE: text/xml;charset="utf-8"
    USER-AGENT: DLNADOC/1.50
    SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#X_GetFeatureList"

    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:X_GetFeatureList xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"></u:X_GetFeatureList></s:Body></s:Envelope>

    [2014/04/09 13:04:29] upnphttp.c:655: debug: SOAPAction: urn:schemas-upnp-org:service:ContentDirectory:1#X_GetFeatureList
    [2014/04/09 13:04:29] upnpsoap.c:1893: debug: SoapMethod: X_GetFeatureList
    [2014/04/09 13:04:29] upnpsoap.c:1953: warn: Returning UPnPError 401: Invalid Action
    [2014/04/09 13:04:29] upnphttp.c:1206: debug: HTTP RESPONSE: HTTP/1.1 500 Internal Server Error
    Content-Type: text/xml; charset="utf-8"
    Connection: close
    Content-Length: 398
    Server: 3.5.0-48-generic DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.1.2
    Date: Wed, 09 Apr 2014 11:04:29 GMT
    EXT:

    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>UPnPError</faultstring><detail><UPnPError xmlns="urn:schemas-upnp-org:control-1-0"><errorCode>401</errorCode><errorDescription>Invalid Action</errorDescription></UPnPError></detail></s:Fault></s:Body></s:Envelope>
    [2014/04/09 13:04:29] minidlna.c:1253: debug: HTTP connection from 192.168.2.103:34886
    [2014/04/09 13:04:29] clients.c:256: debug: Client found in cache. [Samsung Series [CDE]/entry 0]
    [2014/04/09 13:04:29] upnphttp.c:875: debug: HTTP REQUEST: POST /ctl/ContentDir HTTP/1.0
    HOST: 192.168.2.101:8200
    CONTENT-LENGTH: 417
    CONTENT-TYPE: text/xml;charset="utf-8"
    USER-AGENT: DLNADOC/1.50
    SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"

    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:Browse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"><ObjectID>V_T</ObjectID><BrowseFlag>BrowseDirectChildren</BrowseFlag><Filter>*</Filter><StartingIndex>0</StartingIndex><RequestedCount>0</RequestedCount><SortCriteria></SortCriteria></u:Browse></s:Body></s:Envelope>

    [2014/04/09 13:04:29] upnphttp.c:655: debug: SOAPAction: urn:schemas-upnp-org:service:ContentDirectory:1#Browse
    [2014/04/09 13:04:29] upnpsoap.c:1893: debug: SoapMethod: Browse
    [2014/04/09 13:04:29] upnpsoap.c:1194: debug: Browsing ContentDirectory:
    * ObjectID: V_T
    * Count: -1
    * StartingIndex: 0
    * BrowseFlag: BrowseDirectChildren
    * Filter: *
    * SortCriteria: (null)
    [2014/04/09 13:04:29] upnpsoap.c:1271: debug: Browse SQL: SELECT o.OBJECT_ID, o.PARENT_ID, o.REF_ID, o.DETAIL_ID, o.CLASS, d.SIZE, d.TITLE, d.DURATION, d.BITRATE, d.SAMPLERATE, d.ARTIST, d.ALBUM, d.GENRE, d.COMMENT, d.CHANNELS, d.TRACK, d.DATE, d.RESOLUTION, d.THUMBNAIL, d.CREATOR, d.DLNA_PN, d.MIME, d.ALBUM_ART, d.DISC from OBJECTS o left join DETAILS d on (d.ID = o.DETAIL_ID) where PARENT_ID = 'V_T' limit 0, -1;
    [2014/04/09 13:04:29] upnpsoap.c:1953: warn: Returning UPnPError 701: No such object error
    [2014/04/09 13:04:29] upnphttp.c:1206: debug: HTTP RESPONSE: HTTP/1.1 500 Internal Server Error
    Content-Type: text/xml; charset="utf-8"
    Connection: close
    Content-Length: 404
    Server: 3.5.0-48-generic DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.1.2
    Date: Wed, 09 Apr 2014 11:04:29 GMT

    Any clues?

    EDIT: Got a workaround. I applied this patch manually and set

    root_container=.
    merge_media_dirs=yes

    in the conf file.

     
    Last edit: fberndt 2014-04-09
  • Dennis  Lopeman
    Dennis Lopeman
    2014-12-10

    Interesting... I don't want to merge them, so maybe I need to answer that NO and then rescan. When I used the root_container=B option, it only showed MUSIC/sound files everywhere... even in the VIDEO and PICTURE media. Thanks I'll try this combo and rescan... It might resolve another post I made earlier.