Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#2 latest cvs does not compile

closed-fixed
None
5
2009-05-11
2009-01-23
Stedy
No

metadata.c: In function ‘GetVideoMetadata’:
metadata.c:645: error: ‘CODEC_ID_WMAPRO’ undeclared (first use in this function)
metadata.c:645: error: (Each undeclared identifier is reported only once
metadata.c:645: error: for each function it appears in.)
metadata.c:653: error: ‘CODEC_ID_PCM_F64LE’ undeclared (first use in this function)
make: *** [metadata.o] Error 1

Don't know if I should report this as a bug.. but I can't make it compile. If I remove those lines. i could compile but get segmentation fault when executing.

Discussion

1 2 > >> (Page 1 of 2)
  • I get a similar error compiling on Debian Etch with gcc version 4.3.3.

    metadata.c: In function âGetVideoMetadataâ:
    metadata.c:653: error: âCODEC_ID_PCM_F64LEâ undeclared (first use in this function)
    metadata.c:653: error: (Each undeclared identifier is reported only once
    metadata.c:653: error: for each function it appears in.)

    The CODEC_ID_* are defined in avcodec.h (part of FFMPEG), my version is 51.50.0, with is the latest 'testing' version available for Debian.

     
  • Justin Maggard
    Justin Maggard
    2009-01-30

    Can you guys try it out now? It's hard to keep up with those ffmpeg libraries. ;)

    Also, the latest code in CVS also has preliminary album art support. Album art must currently conform to the DLNA spec, which is <= 160x160 resolution JPEG. It will currently be checked for in the directory of the music file, and must be named something like cover.jpg or folder.jpg. If you get a change, I'd like to know if your DLNA clients use it.

     
  • Justin Maggard
    Justin Maggard
    2009-01-30

    • assigned_to: nobody --> jmaggard
     
  • Steve Hollis
    Steve Hollis
    2009-01-31

    Some feedback on attempting to compile latest CVS version.

    1) Had to add /usr/local/* paths to Makefile (c. line 16)
    2) Needed to install id3tag libs ('apt-get install libid3tag0-dev')
    3) Ended up with the following error:

    metadata.o: In function `GetVideoMetadata':
    /tmp/minidlna/metadata.c:756: undefined reference to `ff_get_fourcc'
    /tmp/minidlna/metadata.c:761: undefined reference to `ff_get_fourcc'
    /tmp/minidlna/metadata.c:766: undefined reference to `ff_get_fourcc'
    collect2: ld returned 1 exit status

    'ff_get_fourcc' used to be defined in libavutil/common.h (http://cekirdek.pardus.org.tr/~ismail/ffmpeg-docs/ffmpeg-r_2libavutil_2common_8h-source.html#l00212), but doesn't appear in my version of libavutil (49.14).

    Hope this helps! Look forward to getting it working.

    Steve

     
  • Justin Maggard
    Justin Maggard
    2009-02-03

    Okay, I didn't know that function wasn't there for all version of ffmpeg. I replaced that function with an interal one, so it should compile for you now.

    You can also now specify multiple media directories, and even limit them to a certain content type.

     
  • Steve Hollis
    Steve Hollis
    2009-02-03

    Justin - latest CVS compiles first time (after adding /usr/local/* to Makefile), thanks!

    However, the scanning process just hangs at Scanning 0 Files. The database is created, but nothing else happens. Sorry - I know this isn't much information... let me know if there's any other info I can give you.

    Thanks,
    Steve

     
  • Stedy
    Stedy
    2009-02-03

    latest CVS compiles

    I have also tested album art support on my Sony Bravia, its seems to work.
    As a test I replaced the album.jpg picture (160x160) with a picture sized 2592x1944 and my televison did manage to show album art of that size.
    So in my case the limit 160x160 is in minidlna, pictures biger than that are will note be placed in ALBUM_ART in /tmp/files.db

     
  • Stedy
    Stedy
    2009-02-03

    • status: open --> open-fixed
     
  • Steve Hollis
    Steve Hollis
    2009-02-03

    Update: scanning problem not universal, as it works fine on a smaller sub-tree of my music folder. Must be something in the root that is bothering it. Will investigate.

    Album art is working on my Sony Bravia 40W4500. However, annoyingly, my 'Folder.jpg' are 200x200 (ripped mainly in Windows Media Player) and therefore are not included. As a workaround, I added 'AlbumArtSmall.jpg' (another WMP file, 75x75) to the list of allowed files, however I'll probably remove the size restriction if the Bravia's don't mind the file size. Could this be made a config option, --album-art-strict or something?

     
  • Steve Hollis
    Steve Hollis
    2009-02-03

    Update on the scanning problem: program hangs if media files found in the root of the media dir.

    Code to reproduce:

    minidlna.conf
    #
    port=5555
    media_dir=A,/tmp/music/
    #

    mkdir /tmp/music
    cp song.mp3 /tmp/music
    (/path/to/)minidlna -d -f minidlna.conf
    (hangs on Scanning...)
    rm -rf /tmp/files.db
    mkdir /tmp/music/subfolder
    mv /tmp/music/song.mp3 /tmp/music/subfolder/song.mp3
    (/path/to/)minidlna -d -f minidlna.conf
    (works as expected)

    In short, having media files in the root of media_dir (i.e. not in subfolders), causes the scanner to hang. Only tested this with an mp3.

     
  • Justin Maggard
    Justin Maggard
    2009-02-04

    Thanks for tracking that down. It should be fixed in the latest CVS.

    I also went ahead and relaxed the restrictions for album art resolution. Looks like it's actually a recommendation in the DLNA spec, and not an actual requirement for DLNA compliance, so it should be fairly safe.

     
  • Stedy
    Stedy
    2009-02-04

    sorry that i keep naging at you :)
    CVS 04.feb.2009 gives this error:

    metadata.c:44: error: expected identifier or ‘(’ before ‘<<’ token
    metadata.c: In function ‘modifyString’:
    metadata.c:65: error: expected declaration specifiers before ‘==’ token
    metadata.c:67:1: warning: "FLAG_ARTIST" redefined
    metadata.c:45:1: warning: this is the location of the previous definition
    metadata.c:121: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token
    metadata.c:127: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token
    metadata.c:150: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token
    metadata.c:330: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token
    metadata.c:338: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token
    metadata.c:517: error: storage class specified for parameter ‘aac_object_type_t’
    metadata.c:521: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token
    metadata.c:945: error: old-style parameter declarations in prototyped function definition
    metadata.c:945: error: expected ‘{’ at end of input
    make: *** [metadata.o] Error 1

     
  • Stedy
    Stedy
    2009-02-04

    • status: open-fixed --> open
     
  • Looks to me like CVS conflict markers. If you do a cvs update, you'll probably see a 'C' before metadata.c. It should be safe to just remove any files with a 'C' next to them and do CVS update to get a clean version.

     
  • Stedy
    Stedy
    2009-02-04

    • status: open --> open-fixed
     
  • Stedy
    Stedy
    2009-02-04

    oh... its OK now. maybe I was to fast on the trigger.
    thx nobody.

     
  • Stedy
    Stedy
    2009-02-06

    • status: open-fixed --> closed-fixed
     
  • Stedy
    Stedy
    2009-02-11

    CVS 04.feb.2009 gives this error:

    ./genconfig.sh
    gcc -Wall -g -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/ffmpeg -I/usr/include/libavutil -I/usr/include/libavcodec -I/usr/include/libavformat -I/usr/include/ffmpeg/libavutil -I/usr/include/ffmpeg/libavcodec -I/usr/include/ffmpeg/libavformat -c -o minidlna.o minidlna.c
    In file included from minidlna.c:32:
    upnpglobalvars.h:89: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘updateID’
    minidlna.c: In function ‘main’:
    minidlna.c:729: error: ‘updateID’ undeclared (first use in this function)
    minidlna.c:729: error: (Each undeclared identifier is reported only once
    minidlna.c:729: error: for each function it appears in.)
    make: *** [minidlna.o] Error 1

     
  • Stedy
    Stedy
    2009-02-11

    • status: closed-fixed --> open
     
  • Stedy
    Stedy
    2009-02-11

    the date for the latest post should be:
    CVS 11.feb.2009

     
  • Justin Maggard
    Justin Maggard
    2009-02-11

    Please try it now. Looks like it's better to include linux/types.h to define __u32.

     
  • Stedy
    Stedy
    2009-02-11

    It's OK now.

     
  • Stedy
    Stedy
    2009-02-11

    • status: open --> closed-fixed
     
  • Stedy
    Stedy
    2009-02-15

    CVS 16.feb.2009

    avformat -c -o albumart.o albumart.c
    albumart.c:29:16: error: gd.h: No such file or directory
    albumart.c: In function ‘save_resized_album_art’:
    albumart.c:66: error: ‘gdImagePtr’ undeclared (first use in this function)
    albumart.c:66: error: (Each undeclared identifier is reported only once
    albumart.c:66: error: for each function it appears in.)
    albumart.c:66: error: expected ‘;’ before ‘imsrc’
    albumart.c:80: error: ‘imsrc’ undeclared (first use in this function)
    albumart.c:80: warning: implicit declaration of function ‘gdImageCreateFromJpeg’
    albumart.c:82: warning: implicit declaration of function ‘gdImageCreateFromJpegPtr’
    albumart.c:100: error: ‘imdst’ undeclared (first use in this function)
    albumart.c:100: warning: implicit declaration of function ‘gdImageCreateTrueColor’
    albumart.c:103: warning: implicit declaration of function ‘gdImageDestroy’
    albumart.c:110: warning: implicit declaration of function ‘gdImageCopyResampled’
    albumart.c:112: warning: implicit declaration of function ‘gdImageJpeg’
    make: *** [albumart.o] Error 1

     
  • Stedy
    Stedy
    2009-02-15

    • status: closed-fixed --> open
     
1 2 > >> (Page 1 of 2)