Announcing the release of mingwrt-4.0-rc-4 and w32api-4.0-rc-4

I am pleased to announce release candidate 4 for the up and coming mingwrt-4.0
and w32api-4.0 release. The process to test is convoluted and messy in order
to keep related package data for mingw-get in sync. However, we are
releasing this candidate package so that you may be involved with
testing it.

First and foremost, you must install Keith's GUI alpha release of mingw-get.
You can get that package from his files link[1] and then extract it to your
MinGW folder, e.g. C:\MinGW.

  • If you've installed previous test releases be sure to execute the
    ``test-wsl-rc.bat off'' command before proceeding with the installation.

  • Release candidate 4 fixes a few typo issues, adds the missing _tcsclen define
    in tchar.h and one major issue when wchar.h was included before sys/stat.h that
    left some inlined code undefined.

Once you have that package in place then do the update command[2] to
download the latest package meta data. Then you use the install
command[3] to install the wsl_rc package. This will install a script
that you can then use to install the release candidate[4]. When
you're finished and wish to have your original
installation back you use the script to remove the release candidate[5].

CAUTION: This version has an ABI breakage. Read the NEWS file[6][7] in order
to get a feel for what has changed.

[1] http://sourceforge.net/projects/keithmarshall.u/files/mingw-get/mingw-get-0.6-mingw32-hg-20130129-1-bxz.zip/download

[2] mingw-get update

[3] mingw-get install mingw32-wsl_rc

[4] /mingw/bin/test-wsl-rc.bat on

[5] /mingw/bin/test-wsl-rc.bat off

[6] https://sourceforge.net/p/mingw/mingw-org-wsl/ci/4.0-rc1/tree/NEWS

[7] /mingw/share/doc/mingwrt/NEWS or /mingw/share/doc/w32api/NEWS

NOTE: You must use mingw32 on the install command, the shortened aliases will
disappear as we get closer to providing 64bit packages.

Posted by Earnie Boyd 2013-07-01