On 9 September 2013 10:36, Sebastian Schuberth wrote:
On 09.09.2013 08:38, GeorgeGillan wrote:

> 'mingw-developer-toolkit' version 2013072300 gave 8 pop-ups that looked like
> 4 errors, all in the same format.
> "Cannot get 'tarname' for non-release element <<<unknown>>>"
> "gettext-0.18.3.1-1-mingw32-bin.tar.lzma: requires...
> gcc-core-4.8.1-1-mingw32-dll.tar.lzma: unresolved dependency (type 'eq')
> gcc-core-4.8.1-1-mingw32-dll.tar.lzma: cannot identify any providing
> package"

Same here, I get:

Confirmed here too.
 
mingw-get.exe: *** ERROR *** internal package specification error
mingw-get.exe: *** ERROR *** can't get 'tarname' for non-release element <<<unknown>>>

Not a particularly useful diagnostic, I agree.  I'll have a look, and
see if I can make it more helpful; right now, it is just noise.

mingw-get.exe: *** ERROR *** please report this to the package maintainer
mingw-get.exe: *** ERROR *** gettext-0.18.3.1-1-mingw32-bin.tar.lzma: requires...
mingw-get.exe: *** ERROR *** gcc-core-4.8.1-1-mingw32-dll.tar.lzma: unresolved dependency (type 'eq')
mingw-get.exe: *** ERROR *** gcc-core-4.8.1-1-mingw32-dll.tar.lzma: cannot identify any providing package
mingw-get.exe: *** ERROR *** please report this to the package maintainer

This is the real problem; gcc-core-4.8.1-1-mingw32-dll.tar.lzma is
required by gettext-0.18.3.1-1-mingw32-bin.tar.lzma, but there is no
such package.  I guess the correctly specified requirement should be on
mingw32-libgcc-*-mingw32-dll-1.tar
 
$ mingw-get install mingw32-libiconv
mingw-get.exe: *** ERROR *** internal package specification error
mingw-get.exe: *** ERROR *** can't get 'tarname' for non-release element <<<unknown>>>
mingw-get.exe: *** ERROR *** please report this to the package maintainer
mingw-get.exe: *** ERROR *** libiconv-1.14-3-mingw32-bin.tar.lzma: requires...
mingw-get.exe: *** ERROR *** gcc-core-4.8.1-1-mingw32-dll.tar.lzma: unresolved dependency (type 'eq')
mingw-get.exe: *** ERROR *** gcc-core-4.8.1-1-mingw32-dll.tar.lzma: cannot identify any providing package
mingw-get.exe: *** ERROR *** please report this to the package maintainer

 Same problem: libiconv-1.14-3 also specifies requirements, repeated for
several of its components, on this same non-existent gcc-core DLL.

It is unfortunate that this situation has arisen.  It is human error,
for which we can only apologize; we all make mistakes.  It is also
disappointing that it is taking so long to get it fixed; we all have
other priorities, besides voluntary work on MinGW.

Earnie, I did an "hg pull -u" on mingw-dist, this morning, followed by a
"make".  My previously up to date sandbox registered a bunch of remade
catalogue files.  Did you, perhaps, push the source modifications before
you remade the targets, and neglect to push the updated issue.log files?
Were the updated targets published to FRS?

--
Regards,
Keith.