Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#943 cpp -dM segfaults

OTHER
closed
nobody
gcc (462)
works-for-me
User_Environment_Issue
2013-01-31
2006-05-21
Hin-Tak Leung
No

I want to know what internal macros are defined,
so I did cpp -dM (this works on unices, with a ctrl-D):

cpp -dM
cc1.exe: stdout: Invalid argument
cc1.exe: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://www.mingw.org/bugs.shtml> for instructions.

"cpp -dM <randomfile>" works as intended, so this is not
a serious problem, just unexpected. with Mingw 5.0.2
on wine.

Discussion

  • Danny Smith
    Danny Smith
    2006-05-21

    Logged In: YES
    user_id=11494

    I can't reproduce the segfault on windows XP from a cmd
    box. It may be wine bug.
    On windows, nothing happens with input fron stdin until I
    enter Ctrl-Z, the DOS end of file marker. Then I get a
    listing of builtin defines.

    Can you reproduce on windows box?

    Danny

     
  • Hin-Tak Leung
    Hin-Tak Leung
    2006-05-21

    Logged In: YES
    user_id=506848

    I am willing to take that as a wine bug. also encountered
    some difference elsewhere as well.
    (compiled something under wine, the binary doesn't work
    under wine but works under win2k). Sorry, don't have
    software-install privileges to some of the windows boxes
    I have access to so can't install mingw on windows...
    (and I haven't run windows at home for years).

     
  • Danny Smith
    Danny Smith
    2008-06-14

    • status: open --> closed-works-for-me
     
  • Hin-Tak Leung
    Hin-Tak Leung
    2008-06-14

    Logged In: YES
    user_id=506848
    Originator: YES

    closed it a few months ago on wine's bugzilla.

    http://bugs.winehq.org/show_bug.cgi?id=5271

    Sorry, and thanks for looking at this.

     
  • Earnie Boyd
    Earnie Boyd
    2013-01-31

    • labels: --> gcc
    • status: closed-works-for-me --> closed
    • resolution: --> works-for-me
    • category: --> User_Environment_Issue
    • milestone: --> OTHER