#847 MSYS shell can not be started on Windows XP Professional x64

MSYS
closed
Earnie Boyd
None
duplicate
Duplicate
2013-01-31
2005-10-23
Tuomo Latto
No

MSYS shell can not be started on Windows XP
Professional x64. Looking a bit further, rxvt reports
--->
C:\msys\1.0\bin\rxvt.exe: *** fork: can't reserve memory
for stack 0x480000 - 0x680000, Win32 error 0
0 [main] rxvt 2928 sync_with_child: child
1440(0x2CC) died before initialization with status code
0x1
43 [main] rxvt 2928 sync_with_child: *** child state
waiting for longjmp
rxvt: can't fork
rxvt: aborting
<---

I've added a description of some sort of workaround on
MinGWiki (mSysShell, FAQ). For a better workaround,
the included patch seems to do the trick. It has not been
tested on 32-bit XP/2K/NT (yet), but it probably works. I
don't know about 9x/Me either.

I would, however, like to see a fix to make this sort of
trickery obsolete. (And no, always running 32-bit
command prompt on your 64-bit OS isn't a fix.)

Of course, an ability to *create* 64-bit executables would
be even better..

Discussion

  • Tuomo Latto
    Tuomo Latto
    2005-10-23

     
    Attachments
  • Tuomo Latto
    Tuomo Latto
    2005-10-23

    Logged In: YES
    user_id=1355547

    Forgot to say that sh exhibits the same symptoms if run in C:
    \MSYS\1.0\bin:
    --->
    C:\msys\1.0\bin>sh
    sh-2.04$ ls
    C:\msys\1.0\bin\sh.exe: *** fork: can't reserve memory for
    stack 0x480000 - 0x680000, Win32 error 0
    0 [main] sh 260 sync_with_child: child 264(0x304) died
    before initialization with status code 0x1
    69 [main] sh 260 sync_with_child: *** child state waiting
    for longjmp
    sh: fork: Resource temporarily unavailable
    sh-2.04$ exit
    exit
    <---

    With 32-bit command prompt it works:
    --->
    C:\msys\1.0\bin>c:\WIN64\SysWOW64\cmd
    Microsoft Windows [Version 5.2.3790]
    (C) Copyright 1985-2003 Microsoft Corp.

    C:\msys\1.0\bin>sh
    sh-2.04$ ls ..
    bin etc include lib man msys.bat msys.ico
    uninstall
    doc home info m.ico mingw msys.bat.orig share
    sh-2.04$ exit
    exit

    C:\msys\1.0\bin>exit
    <---

     
  • Logged In: YES
    user_id=643949

    I have very similar problem. My processor is 64 bit (AMD)
    but Windows XP is 32.

    I've read that it is caused by Norton Antivirus.
    Can someone confirm that he was able to resolve this issue
    by turning Norton Avtivirus protection off?

    Thanks

     
  • Tuomo Latto
    Tuomo Latto
    2005-10-28

    Logged In: YES
    user_id=1355547

    Umm.. Similar meaning that you experience a different error
    on a different OS that is likely to be caused by a different
    thing?

    FWIW, I don't have that problem as I'm running Avast! - on
    both 32-bit and 64-bit versions.

     
  • Logged In: YES
    user_id=643949

    No. Similar meaning almost identical

    Here are the messages I get

    0 [main] sh 65068 sync_with_child: child 62744(0x714)
    died before initialization with status code 0xC0000142
    63 [main] sh 65068 sync_with_child: *** child state
    waiting for longjmp
    ./configure: fork: Resource temporarily unavailable
    ./configure: fork: Permission denied
    ./configure: fork: Permission denied
    ./configure: fork: Permission denied
    ./configure: fork: Permission denied
    ./configure: fork: Permission denied
    0 [main] sh 65928 sync_with_child: child 65848(0x6DC)
    died before initialization with status code 0xC0000142
    240 [main] sh 65928 sync_with_child: *** child state
    waiting for longjmp
    ./configure: fork: Resource temporarily unavailable

    and BTW it is not Norton or Symantec antivirus. I still have
    the problem after completely removing it.

     
  • Earnie Boyd
    Earnie Boyd
    2005-11-07

    • status: open --> closed
     
  • Earnie Boyd
    Earnie Boyd
    2005-11-07

    • milestone: 507559 --> 507559
    • status: closed --> closed
     
  • Earnie Boyd
    Earnie Boyd
    2005-11-07

    • milestone: 507559 -->
    • status: closed --> closed-duplicate
     
  • Earnie Boyd
    Earnie Boyd
    2005-11-07

    • milestone: --> Known_bugs
     
  • Earnie Boyd
    Earnie Boyd
    2005-11-07

    Logged In: YES
    user_id=15438

    Please submit your patch to the patch tracker.

     
  • Tuomo Latto
    Tuomo Latto
    2005-11-17

    Logged In: YES
    user_id=1355547

    Forgot to mention here that the patch tracker
    id is 1351029. It has been there since 2005-11-08 00:20.

     
  • Earnie Boyd
    Earnie Boyd
    2013-01-31

    • labels: MSYS -->
    • status: closed-duplicate --> closed
    • resolution: --> duplicate
    • category: --> Duplicate
    • milestone: Known_bugs --> MSYS