#791 Msys hangs/crashes when tab is pressed

MSYS
closed
Earnie Boyd
None
none
Known_Feature
2013-01-30
2005-06-18
Jeff
No

When I open an Msys shell and press tab, the shell
hangs and begins core dumping. It does this everytime,
so it is easy to reproduce. Environment described below:

Windows XP Home SP2
AMD 64 Processor
1GB RAM
Logitech Wireless Keyboard

Discussion

  • Earnie Boyd
    Earnie Boyd
    2005-06-18

    • milestone: --> Known_bugs
    • status: open --> closed-remind
     
  • Earnie Boyd
    Earnie Boyd
    2005-06-18

    Logged In: YES
    user_id=15438

    Well then don't do that. ;t

    Caused by tab completion. I've never seen the coredump; I
    see the loop complete but it may depend on the PATH
    variable. This is bash related and not really MSYS. You
    can turn off tab completion if you find yourself hitting tab
    as the first character of the line frequently. Tab
    completion before a space will try to complete an executable
    file name and when tab completion is executing as the first
    character of the line, it stores every executable
    path/to/file found in the list of paths in PATH in a hash
    table in local memory.

    A team of developers is looking at upgrading MSYS bash to a
    newer versoin of bash.

    Earnie

     
  • Earnie Boyd
    Earnie Boyd
    2013-01-30

    • labels: MSYS -->
    • status: closed-remind --> closed
    • resolution: --> none
    • category: --> Known_Feature
    • milestone: Known_bugs --> MSYS